Нету звука в наушниках. (С передней панели)

Руководства, вопросы, обсуждения
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
Аватара пользователя

Автор темы
LevonX
Сообщения: 2
Зарегистрирован: 16 июн 2017, 09:01
Благодарил (а): 1 раз

Нету звука в наушниках. (С передней панели)

Сообщение LevonX » 16 июн 2017, 09:05

Здравствуйте, уважаемые любители Linux Lint!
Помогите, пожалуйста, у меня странная проблема, решить самостоятельно не удается (Мучаюсь уже 3 месяца :) ).

Проблема такая вот, раньше стояла Ubuntu 14.04 x32, проблем никаких не было. Ну как и все любящие новинок, решил я себе обновить систему до 16.04, но решил поставить x64, вот поставил вроде бы все нормально, но через некоторое время заметил проблему, а именно, почему-то звука в наушниках вообще нету.
Ну и я пошел лазить в настройки alsa (~$ alsamixer).
Обнаружил, что headphon стоит MM (Mute), а что же мне делать, я снял MM поднял до конца и вуаля, работает!
Но, что самое интересное, то что после перезагрузки все возвращается на свои места(То есть, опять нету звука в наушниках).
Через несколько месяцев поставил Linux Mint 18.1, и та же проблема здесь.
PS: и в PavControl так же, сбрасываются настройки.

Что мне делать? Как быть? Может есть знающие люди, которым все же не лень будет помогать мне, отзовитесь, пожалуйста.

Немного технической информации:
Kernel: 4.4.0-79-generic x86_64 (64 bit)
Desktop: Cinnamon 3.2.7
Distro: Linux Mint 18.1 Serena
Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)

Решение Chocobo » 16 июн 2017, 09:16
LevonX, в alsamixer'e правей есть еще такой пункт как Auto-Mute Mode

И вот здесь еще можно почитать по смене дефолтного канала на уровне пульсы - помогите настроить выход на наушники

Перейти к ответу ➙
Последний раз редактировалось пользователем 1 Dja; всего редактировалось раз: 27
Причина: BB-codes

Аватара пользователя

Chocobo
Сообщения: 5977
Зарегистрирован: 27 авг 2016, 19:57
Решено: 136
Откуда: НН
Благодарил (а): 425 раз
Поблагодарили: 1550 раз

Нету звука в наушниках. (С передней панели)

Сообщение Chocobo » 16 июн 2017, 09:16

LevonX, в alsamixer'e правей есть еще такой пункт как Auto-Mute Mode

И вот здесь еще можно почитать по смене дефолтного канала на уровне пульсы - помогите настроить выход на наушники

Аватара пользователя

Автор темы
LevonX
Сообщения: 2
Зарегистрирован: 16 июн 2017, 09:01
Благодарил (а): 1 раз

Нету звука в наушниках. (С передней панели)

Сообщение LevonX » 16 июн 2017, 09:26

Chocobo, Спасибо Вам большое, все работает!
Добавил в default.pa строчку
set-sink-port 0 analog-output-headphones
и все заработало :)
Решение такое простое, а мучился столько.
Последний раз редактировалось пользователем 1 Dja; всего редактировалось раз: 27
Причина: BB-codes

Вернуться в «Параметры и оптимизация»