Восстановление GRUB

Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

_R-S_
Сообщения: 139
Зарегистрирован: 01 фев 2018, 17:36
Благодарил (а): 41 раз

Восстановление GRUB

Сообщение _R-S_ » 28 фев 2019, 17:42

Проверил загрузку UEFI при включение, клавиши Ф9 и пр. не срабатывают, войти можно только из меню граба выбрав сетап. После этого комп отключается от питания (со странным щелчком), затем включается и загружается в уефи.
Кстати, меня посетила мысль, т.к., вроде бы, для UEFI систем не нужно устанавливать bios-grub, он у них в разделе boot/uefi и поэтому его не ставили, может проблема в этом, что граб некорректно устанавливается cразделом boot/uefi?

Аватара пользователя

S.A.
Сообщения: 147
Зарегистрирован: 26 апр 2017, 06:53
Благодарил (а): 7 раз
Поблагодарили: 27 раз

Восстановление GRUB

Сообщение S.A. » 01 мар 2019, 06:25

_R-S_ писал(а):
28 фев 2019, 17:17
Как ребенку теперь еще его дистр вторым поставить, чтоб ничего не сломать)
Запустить установку второй системы без установки загрузчика (запустить установку с ключом ubiquity -b. После установки загрузиться в первую систему и обновить GRUB.


_R-S_
Сообщения: 139
Зарегистрирован: 01 фев 2018, 17:36
Благодарил (а): 41 раз

Восстановление GRUB

Сообщение _R-S_ » 01 мар 2019, 12:10

S.A. писал(а):
01 мар 2019, 06:25
запустить установку с ключом ubiquity -b
Раньше просто обновлял граб, но, это я раза три ставил доп. системы всего. Можно подробнее по ключу?

Аватара пользователя

Unborn
Сообщения: 1778
Зарегистрирован: 03 сен 2016, 10:36
Решено: 24
Благодарил (а): 4 раза
Поблагодарили: 253 раза

Восстановление GRUB

Сообщение Unborn » 01 мар 2019, 12:58

_R-S_ писал(а):
28 фев 2019, 17:42
Кстати, меня посетила мысль, т.к., вроде бы, для UEFI систем не нужно устанавливать bios-grub, он у них в разделе boot/uefi и поэтому его не ставили, может проблема в этом, что граб некорректно устанавливается cразделом boot/uefi?
Просто прочитайте инструкцию по установке на УЕФИ и не парьте мозги ни себе ни людям.
Точку монтирования для esp раздела /boot/efi нужно было задать и всё. Как там у вас сейчас с разметкой и разделами - х.з.
LMDE3 использует каталог linuxmint для установки efi - загрузчика. Залупубунты, к которым и Минт относится, каталог ubuntu. Дебиан - каталог debian. И друг другу они никак не мешают.
S.A. писал(а):
28 фев 2019, 16:25
Если есть возможность, то попробовать сбросить BIOS (отключить АКБ и вытащить батарейку из материнки).
В УЕФИ ничего, кроме даты-времени не сбрасывается, ибо NVRAM.


_R-S_
Сообщения: 139
Зарегистрирован: 01 фев 2018, 17:36
Благодарил (а): 41 раз

Восстановление GRUB

Сообщение _R-S_ » 01 мар 2019, 13:08

Unborn писал(а):
01 мар 2019, 12:58
Просто прочитайте инструкцию по установке на УЕФИ и не парьте мозги ни себе ни людям.
Точку монтирования для esp раздела /boot/efi нужно было задать и всё. Как там у вас сейчас с разметкой и разделами - х.з.
с чего вы взяли, что esp /boot/efi не был создан?

Аватара пользователя

Unborn
Сообщения: 1778
Зарегистрирован: 03 сен 2016, 10:36
Решено: 24
Благодарил (а): 4 раза
Поблагодарили: 253 раза

Восстановление GRUB

Сообщение Unborn » 01 мар 2019, 13:30

_R-S_ писал(а):
01 мар 2019, 13:08
с чего вы взяли, что esp /boot/efi не был создан?
Потому что видимо у вас вторая система не загружается из-за того, что при установке вы не задали точку монтирования для esp раздела или воткнули систему Груб не туда. У вас груб рескуе от предыдущей системы работает, укажите руками ей где ядро, и она вам его загрузит.
Беру с того, что при нормальной установке, проблем, которые возникли не бывает. Конечно при исправности железа. А у вас -
_R-S_ писал(а):
28 фев 2019, 17:42
вроде бы
_R-S_ писал(а):
28 фев 2019, 17:42
может проблема в этом, что граб некорректно устанавливается cразделом boot/uefi?
На вашем месте я бы просто заново установил, что вам там нужно и всё. LMDE, Debian или ещё чего.

Аватара пользователя

S.A.
Сообщения: 147
Зарегистрирован: 26 апр 2017, 06:53
Благодарил (а): 7 раз
Поблагодарили: 27 раз

Восстановление GRUB

Сообщение S.A. » 02 мар 2019, 12:00

Unborn писал(а):
01 мар 2019, 12:58
В УЕФИ ничего, кроме даты-времени не сбрасывается, ибо NVRAM.
Этого достаточно, чтобы открылся BIOS, как раз таки для установки даты и времени (мы попадаем в BIOS,, что нам и нужно). А дальше могут быть разные варианты действий.
Unborn писал(а):
01 мар 2019, 13:30
при установке вы не задали точку монтирования для esp раздела
Если установщик правильно определяет раздел ESP, то точку монтирования для ESP раздела задать не получится, т.к. эта "опция" не активна.

Аватара пользователя

Unborn
Сообщения: 1778
Зарегистрирован: 03 сен 2016, 10:36
Решено: 24
Благодарил (а): 4 раза
Поблагодарили: 253 раза

Восстановление GRUB

Сообщение Unborn » 05 мар 2019, 07:25

S.A. писал(а):
02 мар 2019, 12:00
Этого достаточно, чтобы открылся BIOS, как раз таки для установки даты и времени (мы попадаем в BIOS,, что нам и нужно). А дальше могут быть разные варианты действий.
А ты без всяких сбросов должен заходить по комбинации кнопок.
S.A. писал(а):
02 мар 2019, 12:00
Если установщик правильно определяет раздел ESP, то точку монтирования для ESP раздела задать не получится, т.к. эта "опция" не активна.
Это при чистой установке ещё срабатывает, а в ручном режиме - для того он и ручной. И вот почему-то не всегда срабатывает авто.
И чего там не активно? Вот аж по два esp раздела на одном диске умудряются заделать.
Хотя бы для интереса посмотрел на разметку установочной флешки для УЕФИ-ГПТ. Какой там флаг установлен? Где там видно boot,esp? А с неё ведь загружается и устанавливается ОС.

Аватара пользователя

S.A.
Сообщения: 147
Зарегистрирован: 26 апр 2017, 06:53
Благодарил (а): 7 раз
Поблагодарили: 27 раз

Восстановление GRUB

Сообщение S.A. » 05 мар 2019, 12:37

Unborn,
Ты вообще о чём? Сам с собой разговариваешь что ли.

Аватара пользователя

AlexZ
Сообщения: 1209
Зарегистрирован: 06 янв 2018, 18:06
Решено: 3
Откуда: Горно-Алтайск
Благодарил (а): 181 раз
Поблагодарили: 155 раз

Восстановление GRUB

Сообщение AlexZ » 12 мар 2019, 18:48

Unborn писал(а):
01 мар 2019, 12:58
Точку монтирования для esp раздела /boot/efi нужно было задать и всё
Пользователь не задает её, Системный раздел EFI монтируется в установщике автоматически.
Unborn писал(а):
01 мар 2019, 12:58
LMDE3 использует каталог linuxmint для установки efi - загрузчика. Залупубунты, к которым и Минт относится, каталог ubuntu. Дебиан - каталог debian.
Вот ведь возникает вопрос, почему они в LMUE не исправили на linuxmint как в LMDE?
Само прикольно, я думал это только в UEFI-системах, но у меня на Legacy/MBR после использования grub-customizer LM19.1 тоже переименовался в Ubuntu.. :hoho:
Похоже из-за этого файлика - /etc/default/grub.d/50_linuxmint.cfg
#! /bin/sh
set -e

# Set distributor to "Ubuntu"
#
# In Mint 16:
# shim and grub come with hardcoded ubuntu strings upstream, without this EFI installation is broken
# https://bugs.launchpad.net/ubuntu/+sour ... ug/1242417
#
# In Mint 17:
# Despite the bug report being marked as fixed, the situation is the same. Grub was patched by Ubuntu
# to assign the "ubuntu" distributor ID when it was given "Kubuntu". That results in Kubuntu finally
# getting EFI to work out of the box but still using "ubuntu" as far as grub-install is concerned.
# So we'll stick to "Ubuntu" for this iteration.
#
# In Mint 18:
# Some packages are still hardcoded with the "ubuntu" path.. fwupdate for instance.
# Visually, the grub boot menuentry name is set for derivatives in 10_linux,
# but underneath the EFI path remains "ubuntu" for everything to work properly.

GRUB_DISTRIBUTOR="Ubuntu"
Хотя грабы на других дисках определяют LM корректно "Linux Mint 19.1 Tessa", как в lsb-release..
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=19.1
DISTRIB_CODENAME=tessa
DISTRIB_DESCRIPTION="Linux Mint 19.1 Tessa"

Аватара пользователя

slant
Сообщения: 1829
Зарегистрирован: 21 июн 2017, 15:09
Решено: 29
Благодарил (а): 14 раз
Поблагодарили: 788 раз

Восстановление GRUB

Сообщение slant » 12 мар 2019, 18:52

AlexZ писал(а):
12 мар 2019, 18:48
Вот ведь возникает вопрос, почему они в LMUE не исправили на linuxmint как в LMDE?
Там какая-то несовместимость с самой ubuntu в этом случае получается. Минт же на ее репах основан, и что-то там в пакетах связанных с загрузчиком в этом случае не стыкуется - он то себя убунтой считает, ибо оттуда приехал.

Аватара пользователя

AlexZ
Сообщения: 1209
Зарегистрирован: 06 янв 2018, 18:06
Решено: 3
Откуда: Горно-Алтайск
Благодарил (а): 181 раз
Поблагодарили: 155 раз

Восстановление GRUB

Сообщение AlexZ » 13 мар 2019, 17:43

slant писал(а):
12 мар 2019, 18:52
Минт же на ее репах основан, и что-то там в пакетах связанных с загрузчиком в этом случае не стыкуется
Где бы посмотреть-почитать об этом?
В 18.3 всё норм было, можно подумать что несовместимость появилась на базе U18.04. Но у меня на базе U18.04LTS ещё elementaryOS и Runtu, и их грабы определяют свою систему корректно, не как "ubuntu"

Runtu (на флешке)
Runtu.png
LM19.1
LM19.1.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя

AlexZ
Сообщения: 1209
Зарегистрирован: 06 янв 2018, 18:06
Решено: 3
Откуда: Горно-Алтайск
Благодарил (а): 181 раз
Поблагодарили: 155 раз

Восстановление GRUB

Сообщение AlexZ » 20 мар 2019, 18:51

Вобщем просто поменял в том файлике (/etc/default/grub.d/50_linuxmint.cfg)

Код: Выделить всё

GRUB_DISTRIBUTOR="Ubuntu"
на

Код: Выделить всё

GRUB_DISTRIBUTOR="Linux Mint 19.1 Tessa"
LM19.1.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.


1lya
Сообщения: 4
Зарегистрирован: 12 сен 2018, 22:34
Поблагодарили: 1 раз

Восстановление GRUB

Сообщение 1lya » 02 апр 2019, 22:50

AlexZ писал(а):
20 мар 2019, 18:51
Вобщем просто поменял в том файлике (/etc/default/grub.d/50_linuxmint.cfg)
Расскажи, нормально ли у тебя работает система после того, как ты изменил эту строчку?

Аватара пользователя

darkfenix
Сообщения: 5411
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 295 раз
Поблагодарили: 1009 раз

Восстановление GRUB

Сообщение darkfenix » 03 апр 2019, 03:20

1lya писал(а):
02 апр 2019, 22:50
Расскажи, нормально ли у тебя работает система после того, как ты изменил эту строчку?
На работу ОС это изменение никак не влияет
Изображение

Аватара пользователя

AlexZ
Сообщения: 1209
Зарегистрирован: 06 янв 2018, 18:06
Решено: 3
Откуда: Горно-Алтайск
Благодарил (а): 181 раз
Поблагодарили: 155 раз

Восстановление GRUB

Сообщение AlexZ » 05 апр 2019, 18:58

1lya писал(а):
02 апр 2019, 22:50
нормально ли у тебя работает система после того, как ты изменил эту строчку?
Как уже сказали, на систему это изменение не влияет. Могла слететь настройка при обновлении пакета grub. Но нет, недавно grub обновился (выбирал новую версию конфига) и всё осталось без изменений

Вернуться в «Загрузка системы, бэкапы и восстановление»