Проблемы с стартом системы

В ходе установки системы возникли проблемы? Сложно сделать базовые настройки? Тогда вам сюда!
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Для начала воспользуйтесь поиском форума. 2. Укажите версию ОС вместе с разрядностью. Пример: LM 19.3 x64, LM Sarah x32 3. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 4. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 5. Суть. Желательно с выводом консоли, логами. 6. Скрин. Просьба указывать 2, 3 и 4 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

Автор темы
koshko1
Сообщения: 7
Зарегистрирован: 31 май 2021, 14:31

Проблемы с стартом системы

Сообщение koshko1 » 31 май 2021, 15:41

Здравствуйте!
Предупрежу сразу: Я - чайник. Поэтому прошу прощения за (возможно) дурацкие вопросы, и непонимание "простых вещей, которые все знают".
Суть проблемы:
Заколебала винда, посмотрел что на линуксе есть аналоги программ, которые часто использую, и решил перейти на линукс минт. Через лайв-диск с виндой создал отдельные раздел на диске, форматировал в ехт2 и начал устанавливать с флешки линукс (linuxmint-20.1-cinnamon-64bit-edge.iso). Установку выбрал параллельную с виндой и выбором какую ОС загружать при старте компьютера. После того как комп перезагрузился после установки выбрал запуск линукс, и увидел черный экран. Без ничего. Выключение -> старт-> "Е" на строке линукса. И вижу вот такую надпись: меняю quiet splash на modset = 0 но пробегает текст старта системы, а дальше черный экран.
Моя система:

Аватара пользователя

sheridan
Сообщения: 644
Зарегистрирован: 24 фев 2020, 16:13
Решено: 6
Откуда: Алчевск
Благодарил (а): 478 раз
Поблагодарили: 243 раза

Проблемы с стартом системы

Сообщение sheridan » 31 май 2021, 17:02

А для чего форматировали в ext2?


Автор темы
koshko1
Сообщения: 7
Зарегистрирован: 31 май 2021, 14:31

Проблемы с стартом системы

Сообщение koshko1 » 31 май 2021, 17:05

Чтобы проще найти при установке. У меня на компе 3 физических жёстких диска.

Аватара пользователя

sheridan
Сообщения: 644
Зарегистрирован: 24 фев 2020, 16:13
Решено: 6
Откуда: Алчевск
Благодарил (а): 478 раз
Поблагодарили: 243 раза

Проблемы с стартом системы

Сообщение sheridan » 31 май 2021, 17:08

Сейчас в основном используют ext4 или btrfs

Аватара пользователя

sheridan
Сообщения: 644
Зарегистрирован: 24 фев 2020, 16:13
Решено: 6
Откуда: Алчевск
Благодарил (а): 478 раз
Поблагодарили: 243 раза

Проблемы с стартом системы

Сообщение sheridan » 31 май 2021, 17:13

Попробуйте этот linuxmint-20.1-cinnamon-64bit.iso и отформатируйте в ext4
https://www.linuxmint.com/edition.php?id=284


Автор темы
koshko1
Сообщения: 7
Зарегистрирован: 31 май 2021, 14:31

Проблемы с стартом системы

Сообщение koshko1 » 31 май 2021, 17:17

Да, я знаю что сейчас используется ext4. Но диск я разбивал через партишен мэджик, или аомэй(?). Все равно линукс перед установкой форматирует раздел в ext4. Я это сделал чтобы было проще найти раздел в процессе установки.

Аватара пользователя

sheridan
Сообщения: 644
Зарегистрирован: 24 фев 2020, 16:13
Решено: 6
Откуда: Алчевск
Благодарил (а): 478 раз
Поблагодарили: 243 раза

Проблемы с стартом системы

Сообщение sheridan » 31 май 2021, 17:27

Загрузитесь с флешки в live режиме и в терминале введите
inxi -Fxz
полученное скопируйте и сюда выложите


Автор темы
koshko1
Сообщения: 7
Зарегистрирован: 31 май 2021, 14:31

Проблемы с стартом системы

Сообщение koshko1 » 31 май 2021, 17:34

sheridan писал(а):
31 май 2021, 17:27
Загрузитесь с флешки в live режиме и в терминале введите
inxi -Fxz
полученное скопируйте и сюда выложите
Сначала попробую установить ваш образ. Если снова будет чёрный экран, то скопирую информацию сюда.


Автор темы
koshko1
Сообщения: 7
Зарегистрирован: 31 май 2021, 14:31

Проблемы с стартом системы

Сообщение koshko1 » 31 май 2021, 18:36

При запуске с флешки первый пункт "Start Linux mint ..." даёт черный экран. Судя по звуку приветствия в колонках, система стартует, но на этом всё.
При запуске строки "Start Linux ... (compability mode) система стартует. Устанавливать пока не стал.
Что можете сказать?

Аватара пользователя

sheridan
Сообщения: 644
Зарегистрирован: 24 фев 2020, 16:13
Решено: 6
Откуда: Алчевск
Благодарил (а): 478 раз
Поблагодарили: 243 раза

Проблемы с стартом системы

Сообщение sheridan » 01 июн 2021, 03:43

koshko1 писал(а):
31 май 2021, 18:36
При запуске с флешки первый пункт "Start Linux mint ..." даёт черный экран. Судя по звуку приветствия в колонках, система стартует, но на этом всё.
При запуске строки "Start Linux ... (compability mode) система стартует. Устанавливать пока не стал.
Что можете сказать?
С начала inxi -Fxz, хотя бы глянуть на Ваше железо.


Автор темы
koshko1
Сообщения: 7
Зарегистрирован: 31 май 2021, 14:31

Проблемы с стартом системы

Сообщение koshko1 » 01 июн 2021, 11:56

Кажется проблема решена (частично). nomodeset применил, а потом прописал в файл. Но теперь при загрузке появляется окно с рекомендацией обновить видеодрайвер, а менеджер драйвера сообщает, что драйверы актуальны.
И по этому вопросу мне нужен совет. Нужно ли что-то делать с драйверами? Мне это довольно важно - я занимаюсь 3д моделированием и визуализацией.

Система:

Код: Выделить всё

System:    Kernel: 5.4.0-58-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.8.5 
           wm: muffin dm: LightDM Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal 
Machine:   Type: Desktop Mobo: ASRock model: B450M Pro4-F serial: <filter> 
           UEFI: American Megatrends v: P2.00 date: 12/16/2019 
CPU:       Topology: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ rev: 2 
           L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 81434 
           Speed: 2794 MHz min/max: 1550/3400 MHz Core speeds (MHz): 1: 2794 2: 2794 3: 2595 
           4: 3892 5: 2794 6: 2595 7: 2595 8: 3892 9: 2794 10: 2794 11: 2794 12: 2595 
Graphics:  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
           vendor: Micro-Star MSI driver: N/A bus ID: 06:00.0 chip ID: 1002:67df 
           Display: x11 server: X.Org 1.20.8 driver: ati,fbdev unloaded: modesetting,radeon,vesa 
           resolution: 1920x1080~77Hz 
           OpenGL: renderer: llvmpipe (LLVM 10.0.0 128 bits) v: 3.3 Mesa 20.0.8 compat-v: 3.1 
           direct render: Yes 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
           vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 06:00.1 
           chip ID: 1002:aaf0 
           Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel v: kernel 
           bus ID: 08:00.3 chip ID: 1022:1457 
           Sound Server: ALSA v: k5.4.0-58-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock 
           driver: r8169 v: kernel port: f000 bus ID: 04:00.0 chip ID: 10ec:8168 
           IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 2.49 TiB used: 579.92 GiB (22.7%) 
           ID-1: /dev/sda vendor: Crucial model: CT480BX500SSD1 size: 447.13 GiB speed: 6.0 Gb/s 
           serial: <filter> temp: 33 C 
           ID-2: /dev/sdb vendor: A-Data model: SU720 size: 1.82 TiB speed: 6.0 Gb/s 
           serial: <filter> temp: 50 C 
           ID-3: /dev/sdc vendor: Seagate model: ST9250315AS size: 232.89 GiB speed: 3.0 Gb/s 
           serial: <filter> temp: 31 C 
           ID-4: /dev/sdd type: USB vendor: Kingston model: DataTraveler 3.0 size: 7.22 GiB 
           serial: <filter> 
Partition: ID-1: / size: 15.65 GiB used: 74.3 MiB (0.5%) fs: overlay source: ERR-102 
Sensors:   System Temperatures: cpu: 53.5 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Repos:     Active apt repos in: /etc/apt/sources.list 
           1: deb cdrom:[Linux Mint 20.1 _Ulyssa_ - Release amd64 20210103]/ focal contrib main
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http: //packages.linuxmint.com ulyssa main upstream import backport #id:linuxmint_main
           2: deb http: //archive.ubuntu.com/ubuntu focal main restricted universe multiverse
           3: deb http: //archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
           4: deb http: //archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
           5: deb http: //security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
           6: deb http: //archive.canonical.com/ubuntu/ focal partner
Info:      Processes: 270 Uptime: 5m Memory: 31.29 GiB used: 908.6 MiB (2.8%) Init: systemd v: 245 
           runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Client: Unknown python3.8 client inxi: 3.0.38 

Аватара пользователя

sheridan
Сообщения: 644
Зарегистрирован: 24 фев 2020, 16:13
Решено: 6
Откуда: Алчевск
Благодарил (а): 478 раз
Поблагодарили: 243 раза

Проблемы с стартом системы

Сообщение sheridan » 01 июн 2021, 13:07

В принципе у AMD свободные драйвера самодостаточные, если только не необходим OpenCL для параллельных вычислений.
Попробуйте обновится с консоли:
sudo apt update
sudo apt full-upgrade


Автор темы
koshko1
Сообщения: 7
Зарегистрирован: 31 май 2021, 14:31

Проблемы с стартом системы

Сообщение koshko1 » 01 июн 2021, 17:45

sheridan писал(а):
01 июн 2021, 13:07
В принципе у AMD свободные драйвера самодостаточные, если только не необходим OpenCL для параллельных вычислений.
Попробуйте обновится с консоли:
sudo apt update
sudo apt full-upgrade
Спасибо! Попробую.

Вернуться в «Установка Linux Mint»