Не устанавливается VM

Языки программирования, IDE, компиляторы, интерпретаторы, гипервизоры и виртуальные среды
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Для начала воспользуйтесь поиском форума. 2. Укажите версию ОС вместе с разрядностью. Пример: LM 19.3 x64, LM Sarah x32 3. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 4. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 5. Суть. Желательно с выводом консоли, логами. 6. Скрин. Просьба указывать 2, 3 и 4 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

Автор темы
Vaspet
Сообщения: 13
Зарегистрирован: 03 май 2021, 15:03
Решено: 1
Благодарил (а): 6 раз

Не устанавливается VM

Сообщение Vaspet » 09 май 2021, 19:26

Приветствую всех. Вот и меня достала винда. Перехожу на Линукс (2 или 3 раза лет 14 назад). Остановился на LM20.1 ulissa cinnamon 4.8.6 Осваиваю пока на уровне: "азбуку видел(прочитал) смотрю букварь") Захотел поставит виртуалку - пишет ошибка: отключите аппаратный виртуализатор, ваш хост не поддерживает ... я тупанул и не могу в биосе найти. Явного пункта с таким параметром не увидел. А отключая CSM - перестает видеть SSD на которые поставил LM20.1 bи MX kde. Чтото я напортачил, а где не пойму. Мать гигабитка B450 GAMING X биос f50. КТО МОЖЕТ ПОДСКАЗАТЬ КУДА КОПАТЬ? Спасибо!
System: Kernel: 5.4.0-72-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.8.6
wm: muffin dm: LightDM Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal
Machine: Type: Desktop System: Gigabyte product: B450 GAMING X v: N/A serial: <filter>
Mobo: Gigabyte model: B450 GAMING X v: x.x serial: <filter>
UEFI [Legacy]: American Megatrends v: F50 date: 11/27/2019
Battery: Device-1: hidpp_battery_0 model: Logitech M510 serial: <filter>
charge: 55% (should be ignored) status: Discharging
CPU: Topology: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+ rev: 2
L2 cache: 3072 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86227
Speed: 1907 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 1881 2: 1887 3: 2194
4: 2195 5: 2018 6: 2192 7: 2193 8: 2194 9: 2192 10: 2061 11: 1890 12: 2193
Graphics: Device-1: NVIDIA TU104 [GeForce RTX 2060] vendor: Gigabyte driver: nvidia v: 460.73.01
bus ID: 08:00.0 chip ID: 10de:1e89
Display: x11 server: X.Org 1.20.9 driver: nvidia
unloaded: fbdev,modesetting,nouveau,vesa resolution: 1920x1200~60Hz
OpenGL: renderer: GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 460.73.01
direct render: Yes
Audio: Device-1: Conexant Systems CX23887/8 PCIe Broadcast Audio and Video Decoder with 3D Comb vendor: VoiceTronix Pty GoTView X5 DVD Hybrid PCI-E driver: cx23885 v: 0.0.4
bus ID: 07:00.0 chip ID: 14f1:8880
Device-2: NVIDIA TU104 HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel
bus ID: 08:00.1 chip ID: 10de:10f8
Device-3: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel
bus ID: 0a:00.3 chip ID: 1022:1457
Sound Server: ALSA v: k5.4.0-72-generic
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte
driver: r8169 v: kernel port: f000 bus ID: 03:00.0 chip ID: 10ec:8168
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives: Local Storage: total: 2.49 TiB used: 26.71 GiB (1.0%)
ID-1: /dev/sda vendor: Toshiba model: HDWD120 size: 1.82 TiB speed: 6.0 Gb/s
serial: <filter>
ID-2: /dev/sdb vendor: A-Data model: SU650 size: 223.57 GiB speed: 6.0 Gb/s
serial: <filter>
ID-3: /dev/sdc vendor: Samsung model: SSD 870 EVO 500GB size: 465.76 GiB
speed: 6.0 Gb/s serial: <filter>
Partition: ID-1: / size: 190.26 GiB used: 26.71 GiB (14.0%) fs: ext4 dev: /dev/sdc5
Sensors: System Temperatures: cpu: 43.6 C mobo: N/A gpu: nvidia temp: 49 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Repos: No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
1: deb http: //packages.linuxmint.com ulyssa main upstream import backport #id:linuxmint_main
2: deb http: //archive.ubuntu.com/ubuntu focal main restricted universe multiverse
3: deb http: //archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
4: deb http: //archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
5: deb http: //security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
6: deb http: //archive.canonical.com/ubuntu/ focal partner
Active apt repos in: /etc/apt/sources.list.d/teamviewer.list
1: deb https: //linux.teamviewer.com/deb stable main
Info: Processes: 286 Uptime: 11m Memory: 15.65 GiB used: 1.42 GiB (9.1%) Init: systemd v: 245
runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Client: Unknown python3.8 client inxi: 3.0.38
,

Решение Vaspet » 10 май 2021, 07:52
Однако. Как глубоко зарыли. И никакой логики. Довольно слабо связана частота с виртуалкой. это не оверклокинг. ну да ладно бог с ними. Но ВАМ огромное спасибо!!!

Перейти к ответу ➙

Аватара пользователя

madesta
Сообщения: 1077
Зарегистрирован: 11 июн 2017, 18:47
Решено: 12
Благодарил (а): 43 раза
Поблагодарили: 255 раз

Не устанавливается VM

Сообщение madesta » 09 май 2021, 19:38

Так море же материала выдаёт если задать Яндексу вопрос "отключите аппаратный виртуализатор, ваш хост не поддерживает ..." При беглом просмотре что-то не увидел там про CSM. Тут уж или фото всего BIOS просить или может кто из гуру ответит.


Автор темы
Vaspet
Сообщения: 13
Зарегистрирован: 03 май 2021, 15:03
Решено: 1
Благодарил (а): 6 раз

Не устанавливается VM

Сообщение Vaspet » 09 май 2021, 19:59

Спасибо. Я с этого начал. Но в этом биосе не нашел путкт где хотя бы отдаленно было слово virtual.... да и английский для меня как болгарский.


Автор темы
Vaspet
Сообщения: 13
Зарегистрирован: 03 май 2021, 15:03
Решено: 1
Благодарил (а): 6 раз

Не устанавливается VM

Сообщение Vaspet » 09 май 2021, 20:01

Что такое CSM. Если не вдаваться глубоко в технические подробности, CSM — это модуль совместимости, режим, позволяющий устанавливать и загружать старые операционные системы на компьютерах с UEFI так же, как если бы вместо UEFI в них использовался классический BIOS, примером чему может служить загрузка с MBR-дисков на UEFI.

Аватара пользователя

slant
Сообщения: 3266
Зарегистрирован: 21 июн 2017, 15:09
Решено: 58
Благодарил (а): 39 раз
Поблагодарили: 1377 раз

Не устанавливается VM

Сообщение slant » 09 май 2021, 20:11

Vaspet писал(а):
09 май 2021, 19:26
Захотел поставит виртуалку - пишет ошибка: отключите аппаратный виртуализатор, ваш хост не поддерживает ... я тупанул и не могу в биосе найти.
Здесь я словил когнитивный диссонанс: любая современная виртуалка наоборот, ТРЕБУЕТ включенной поддержки виртуалиазции в BIOS/EFI.
Посему:
1. Какая виртуалка ставится?
2. Скриншот ошибки. Либо копипаст всего текста. Не пересказ своими словами пожалуйста.

CSM сюда отношения не имеет. Забудьте пока. Оставьте в работающем виде и не трогайте.


Автор темы
Vaspet
Сообщения: 13
Зарегистрирован: 03 май 2021, 15:03
Решено: 1
Благодарил (а): 6 раз

Не устанавливается VM

Сообщение Vaspet » 09 май 2021, 21:15

Пробую еще раз
Снимок экрана от 2021-05-09 23-42-45.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.


Автор темы
Vaspet
Сообщения: 13
Зарегистрирован: 03 май 2021, 15:03
Решено: 1
Благодарил (а): 6 раз

Не устанавливается VM

Сообщение Vaspet » 09 май 2021, 21:30

Вот еще
Не удалось открыть сессию для виртуальной машины VM_11.

AMD-V is disabled in the BIOS (or by the host OS) (VERR_SVM_DISABLED).

Код ошибки: NS_ERROR_FAILURE (0x80004005)
Компонент: ConsoleWrap
Интерфейс: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Аватара пользователя

madesta
Сообщения: 1077
Зарегистрирован: 11 июн 2017, 18:47
Решено: 12
Благодарил (а): 43 раза
Поблагодарили: 255 раз

Не устанавливается VM

Сообщение madesta » 10 май 2021, 00:25

Попробуйте щёлкнуть на значку справа от текста "Обнаружены неправильные настройки"- обычно там бывает пояснение что не так. И посмотрите текст в рамке, там предлагается изменить настройки вашей виртуальной машины (Ускорение).


Автор темы
Vaspet
Сообщения: 13
Зарегистрирован: 03 май 2021, 15:03
Решено: 1
Благодарил (а): 6 раз

Не устанавливается VM

Сообщение Vaspet » 10 май 2021, 05:35

Текст в рамке и появляется после нажатия на значок. понятно что надо отключить виртуализацию аппаратную, но в биосе не обнаруживается ничего похожего ни на абревеатуру ни на слова о ВМ, типа:svm mode и др. На просторах инета попался один ответ: что в этой мамке нет такого пункта. мать - machine: Type: Desktop System: Gigabyte product: B450 GAMING X v: N/A serial: <filter>
Mobo: Gigabyte model: B450 GAMING X v: x.x serial: <filter>
UEFI [Legacy]: American Megatrends v: F50 date: 11/27/2019 /
А может такое быть? Я пока не нашел ничего похожего.
На другом диске этой машины стоит Win10, с VMware Workstation 16 Pro 16.1.1 так тоже была проблема, но удалось поставить три виртуальные машины: LM 20.1; MX 19.1 И Win10 но как гостевые.


Автор темы
Vaspet
Сообщения: 13
Зарегистрирован: 03 май 2021, 15:03
Решено: 1
Благодарил (а): 6 раз

Не устанавливается VM

Сообщение Vaspet » 10 май 2021, 05:42

slant писал(а):
09 май 2021, 20:11
Здесь я словил когнитивный диссонанс: любая современная виртуалка наоборот, ТРЕБУЕТ включенной поддержки виртуалиазции в BIOS/EFI.
Меня это тоже озадачило. А не зависит ли от того, что установлено UEFI или просто EFI. Я не сильно разбираюсь еще в этом.

Аватара пользователя

rogoznik
Сообщения: 8479
Зарегистрирован: 27 июн 2017, 10:36
Решено: 93
Откуда: Нижний Тагил
Благодарил (а): 555 раз
Поблагодарили: 1543 раза

Не устанавливается VM

Сообщение rogoznik » 10 май 2021, 05:43

Vaspet, текс ошибки говорит о том что надо отключить виртуализацию для виртуальной машины, т.к. у тебя виртуализация выключена.
Vaspet писал(а):
10 май 2021, 05:35
B450 GAMING X
Такая же материнка, только я прошивку обновил до версии F52
Vaspet писал(а):
10 май 2021, 05:35
типа:svm mode и др. На просторах инета попался один ответ: что в этой мамке нет такого пункта.
есть такое, только не сразу находится, путь такой: M.I.T. => Advanced CPU Settings => svm mode => Enable
ИзображениеИзображение


Автор темы
Vaspet
Сообщения: 13
Зарегистрирован: 03 май 2021, 15:03
Решено: 1
Благодарил (а): 6 раз

Не устанавливается VM

Сообщение Vaspet » 10 май 2021, 05:48

Сейчас посмотрю еще раз. Или это появляется после перепрошивки на F52?

Аватара пользователя

rogoznik
Сообщения: 8479
Зарегистрирован: 27 июн 2017, 10:36
Решено: 93
Откуда: Нижний Тагил
Благодарил (а): 555 раз
Поблагодарили: 1543 раза

Не устанавливается VM

Сообщение rogoznik » 10 май 2021, 05:56

Vaspet писал(а):
10 май 2021, 05:48
Или это появляется после перепрошивки на F52?
Оно и на F50 есть
ИзображениеИзображение


Автор темы
Vaspet
Сообщения: 13
Зарегистрирован: 03 май 2021, 15:03
Решено: 1
Благодарил (а): 6 раз

Не устанавливается VM

Сообщение Vaspet » 10 май 2021, 06:25

Это меню M.I.T.
У вас нет необходимых прав для просмотра вложений в этом сообщении.


Автор темы
Vaspet
Сообщения: 13
Зарегистрирован: 03 май 2021, 15:03
Решено: 1
Благодарил (а): 6 раз

Не устанавливается VM

Сообщение Vaspet » 10 май 2021, 06:32

rogoznik писал(а):
10 май 2021, 05:43
есть такое, только не сразу находится, путь такой: M.I.T. => Advanced CPU Settings => svm mode => Enable
ИзображениеИзображение
Я и ищу что то подобное. На других компах было(старых). А здесь перерыл раз ...дцать все пункты и результат: или я сильно тупанул или словил клина.


Автор темы
Vaspet
Сообщения: 13
Зарегистрирован: 03 май 2021, 15:03
Решено: 1
Благодарил (а): 6 раз

Не устанавливается VM

Сообщение Vaspet » 10 май 2021, 06:40

Небольшое уточнение: этот комп мне подарили на ДР в собраном виде. Покупали в NIXе с предустановленой ОС и вшитом словаре от них, и в качестве изготовителя и поддержка указаны они. Могли они поставить свою прошивку? Очень странно что нет такого пункта.

Аватара пользователя

rogoznik
Сообщения: 8479
Зарегистрирован: 27 июн 2017, 10:36
Решено: 93
Откуда: Нижний Тагил
Благодарил (а): 555 раз
Поблагодарили: 1543 раза

Не устанавливается VM

Сообщение rogoznik » 10 май 2021, 07:31

Vaspet, это я пропустил. Должно быть так
M.I.T. => Advanced frequency settings => Advanced CPU Settings => svm mode => Enable
В твоем случае, т.к. ты поставил русский язык
M.I.T. => Расширенные настройки частот => Advanced CPU Settings => svm mode => Enable
ИзображениеИзображение


Автор темы
Vaspet
Сообщения: 13
Зарегистрирован: 03 май 2021, 15:03
Решено: 1
Благодарил (а): 6 раз

Не устанавливается VM

Сообщение Vaspet » 10 май 2021, 07:52

Однако. Как глубоко зарыли. И никакой логики. Довольно слабо связана частота с виртуалкой. это не оверклокинг. ну да ладно бог с ними. Но ВАМ огромное спасибо!!!
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Вернуться в «Программирование, скриптинг, виртуализация»