Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Нет звука? Вас не устраивает качество звучания? Вы попали по адресу.
Правила форума
Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа.
Аватара пользователя

Автор темы
zuzabrik
Сообщения: 759
Зарегистрирован: 29 авг 2016, 09:08
Решено: 15
Благодарил (а): 48 раз
Поблагодарили: 222 раза

Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Сообщение zuzabrik » 20 янв 2017, 17:06

Да да, я знаю что форум про Linux Mint, но надеюсь вы достаточно красноглазы чтобы помочь мне с Debian :)

История такова. Мой комп навернулся и наверное надолго. К счастью нашелся рабочий системник, правда с очень фиговыми параметрами. Собсна вывод Inxi -Fxz под спойлером, а если кратко это некая материнка Asus M2N-E SLI с звуковухой которая определяется линуксом как C-Media CM6501 driver: USB Audio usb-ID: 002-003.

Код: Выделить всё

$ inxi -Fxz
System:    Host: pc Kernel: 3.16.0-4-686-pae i686 (32 bit gcc: 4.8.4) Desktop: N/A Distro: Debian GNU/Linux 8 
Machine:   Mobo: ASUSTeK model: M2N-E SLI v: 1.XX Bios: Phoenix v: ASUS M2N-E SLI 0506 date: 12/05/2006
CPU:       Dual core AMD Athlon 64 X2 3600+ (-MCP-) cache: 512 KB
           flags: (lm nx pae sse sse2 sse3 svm) bmips: 4020 
           Clock Speeds: 1: 1000 MHz 2: 1000 MHz
Graphics:  Card: NVIDIA GK208 [GeForce GT 640 Rev. 2] bus-ID: 05:00.0
           Display Server: X.Org 1.16.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce GT 640/PCIe/SSE2/3DNOW! GLX Version: 4.5.0 NVIDIA 375.26 Direct Rendering: Yes
Audio:     Card-1 NVIDIA Device 0e0f driver: snd_hda_intel bus-ID: 05:00.1 Sound: ALSA v: k3.16.0-4-686-pae
           Card-2 C-Media CM6501 driver: USB Audio usb-ID: 002-003 
Network:   Card: NVIDIA CK804 Ethernet Controller driver: forcedeth port: bc00 bus-ID: 00:0a.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 500.1GB (1.4% used) ID-1: /dev/sda model: TOSHIBA_DT01ACA0 size: 500.1GB
Partition: ID-1: / size: 457G used: 4.7G (2%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 2.14GB used: 0.17GB (8%) fs: swap dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 37.0C mobo: 36.0C gpu: 0.0:39C 
           Fan Speeds (in rpm): cpu: 3154 psu: 0 sys-1: 0 
Info:      Processes: 146 Uptime: 1:10 Memory: 436.9/1006.5MB Init: systemd runlevel: 5 Gcc sys: 4.9.2 
           Client: Shell (bash 4.3.301) inxi: 2.1.28 
Установил я Debian 8.7.1 32-х битную версию с раб. столом Xfce. После установки обнаружилось что звука нет от слова совсем. Погуглив немного наткнулся на совет поставить pavucontrol. Как ни странно (и правда схренабы) звук после открытия этой проги появился и отлично прожил примерно сутки. За это время я посмотрел кучу видосов в инете, музычку послушал. В общем наслаждался жизнью. Перезагружая комп звук никуда не пропадал.

ВНЕЗАПНО, БЕЗ ОБЪЯВЛЕНИЯ ВОЙНЫ!!! Звук пару часов назад при проигрывании ролика с ютуба превратился просто в очень громкий шум. Перезагрузка компа не помогла, скачав музычку на диск и открыв ее в VLC я так же убедился что дело не в браузере и его плагине, VLC выдавал такой же шум вместо звука :) При этом если ничего не воспроизводится, то ничего и не шумит.

А теперь уважаемые знатоки, внимание вопрос! ЧО ОН ОТ МЕНЯ ХОЧЕТ ЧТОБЫ ВЕРНУТЬ ЗВУК ВМЕСТО ШУМОВ?
Имею желание иметь всех желающих, но не имею желающих.

Аватара пользователя

Chocobo
Сообщения: 5492
Зарегистрирован: 27 авг 2016, 19:57
Решено: 126
Откуда: НН
Благодарил (а): 410 раз
Поблагодарили: 1422 раза

Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Сообщение Chocobo » 20 янв 2017, 17:11

в том же pavucontrol и alsamixer ничего никуда не делось на момент возникновения проблемы?

Аватара пользователя

Автор темы
zuzabrik
Сообщения: 759
Зарегистрирован: 29 авг 2016, 09:08
Решено: 15
Благодарил (а): 48 раз
Поблагодарили: 222 раза

Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Сообщение zuzabrik » 20 янв 2017, 17:17

Chocobo писал(а): в том же pavucontrol и alsamixer ничего никуда не делось на момент возникновения проблемы?
В pavucontrol все вроде как было. Я ползунки всякие и кнопочки пробовал потыкать, но не помогло. Что там использует Хфце для своего аплета звука я не в курсе, но запустив щас из терминала комаду alsamixer получил в терминале же консольное нечто... ))) этот микшер фронтенд имеет? )
Имею желание иметь всех желающих, но не имею желающих.

Аватара пользователя

Chocobo
Сообщения: 5492
Зарегистрирован: 27 авг 2016, 19:57
Решено: 126
Откуда: НН
Благодарил (а): 410 раз
Поблагодарили: 1422 раза

Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Сообщение Chocobo » 20 янв 2017, 17:21

собсно это и есть его фронтенд, графика вторична)
Дебианщику стесняться псевдографики должно быть зазорно :-D

Ну а еще из методов - побробуй воспроизвести проблему на лайв-сессии чтоль, может и концы найдутся

драйвер USB Audio - странно как-то :hm:

Аватара пользователя

Автор темы
zuzabrik
Сообщения: 759
Зарегистрирован: 29 авг 2016, 09:08
Решено: 15
Благодарил (а): 48 раз
Поблагодарили: 222 раза

Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Сообщение zuzabrik » 20 янв 2017, 18:27

Chocobo писал(а): драйвер USB Audio - странно как-то
как я понял там хитрая схема при которой встроенная звуковуха через usb интерфейс общается... хрен пойми :)
вообще по поиску в гугл складывается впечатление что карточка то еще говнище, но мне пока выбирать не приходится.

UPD. Нашлись на сайте асуса какие-то дрова под линукс для этой материнки, но запускать их я очканул когда увидел в коде kernel 2.4.20 и упоминание Mandrake :-D :-D :-D

Отправлено спустя 59 минут 30 секунд:
Chocobo писал(а): побробуй воспроизвести проблему на лайв-сессии чтоль
Если ты про LiveCD то у меня его нет. Ставился через NetInstall образ :)
Имею желание иметь всех желающих, но не имею желающих.


Unborn
Сообщения: 777
Зарегистрирован: 03 сен 2016, 10:36
Решено: 15
Благодарил (а): 2 раза
Поблагодарили: 118 раз

Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Сообщение Unborn » 20 янв 2017, 19:42

zuzabrik, эта звуковуха и в Винде глючила. Если разгон присутствует - верни параметры по умолчанию. БИОС сбрось перемычкой. ЮСБ-Аудио - так и должно быть. Ещё из-за БП могут быть проблемы. Неудачная эта модель мат. платы, с ЦПУ АМД +чипсет НВИДИА.

Аватара пользователя

Автор темы
zuzabrik
Сообщения: 759
Зарегистрирован: 29 авг 2016, 09:08
Решено: 15
Благодарил (а): 48 раз
Поблагодарили: 222 раза

Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Сообщение zuzabrik » 20 янв 2017, 19:44

Если раньше я ничего не понимал, то теперь совсем ничего не понимаю...

В общем в alsamixer консольном наткнулся на одинокий столбик master в настройках звука. Столб был на 100, уменьшив его в половину из шипения получился таки звук.

Методом тыка и мата я подобрал приемлемые настройки, так чтобы устраивало и по громкости и покачеству. мастер - 15, микшер хфце - 100, колонки - 50 громкости. Казалось бы вот она, рыба моей мечты, но радовался я недолго.

По непонятной причине музычка с сайтов типа music.yandex.ru идет нормально, а на youtube.com гробовая тишина. Я заподозрил что проблема в HTML5/Flash. Найдя сайт где есть переключалка между этими режимами обнаружилось что во Flash плеере звук есть, а в HTML5 плеере его нет...

Отсюда 2 вопроса. 1 - какого хрена микшер без спроса скакнул до максимума посредине воспроизведения ролика с ютуб, 2 - как теперь вернуть звук на HTML5 видео?
Имею желание иметь всех желающих, но не имею желающих.


Unborn
Сообщения: 777
Зарегистрирован: 03 сен 2016, 10:36
Решено: 15
Благодарил (а): 2 раза
Поблагодарили: 118 раз

Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Сообщение Unborn » 20 янв 2017, 20:19

zuzabrik, у тебя что-то монополизирует Альсу и не корректно её отпускает. Флеш что-ли? Дебианский фирефокс?

Аватара пользователя

Автор темы
zuzabrik
Сообщения: 759
Зарегистрирован: 29 авг 2016, 09:08
Решено: 15
Благодарил (а): 48 раз
Поблагодарили: 222 раза

Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Сообщение zuzabrik » 20 янв 2017, 20:32

Unborn писал(а): zuzabrik, у тебя что-то монополизирует Альсу и не корректно её отпускает. Флеш что-ли? Дебианский фирефокс?
Firefox ESR 45.6.0 флеш последний.

Открыл одновременно VLC, яндекс музыку, ютуб. Первые два играют одновременно, ютуб по прежнему полчит. Не похоже на блокировку, тогда бы после запуска музычки с ютуба по идее она бы работала, будь первой запущена.
Имею желание иметь всех желающих, но не имею желающих.


Unborn
Сообщения: 777
Зарегистрирован: 03 сен 2016, 10:36
Решено: 15
Благодарил (а): 2 раза
Поблагодарили: 118 раз

Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Сообщение Unborn » 20 янв 2017, 20:46

zuzabrik, а с Яндекс чем играет - флешем или ХТМЛ5?

Аватара пользователя

Свежий Ветер
Сообщения: 51
Зарегистрирован: 16 янв 2017, 11:13
Благодарил (а): 16 раз
Поблагодарили: 14 раз

Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Сообщение Свежий Ветер » 20 янв 2017, 21:00

Ну, как-то совсем не сложно для эксперименту слепить лив_юсб из чего нибудь похожего, или из того же образа. минута установки юнитбутена и прям оттуда живой образ на флешку за 15 минут. Может кривовато система встала, с кем не бывает?
Попробуй другим браузером тоже самое сделать. я про ютуб.
Последний раз редактировалось пользователем 1 Свежий Ветер; всего редактировалось раз: 20
Глаза боятся, а руки - крюки.

Аватара пользователя

Автор темы
zuzabrik
Сообщения: 759
Зарегистрирован: 29 авг 2016, 09:08
Решено: 15
Благодарил (а): 48 раз
Поблагодарили: 222 раза

Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Сообщение zuzabrik » 20 янв 2017, 21:02

Unborn писал(а): а с Яндекс чем играет - флешем или ХТМЛ5?
без понятия... как проверить? :)

Попробовал скачать плагином video download helper видос с ютуба. В браузере нет звука, в скачаном файле при проигрывании в VLC звук есть :dash2:

Могли какие-то кодеки отвалиться или еще чего веселое? :) У меня теории заканчиваются
Имею желание иметь всех желающих, но не имею желающих.

Аватара пользователя

Chocobo
Сообщения: 5492
Зарегистрирован: 27 авг 2016, 19:57
Решено: 126
Откуда: НН
Благодарил (а): 410 раз
Поблагодарили: 1422 раза

Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Сообщение Chocobo » 20 янв 2017, 21:06

zuzabrik, давай еще сузим круг запробовав второй браузер. тот же хромиум
уровень это приложения, декодера потока из сети или еще чего...

Аватара пользователя

Автор темы
zuzabrik
Сообщения: 759
Зарегистрирован: 29 авг 2016, 09:08
Решено: 15
Благодарил (а): 48 раз
Поблагодарили: 222 раза

Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Сообщение zuzabrik » 20 янв 2017, 21:12

Свежий Ветер писал(а): Ну, как-то совсем не сложно для эксперименту слепить лив_юсб из чего нибудь похожего, или из того же образа. минута установки юнитбутена и прям оттуда живой образ на флешку за 15 минут. Может кривовато система встала, с кем не бывает?
Да нормально она встала... а идея с лайвСД так себе...

Отправлено спустя 2 минуты 59 секунд:
Chocobo писал(а): давай еще сузим круг запробовав второй браузер. тот же хромиум
уровень это приложения, декодера потока из сети или еще чего...
Ок. завтра нарою еще браузер. На сегодня с меня хватит :)
Имею желание иметь всех желающих, но не имею желающих.


Unborn
Сообщения: 777
Зарегистрирован: 03 сен 2016, 10:36
Решено: 15
Благодарил (а): 2 раза
Поблагодарили: 118 раз

Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Сообщение Unborn » 20 янв 2017, 21:15

zuzabrik писал(а): без понятия... как проверить? :)
https://yandex.ru/support/music/trouble ... player.xml

Аватара пользователя

Bill Williamson
Сообщения: 460
Зарегистрирован: 31 авг 2016, 10:38
Решено: 18
Благодарил (а): 171 раз
Поблагодарили: 96 раз

Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Сообщение Bill Williamson » 21 янв 2017, 06:41

У меня не совсем Debian, но вот как я сделал в Arch с окружением xfce4:
установил pulseaudio pulseaudio-alsa alsa-lib alsa-utils paprefs pavucontrol
Со стандартным регулятором громкости были проблемы. Когда я на нем убавлял громкость до нуля, при обратном прибавлении звука не было. Приходилось лезть в audacious и там поднимать звук - тогда он появлялся. Решилось это установкой pa-applet-git и добавлением в автозапуск pa-applet. После этого и Fn начинает работать через этот апплет, а стандартный регулятор убрал.
В настройках pavucontrol аналоговый стереовыход.
Не могу сказать на сколько это все правильно, но работает как мне надо. Может эта информация чем-то поможет.

Аватара пользователя

Автор темы
zuzabrik
Сообщения: 759
Зарегистрирован: 29 авг 2016, 09:08
Решено: 15
Благодарил (а): 48 раз
Поблагодарили: 222 раза

Debian 8.7.1 Xfce 32bit. C-Media CM6501. Шум вместо звука.

Сообщение zuzabrik » 21 янв 2017, 15:04

Проблему решил вроде, но как я сам не понял, поэтому описывать рецепт тут не буду... Нечто из черной магии с alsactl, alsamixer, pavucontrol...
Имею желание иметь всех желающих, но не имею желающих.

Вернуться в «Звуковые карты»