Установка kde приложения = краш системы

Аватара пользователя

Автор темы
MrTowelie
Сообщения: 88
Зарегистрирован: 24 июл 2017, 06:01
Решено: 5
Благодарил (а): 5 раз
Поблагодарили: 29 раз

Установка kde приложения = краш системы

Сообщение MrTowelie » 10 дек 2019, 14:49

Добрый вечер.
А такой вопрос возник, можно ли установить пакет без обновления пакетов, связанных с ним? (понимаю, что при этом есть риск не запуска этого пакета)
К примеру, пришлось установить на днях на нетбуке с kde neon 5.17 пакет hplib-gui. Он предложил обновить пакет libqt5core5a. Ну а обновление любого пакета qt как и выше приводит к невозможности запустить любые kde-приложения (как понимаю qt-приложения, ибо тот же firefox работал). Следовательно приходится делать снова sudo apt full-upgrade, чтобы всё опять заработало. (т.е. обновляться до kde neon 5.17.2)
Вообще, всё никак не пойму, как так произошло, что начиная с kde neon 5.17, обновление пакетов, принадлежащих qt делает невозможным запуск kde приложений до их обновления. Кто-то с таким сталкивался из пользователей kde?

Аватара пользователя

rogoznik
Сообщения: 6348
Зарегистрирован: 27 июн 2017, 10:36
Решено: 71
Откуда: Нижний Тагил
Благодарил (а): 336 раз
Поблагодарили: 1158 раз

Установка kde приложения = краш системы

Сообщение rogoznik » 10 дек 2019, 14:56

Потому что нужно ставить полностью все обновы qt/kde, т.к. приложения на них завязаны. А при обновлении какого-то одно пакета - получаешь версии библиотек несоответствующие требуемым.
ИзображениеИзображение

Аватара пользователя

Автор темы
MrTowelie
Сообщения: 88
Зарегистрирован: 24 июл 2017, 06:01
Решено: 5
Благодарил (а): 5 раз
Поблагодарили: 29 раз

Установка kde приложения = краш системы

Сообщение MrTowelie » 10 дек 2019, 15:22

rogoznik, да я бы с радостью, вот только при попытке обновить libqt5core5a и libqt5dbus5, которые чаще всего просят обновить приложения при их установке, не строят зависимость на обновление остальных qt5 пакетов.
Конечно, если зайти в Synaptic и вручную прокликать обновление каждого qt5 пакета, то проблема не возникнет и не потребуется обновление системы. Но обновление 1 из пакетов qt5 не требует автоматически обновления остальных пакетов qt5. Может можно это как-то прописать, чтобы при обновлении одного из таких пакетов шло обновление всех пакетов?

Аватара пользователя

rogoznik
Сообщения: 6348
Зарегистрирован: 27 июн 2017, 10:36
Решено: 71
Откуда: Нижний Тагил
Благодарил (а): 336 раз
Поблагодарили: 1158 раз

Установка kde приложения = краш системы

Сообщение rogoznik » 10 дек 2019, 15:56

MrTowelie, тут нужно понимать. Если собрался что-то установить, а у тебя не обновлена система - сначала обнови систему и только потом устанавливай что хотел
ИзображениеИзображение

Аватара пользователя

x230
Сообщения: 1804
Зарегистрирован: 02 сен 2016, 19:07
Решено: 5
Откуда: Курилы/Сахалин/Кубань
Благодарил (а): 303 раза
Поблагодарили: 436 раз

Установка kde приложения = краш системы

Сообщение x230 » 10 дек 2019, 16:57

MrTowelie, для решения твоей проблемы попробуй найти отдельный пакет deb и не одной версии, а нескольких, и поиграйся с ними. Какая-то да установится без траблов.
i3-3210/4GB/VGA на борту//Manjaro/5.4.*/x64/KDE Plasma 5.17.5/Chromium 80.*
N5000/4GB/VGA на борту/SSD 256//KDE neon/5.3.*/x64/KDE Plasma 5.18/SlimJet 25.*

Вернуться в «Deb-based [Debian / Neon / Ubuntu]»