Решение маленьких проблем с Samba в Linux Mint 19.2 Mate

Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

Автор темы
ppp
Сообщения: 19
Зарегистрирован: 03 дек 2018, 13:08
Поблагодарили: 1 раз

Решение маленьких проблем с Samba в Linux Mint 19.2 Mate

Сообщение ppp » 22 сен 2019, 10:30

Из Ubuntu 18.04 выпилили gksu, отсюда растут ноги с проблемой запуска некоторых системных программ. Например при установки Samba. Между Ubuntu Mate и Linux Mint Mate есть еще есть разница в установленных файлах. Почему то минт по дефолту ставит не все нужные файлы (проверялось только с Mate!). Но если нужен просто доступ к винде, то это не критично.
Если Samba настраивается только через smb.conf, то вроде как все в норме, но если по условиям задачи обязательна нужна графическая утилита, то вылезают проблемы с отсутствием в системе gksu. Например system-config-samba не работает, т.к. при запуске у него не хватает прав на создание файла libuser.conf. Решается данная проблема очень просто - нужно создать файл libuser.conf вручную, работает даже пустой файл:

Код: Выделить всё

sudo touch /etc/libuser.conf

Аватара пользователя

etamax
Сообщения: 1231
Зарегистрирован: 16 дек 2017, 18:59
Решено: 8
Благодарил (а): 5 раз
Поблагодарили: 85 раз

Решение маленьких проблем с Samba в Linux Mint 19.2 Mate

Сообщение etamax » 22 сен 2019, 10:42

Об отсутствии gksu известно , мне понадобилось его поставить как то , пришлось 3 пакета искать по старым убунтовым репам и еще 18 потом сами подтянулись по зависимостям)))


Автор темы
ppp
Сообщения: 19
Зарегистрирован: 03 дек 2018, 13:08
Поблагодарили: 1 раз

Решение маленьких проблем с Samba в Linux Mint 19.2 Mate

Сообщение ppp » 22 сен 2019, 13:11

Я знаю, что gksu был удален из Ubuntu 16.04, т.к. wayland с ним не работал. В 18.04 waylandа нет, но gksu так и не вернули. Да gksu можно установить в 19 минт, но так как gksu удален из репозиториев, а старый без бубна не ставится, то я предложил простой способ решения проблемы. Вяленый нам еще много крови попортит:
https://discourse.ubuntu.com/t/porting- ... land/12670

Аватара пользователя

etamax
Сообщения: 1231
Зарегистрирован: 16 дек 2017, 18:59
Решено: 8
Благодарил (а): 5 раз
Поблагодарили: 85 раз

Решение маленьких проблем с Samba в Linux Mint 19.2 Mate

Сообщение etamax » 22 сен 2019, 14:42

Не по теме
Кровопускание для линуксоидов полезно, глаза будут не такими красными.)))
:-D

Аватара пользователя

darkfenix
Сообщения: 5714
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 314 раз
Поблагодарили: 1055 раз

Решение маленьких проблем с Samba в Linux Mint 19.2 Mate

Сообщение darkfenix » 22 сен 2019, 16:35

В 16.04 gksu еще был, а вот 18.04 его действительно выпилили. Но это было сделано по причине безопасности.
Изображение

Вернуться в «Mate»