Отличия версий Ubuntuu 16.04, 18.04, 19.04 и возможность установки ПО из репозитория

Вы не знаете в какой раздел задать вопрос? Ищите ответы на популярные вопросы? Тогда вам сюда!
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

Автор темы
glorsh66
Сообщения: 1
Зарегистрирован: 12 авг 2019, 12:42

Отличия версий Ubuntuu 16.04, 18.04, 19.04 и возможность установки ПО из репозитория

Сообщение glorsh66 » 12 авг 2019, 12:43

Подскажите относительному нубу Linux, в чем именно заключается отлиия между выпусками Ubuntu 16.04, 18.04, 19.04 и т.д.?
Особенно вопрос относится к возможности и целесобразности (безопасности и наджности) установки пактов из репозитория?

Я понимаю, что есть различные версии сборок системы. Т.е. все сделали - например 18.04 и все, ISO файл для скачки, для этой версии остается таким же.
Однако остается возможность самостоятельно обновлять и/или устанавливать програмнное обеспечение из репозиториев.
Так вот я например сижу на linux mint 19 (для него за основу взять - Ubuntu 18.04 LTS).
Я хочу установить новую программу (Я не понмю точно, в чем была проблема, кажется это был Docker). Однако в стандартных прописанных репозиториях для Ubuntu 18.04 стоит не самая новая версия ПО которое я хочу установить.
При этом в репозиториях для 19.04 есть более свежая версия.


Так вопрос: чем опасно и можно ли так делать постоянно - скачивать ПО из репозиториев для версии старше чем у тебя?
Чем это черевато?
Меняет ли это ситуацию, если я обновил ядро самостоятельно? Или опасность в конфликте мажорных версий разных пакетов?


Также я правильно понимаю что aptitude и другим более сложным пакетным менеджерам пофиг на текущую версию системы, они скачивают зависимости самостоятельно и безопасно?

Аватара пользователя

symon2014
Сообщения: 1361
Зарегистрирован: 16 дек 2017, 18:59
Решено: 8
Откуда: Феодосия
Благодарил (а): 5 раз
Поблагодарили: 93 раза

Отличия версий Ubuntuu 16.04, 18.04, 19.04 и возможность установки ПО из репозитория

Сообщение symon2014 » 12 авг 2019, 12:59

glorsh66 писал(а):
12 авг 2019, 12:43
Ubuntu 16.04, 18.04, 19.04 и т.д.?
Версии 16.04 и 18.04 (год и месяц) LTS с длительным сроком поддержки (5 лет) , 19.04 промежуточная.
Более свежие пакеты при необходимости лучше брать из исходников и компилировать самому (если невтерпёж )))
Изображение

Аватара пользователя

x230
Сообщения: 1675
Зарегистрирован: 02 сен 2016, 19:07
Решено: 5
Откуда: Курилы/Сахалин/Кубань
Благодарил (а): 287 раз
Поблагодарили: 421 раз

Отличия версий Ubuntuu 16.04, 18.04, 19.04 и возможность установки ПО из репозитория

Сообщение x230 » 12 авг 2019, 13:24

etamax писал(а):
12 авг 2019, 12:59
Более свежие пакеты ... лучше брать из исходников и компилировать
Это ты с кем сейчас разговариваешь?
.
glorsh66, Бери версию LM 19.2 Cinnamon, - самый лучший вариант (если "по вкусу" серо-бледно-невзрачно-безвкусный вид).
А уж за софтинку подсуетись сам путём добавления разный реп. - Какие-то подойдут, какие-то нет. Это даже интересно.
А сложного нету ничего (и "компилировать" ничего не надо).
Intel Core i3-3210 / 4GB / VGA - на борту:
1) KDE neon 5.17 / KDE Plasma 5.17.* / 5.0.0-** / Pale Moon 28.* / SlimJet 24.*
2) Linux Mint 18.3 / Cinnamon 3.6.7 / 4.15.0-52 / Pale Moon 28.* / SlimJet 23.*

Аватара пользователя

symon2014
Сообщения: 1361
Зарегистрирован: 16 дек 2017, 18:59
Решено: 8
Откуда: Феодосия
Благодарил (а): 5 раз
Поблагодарили: 93 раза

Отличия версий Ubuntuu 16.04, 18.04, 19.04 и возможность установки ПО из репозитория

Сообщение symon2014 » 12 авг 2019, 14:30

x230 писал(а):
12 авг 2019, 13:24
Это ты с кем сейчас разговариваешь?
Сам собой разговариваю. А ещё я (лол) бывает что и компиляю что нить для себя свеженькое , чего нет в репах.
Изображение

Аватара пользователя

x230
Сообщения: 1675
Зарегистрирован: 02 сен 2016, 19:07
Решено: 5
Откуда: Курилы/Сахалин/Кубань
Благодарил (а): 287 раз
Поблагодарили: 421 раз

Отличия версий Ubuntuu 16.04, 18.04, 19.04 и возможность установки ПО из репозитория

Сообщение x230 » 12 авг 2019, 15:18

etamax писал(а):
12 авг 2019, 14:30
бывает что и компиляю что нить для себя свеженькое , чего нет в репах
Красавчик! :thumbs:
Ну, ты уж не пугай новоначальных сильно-то?! :smile:
А уменя вот руки настолько кривые, что я даже и недумаю в эту сторону. - Максимум заремастерить что-нить...
Вот только Kubuntu 19.04 никак не совмещается с имеющимися у меня инструментами для ремастеринга.
Эту систему я не стал советовать ТС (кто-нить об'яснит мне, как это расшифровывается?), потому как там придётся слишком много допиливать самостоятельно. Хотя... В нынешнем виде Циннамон - тоже не сахар!
Intel Core i3-3210 / 4GB / VGA - на борту:
1) KDE neon 5.17 / KDE Plasma 5.17.* / 5.0.0-** / Pale Moon 28.* / SlimJet 24.*
2) Linux Mint 18.3 / Cinnamon 3.6.7 / 4.15.0-52 / Pale Moon 28.* / SlimJet 23.*

Аватара пользователя

KOT040188
Сообщения: 771
Зарегистрирован: 11 май 2017, 19:01
Решено: 5
Откуда: РБ
Благодарил (а): 13 раз
Поблагодарили: 35 раз

Отличия версий Ubuntuu 16.04, 18.04, 19.04 и возможность установки ПО из репозитория

Сообщение KOT040188 » 12 авг 2019, 15:48

glorsh66 писал(а):
12 авг 2019, 12:43
Так вопрос: чем опасно и можно ли так делать постоянно - скачивать ПО из репозиториев для версии старше чем у тебя?
Чем это черевато
Поломкой системы. Только безумец будет так делать. Если нужны свежие версии ПО, можно перейти на новую версию дистрибутива, можно добавить нужный ppa с ланчпада и в конце концов собрать самому из исходников. Если какими-то докерами балуешься (не в курсе что это), то и собрать сможешь.
Вы думаете у котов лёгкая жизнь? А вы попробуйте целый день лизать меховую шапку!
Как бы хотелось однажды проснуться, а тебе 8 лет и вся эта херня просто приснилась…
Чудесный сон приснился мне когда-то… четыре грузчика несли мою зарплату.

Аватара пользователя

rogoznik
Сообщения: 5821
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 321 раз
Поблагодарили: 1067 раз

Отличия версий Ubuntuu 16.04, 18.04, 19.04 и возможность установки ПО из репозитория

Сообщение rogoznik » 12 авг 2019, 16:41

x230 писал(а):
12 авг 2019, 15:18
ТС (кто-нить об'яснит мне, как это расшифровывается?)
Топик Стартер
glorsh66 писал(а):
12 авг 2019, 12:43
это был Docker
Docker из репозитория лучше вообще не ставить там он протухший даже в убунте19.04. Лучше всего докер ставить от сюда
ИзображениеИзображение

Аватара пользователя

symon2014
Сообщения: 1361
Зарегистрирован: 16 дек 2017, 18:59
Решено: 8
Откуда: Феодосия
Благодарил (а): 5 раз
Поблагодарили: 93 раза

Отличия версий Ubuntuu 16.04, 18.04, 19.04 и возможность установки ПО из репозитория

Сообщение symon2014 » 12 авг 2019, 16:46

Не по теме
darkfenix писал(а):
12 авг 2019, 16:41
Топик Стартер
Афтар. :hoho:
Изображение


Adrian
Сообщения: 58
Зарегистрирован: 11 сен 2016, 16:54
Решено: 1
Благодарил (а): 32 раза
Поблагодарили: 15 раз

Отличия версий Ubuntuu 16.04, 18.04, 19.04 и возможность установки ПО из репозитория

Сообщение Adrian » 12 авг 2019, 19:13

x230 писал(а):
12 авг 2019, 15:18
Вот только Kubuntu 19.04 никак не совмещается с имеющимися у меня инструментами для ремастеринга.
А ffmpeg не пробовали в этой Kubuntu 19.04 устанавливать?
Я что-то репозиториев подходящих не нашёл.
Компилировать самому, что ли, в таком случае надо?

Аватара пользователя

x230
Сообщения: 1675
Зарегистрирован: 02 сен 2016, 19:07
Решено: 5
Откуда: Курилы/Сахалин/Кубань
Благодарил (а): 287 раз
Поблагодарили: 421 раз

Отличия версий Ubuntuu 16.04, 18.04, 19.04 и возможность установки ПО из репозитория

Сообщение x230 » 12 авг 2019, 19:45

Adrian писал(а):
12 авг 2019, 19:13
ffmpeg
не знаю как там с этим... но вот flash plugin в SlimJet'е не завелся. Уже пару бубунов изнахратил, да безтолку... :sad:
Intel Core i3-3210 / 4GB / VGA - на борту:
1) KDE neon 5.17 / KDE Plasma 5.17.* / 5.0.0-** / Pale Moon 28.* / SlimJet 24.*
2) Linux Mint 18.3 / Cinnamon 3.6.7 / 4.15.0-52 / Pale Moon 28.* / SlimJet 23.*


Adrian
Сообщения: 58
Зарегистрирован: 11 сен 2016, 16:54
Решено: 1
Благодарил (а): 32 раза
Поблагодарили: 15 раз

Отличия версий Ubuntuu 16.04, 18.04, 19.04 и возможность установки ПО из репозитория

Сообщение Adrian » 12 авг 2019, 20:03

:smile: С флеш плеером сам только вчера в Кубунте морочился.
Надо было вот эту детскую игру запустить (это я не спрашиваю, просто пример):
http://multoigri.ru/game/igra-padaushie-peski

В Linux Mint Mate нормально. В Кубунте не пойму. То работает, то не работает.
Я поигрался и c peppermint и adobe плеером. И ещё всяким, что в поисковике нашёл...

Аватара пользователя

rogoznik
Сообщения: 5821
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 321 раз
Поблагодарили: 1067 раз

Отличия версий Ubuntuu 16.04, 18.04, 19.04 и возможность установки ПО из репозитория

Сообщение rogoznik » 13 авг 2019, 03:07

Adrian писал(а):
12 авг 2019, 19:13
А ffmpeg не пробовали в этой Kubuntu 19.04 устанавливать?
Я что-то репозиториев подходящих не нашёл.
Компилировать самому, что ли, в таком случае надо?
Вот интересно как искали? Он там в родных репах лежит, ничего не нужно добавлять и тем более компилять https://packages.ubuntu.com/disco/ffmpeg
ИзображениеИзображение


Adrian
Сообщения: 58
Зарегистрирован: 11 сен 2016, 16:54
Решено: 1
Благодарил (а): 32 раза
Поблагодарили: 15 раз

Отличия версий Ubuntuu 16.04, 18.04, 19.04 и возможность установки ПО из репозитория

Сообщение Adrian » 13 авг 2019, 15:10

darkfenix, спасибо, навели меня на правильную мысль. Я не в ту сторону копал.

Если коротко, то это новый компьютер, на который я поставил "старый" жёсткий диск. На диске раньше был установлен Linux Mint KDE. Теперь Kubuntu.

В общем, остатки старого ffmpeg конфликтовали с новым. (Я /home не форматировал.)
Я стёр старый и новый ffmpeg и установил заново. Всё нормально, вроде бы.

Вернуться в «Вопрос новичка и FaQ»