Проблемы при обновлении пакета gconf2 на linux mint 19.1x64 Cinnamon

Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

Автор темы
Muser
Сообщения: 3
Зарегистрирован: 26 июн 2019, 20:57
Благодарил (а): 1 раз

Проблемы при обновлении пакета gconf2 на linux mint 19.1x64 Cinnamon

Сообщение Muser » 26 июн 2019, 21:05


При попытке обновить все пакеты через apt upgrade возникла проблема с тем, что не может обновить пакет gconf2. Когда в дальнейшем попробовал удалить пакет через apt remove выдало следующее

Код: Выделить всё

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты будут УДАЛЕНЫ:
  gconf2 tomboy
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 2 пакетов, и 280 пакетов не обновлено.
Установлено или удалено не до конца 121 пакетов.
После данной операции объём занятого дискового пространства уменьшится на 11,0 MB.
Хотите продолжить? [Д/н] д
dpkg: проблемы зависимостей не позволяют выполнить обработку триггеров gconf2:
 gconf2 зависит от default-dbus-session-bus | dbus-session-bus, однако:
  Пакет default-dbus-session-bus не установлен.
  Пакет dbus-user-session, предоставляющий default-dbus-session-bus, пока не настроен.
  Пакет dbus-session-bus не установлен.
  Пакет dbus-user-session, предоставляющий dbus-session-bus, пока не настроен.
  Пакет dbus-x11, предоставляющий dbus-session-bus, пока не настроен.
Попробовал установить default-dbus-session-bus, но там требуется выбрать из

Код: Выделить всё

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Пакет dbus-session-bus — виртуальный, его функции предоставляются пакетами:
  dbus-x11:i386 1.12.2-1ubuntu1.1
  dbus-user-session:i386 1.12.2-1ubuntu1.1
  dbus-x11 1.12.2-1ubuntu1.1
  dbus-user-session 1.12.2-1ubuntu1.1
Вы должны явно указать, какой именно вы хотите установить.

E: Для пакета «dbus-session-bus» не найден кандидат на установку
Что из этого списка выбрать? Может есть какой-то другой способ решения проблемы? (за неточности заранее прошу прощения, пока являюсь новичком )

Решение Dja » 26 июн 2019, 21:37
Параметры - источники приложений (пакетов или как там) Там переходим в обслуживание и жмакаем поочередно на кнопочки обслуживания. Затем пытаемся обновить список пакетов.

Перейти к ответу ➙

Аватара пользователя

Dja
Сообщения: 6228
Зарегистрирован: 27 авг 2016, 17:03
Решено: 27
Откуда: Voskresensk
Благодарил (а): 927 раз
Поблагодарили: 662 раза

Проблемы при обновлении пакета gconf2 на linux mint 19.1x64 Cinnamon

Сообщение Dja » 26 июн 2019, 21:14

Код: Выделить всё

sudo apt install -f
А вообще тут еще вопрос что было выше... в самом ли деле был sudo apt upgrade... Да и что понадобавлено в репы.


Автор темы
Muser
Сообщения: 3
Зарегистрирован: 26 июн 2019, 20:57
Благодарил (а): 1 раз

Проблемы при обновлении пакета gconf2 на linux mint 19.1x64 Cinnamon

Сообщение Muser » 26 июн 2019, 21:35

Dja писал(а):
26 июн 2019, 21:14

Код: Выделить всё

sudo apt install -f
А вообще тут еще вопрос что было выше... в самом ли деле был sudo apt upgrade... Да и что понадобавлено в репы.
Мамой клянусь, что было udo apt upgrade). К сожалению ваша команда не помогла, все еще жалуется на отсутствие default-dbus-session-bus. Да и в репах должно быть все в порядке, т.к. система не так давно поставлена, и руки еще туда не дошли просто.

Аватара пользователя

Dja
Сообщения: 6228
Зарегистрирован: 27 авг 2016, 17:03
Решено: 27
Откуда: Voskresensk
Благодарил (а): 927 раз
Поблагодарили: 662 раза

Проблемы при обновлении пакета gconf2 на linux mint 19.1x64 Cinnamon

Сообщение Dja » 26 июн 2019, 21:37

Параметры - источники приложений (пакетов или как там) Там переходим в обслуживание и жмакаем поочередно на кнопочки обслуживания. Затем пытаемся обновить список пакетов.


Автор темы
Muser
Сообщения: 3
Зарегистрирован: 26 июн 2019, 20:57
Благодарил (а): 1 раз

Проблемы при обновлении пакета gconf2 на linux mint 19.1x64 Cinnamon

Сообщение Muser » 26 июн 2019, 21:52

Dja писал(а):
26 июн 2019, 21:37
Параметры - источники приложений (пакетов или как там) Там переходим в обслуживание и жмакаем поочередно на кнопочки обслуживания. Затем пытаемся обновить список пакетов.
Спасибо большое, проблема решена)

Аватара пользователя

Dja
Сообщения: 6228
Зарегистрирован: 27 авг 2016, 17:03
Решено: 27
Откуда: Voskresensk
Благодарил (а): 927 раз
Поблагодарили: 662 раза

Проблемы при обновлении пакета gconf2 на linux mint 19.1x64 Cinnamon

Сообщение Dja » 26 июн 2019, 21:55

Muser, и вам добра! :vic: :close:

Вернуться в «Cinnamon»