Установка зависимостей Gajim-nightly

Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
Аватара пользователя

Автор темы
zxc12
Сообщения: 29
Зарегистрирован: 22 ноя 2017, 12:04
Решено: 1
Благодарил (а): 5 раз

Установка зависимостей Gajim-nightly

Сообщение zxc12 » 13 янв 2019, 13:35

Приветствую lm_users

Подскажите что не так, пытаюсь установить gajim v1 в домашних репах доступна только v0.16.5.
Всё делаю как описано на офф сайте

При выполнении команды install терминал выдаёт:

Код: Выделить всё

⏩ ⏩ $ sudo apt-get install gajim-nightly
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимостиc:
 gajim-nightly : Зависит: python3-precis-i18n но он не может быть установлен
                 Зависит: gir1.2-gtk-3.0 (>= 3.22) но 3.18.9-1ubuntu3.3 будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
Делал:
$ sudo apt install -f
$ sudo apt remove --fix-broken
$ sudo apt autoremove


Через aptitude:

Код: Выделить всё

⏩ ⏩ $ sudo aptitude install gajim-nightly
Следующие НОВЫЕ пакеты будут установлены:        
  gajim-nightly{b} 
0 пакетов обновлено, 1 установлено новых, 0 пакетов отмечено для удаления, и 1 пакетов не обновлено.
Необходимо получить 6 115 kБ архивов. После распаковки 17,7 MБ будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 gajim-nightly : Зависит: python3-precis-i18n which is a virtual package and is not provided by any available package.

                 Зависит: gir1.2-gtk-3.0 (>= 3.22) но установлен 3.18.9-1ubuntu3.3.
Следующие действия разрешат зависимости:

     Оставить для следующих пакетов их текущие версии:
1)     gajim-nightly [Не установлен]                  



Принять данное решение? [Y/n/q/?] y
Ни одного пакета не будет установлено, обновлено или удалено.
0 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 1 пакетов не обновлено.
Необходимо получить 0 Б архивов. После распаковки 0 Б будет занято.
⏩ ⏩ $ inxi -Fxz
System: Host: linux Kernel: 4.11.12-041112-generic x86_64 (64 bit gcc: 6.3.0)
Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18.1 Serena
Machine: Mobo: MICRO-STAR model: P35 Platinum(MS-7345) v: 1.0
Bios: American Megatrends v: V1.12 date: 12/30/2009
CPU: Quad core Intel Xeon E5472 (-HT-MCP-) cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 26333
clock speeds: max: 3291 MHz 1: 3291 MHz 2: 3291 MHz 3: 3291 MHz 4: 3291 MHz
Graphics: Card: NVIDIA GF114 [GeForce GTX 560] bus-ID: 01:00.0
Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
Resolution: 1680x1050@59.88hz, 1366x768@59.79hz
GLX Renderer: GeForce GTX 560/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 384.130 Direct Rendering: Yes
Audio: Card-1 NVIDIA GF114 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
Card-2 Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.11.12-041112-generic
Network: Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: d800 bus-ID: 04:00.0
IF: enp4s0 state: down mac: <filter>
Card-2: VIA VT6105/VT6106S [Rhine-III] driver: via-rhine port: e800 bus-ID: 05:01.0
IF: enp5s1 state: unknown speed: 100 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 1516.2GB (8.1% used) ID-1: /dev/sda model: WDC_WD15EARS size: 1500.3GB temp: 28C
ID-2: USB /dev/sdf model: Storage_Device size: 15.9GB temp: 0C
Partition: ID-1: / size: 65G used: 13G (21%) fs: ext4 dev: /dev/sda5
ID-2: /home size: 138G used: 100G (77%) fs: ext4 dev: /dev/sda7
ID-3: swap-1 size: 2.05GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 54.0C mobo: N/A gpu: 0.0:62C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 261 Uptime: 6:04 Memory: 3835.1/7981.4MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35
Читать написанное транслитом — это как читать написанное фекалиями на стене: вроде и понятно все, и все равно неприятно.

Аватара пользователя

zuzabrik
Сообщения: 1594
Зарегистрирован: 29 авг 2016, 09:08
Решено: 19
Благодарил (а): 103 раза
Поблагодарили: 500 раз

Установка зависимостей Gajim-nightly

Сообщение zuzabrik » 13 янв 2019, 14:10

Минт 18.3 стоит? Потому что в 19.1 там версия уже 1.0.1-3
zxc12 писал(а):
13 янв 2019, 13:35
Зависит: python3-precis-i18n
Проблема в этом. Менеджер пакетов не находит его среди репозиториев. И походу такого пакета в 18.3 нет. Тебе придется еще его добавить в систему, благо среди зависимостей у него только python3

https://packages.debian.org/sid/python3-precis-i18n

Я бы использовал gajim тот что из пакетов самого репозитория дистрибутива, а не гнался за номером версии. Тем более что это ежедневные ночные сборки, и они могут быть нестабильны.

Тем не менее я попробовал поставить по инструкции на своей виртуалке с 19.1 минтом и у меня все прошло без проблем. Ошибок нет, сборка установилась.
Наш IRC-канал для общения: #linuxmint-ru на сервере irc.spotchat.org
Для захода откройте HexChat, выберите сервер Linux Mint и наберите в чате /join #linuxmint-ru
Или любым другим удобным способом ;)

Аватара пользователя

Автор темы
zxc12
Сообщения: 29
Зарегистрирован: 22 ноя 2017, 12:04
Решено: 1
Благодарил (а): 5 раз

Установка зависимостей Gajim-nightly

Сообщение zxc12 » 13 янв 2019, 14:19

zuzabrik писал(а):
13 янв 2019, 14:10
Минт 18.3 стоит?
18.1 Serena
zuzabrik писал(а):
13 янв 2019, 14:10
Зависит: python3-precis-i18n
Частично решило проблему, но всё же:

Код: Выделить всё

⏩ ⏩ $ sudo aptitude install gajim-nightly
Следующие НОВЫЕ пакеты будут установлены:        
  gajim-nightly{b} 
0 пакетов обновлено, 1 установлено новых, 0 пакетов отмечено для удаления, и 1 пакетов не обновлено.
Необходимо получить 6 115 kБ архивов. После распаковки 17,7 MБ будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 gajim-nightly : Зависит: gir1.2-gtk-3.0 (>= 3.22) но установлен 3.18.9-1ubuntu3.3.
Следующие действия разрешат зависимости:

     Оставить для следующих пакетов их текущие версии:
1)     gajim-nightly [Не установлен]                  



Принять данное решение? [Y/n/q/?] y
Ни одного пакета не будет установлено, обновлено или удалено.
0 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 1 пакетов не обновлено.
Необходимо получить 0 Б архивов. После распаковки 0 Б будет занято.
Читать написанное транслитом — это как читать написанное фекалиями на стене: вроде и понятно все, и все равно неприятно.

Аватара пользователя

zuzabrik
Сообщения: 1594
Зарегистрирован: 29 авг 2016, 09:08
Решено: 19
Благодарил (а): 103 раза
Поблагодарили: 500 раз

Установка зависимостей Gajim-nightly

Сообщение zuzabrik » 13 янв 2019, 14:26

Небольшое дополнение. Gajim при установке по инструкции на 19.1 не завелся.

Код: Выделить всё

$ gajim
Found default language: ru
Gajim needs python-nbxmpp >= 0.6.9 to run. Quitting...
Для того чтобы заработало я залез в synaptic, установил вместо python-nbxmpp версию python-nbxmpp-nightly и версию gajim-default-nightly вместо gajim-nightly.

После этого клиент запустился и открылось окно с просьбой ввести данные учетки.
zxc12 писал(а):
13 янв 2019, 14:19
Зависит: gir1.2-gtk-3.0
Ну, теперь жалуется на то что более старой версии чем хочет gajim. Попробуй сменить gajim-nightly на gajim-default-nightly, если не поможет или обманывать систему делая символическую ссылку на старую либу, либо ставить новую версию либы gir.
Наш IRC-канал для общения: #linuxmint-ru на сервере irc.spotchat.org
Для захода откройте HexChat, выберите сервер Linux Mint и наберите в чате /join #linuxmint-ru
Или любым другим удобным способом ;)

Аватара пользователя

Автор темы
zxc12
Сообщения: 29
Зарегистрирован: 22 ноя 2017, 12:04
Решено: 1
Благодарил (а): 5 раз

Установка зависимостей Gajim-nightly

Сообщение zxc12 » 13 янв 2019, 14:31

zuzabrik писал(а):
13 янв 2019, 14:26
установил вместо python-nbxmpp версию python-nbxmpp-nightly
Сделал.
При попытке установить gajim-default-nightly
synaptic_007.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Читать написанное транслитом — это как читать написанное фекалиями на стене: вроде и понятно все, и все равно неприятно.

Аватара пользователя

zuzabrik
Сообщения: 1594
Зарегистрирован: 29 авг 2016, 09:08
Решено: 19
Благодарил (а): 103 раза
Поблагодарили: 500 раз

Установка зависимостей Gajim-nightly

Сообщение zuzabrik » 13 янв 2019, 14:32

zxc12 писал(а):
13 янв 2019, 14:31
При попытке установить gajim-default-nightly
Или обманывать систему делая символическую ссылку на старую либу, либо ставить новую версию либы gir.
Наш IRC-канал для общения: #linuxmint-ru на сервере irc.spotchat.org
Для захода откройте HexChat, выберите сервер Linux Mint и наберите в чате /join #linuxmint-ru
Или любым другим удобным способом ;)

Вернуться в «Иные системные ошибки»