Битые пакеты и зависимости

Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

Автор темы
Xiomon
Сообщения: 14
Зарегистрирован: 31 июл 2018, 14:36
Благодарил (а): 2 раза

Битые пакеты и зависимости

Сообщение Xiomon » 07 авг 2018, 06:01

E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
E: Ошибка, pkgProblemResolver::Resolve сгенерировал повреждённые пакеты. Это может быть вызвано отложенными (held) пакетами.
Что делать чтобы исправить хочу установить одну программу ей нужен"npm". Когда пытаюсь установить мне пишут про зависимости и про битые пакеты.

Решение Chocobo » 07 авг 2018, 07:22
Xiomon писал(а):
07 авг 2018, 07:12
*** 1.0.2l-1~bpo8+1 100
100 /var/lib/dpkg/status
Вручную был натянут этот пакет libssl со стороны зачем-то. Переустанавливай сперва его на те версии что доступны в репозитории.
apt install libssl1.0.0=1.0.2g-1ubuntu4.13

Перейти к ответу ➙


Автор темы
Xiomon
Сообщения: 14
Зарегистрирован: 31 июл 2018, 14:36
Благодарил (а): 2 раза

Битые пакеты и зависимости

Сообщение Xiomon » 07 авг 2018, 06:17

Вот логи:
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
npm : Зависит: node-gyp (>= 0.10.9) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
node-gyp : Зависит: nodejs-dev но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
nodejs-dev : Зависит: libssl-dev (>= 1.0.0g) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
libssl-dev : Зависит: libssl1.0.0 (= 1.0.2g-1ubuntu4.13) но 1.0.2l-1~bpo8+1 будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.


Автор темы
Xiomon
Сообщения: 14
Зарегистрирован: 31 июл 2018, 14:36
Благодарил (а): 2 раза

Битые пакеты и зависимости

Сообщение Xiomon » 07 авг 2018, 06:22

Linux Mint 18.3

Аватара пользователя

Chocobo
Сообщения: 9268
Зарегистрирован: 27 авг 2016, 19:57
Решено: 200
Откуда: НН
Благодарил (а): 645 раз
Поблагодарили: 2677 раз

Битые пакеты и зависимости

Сообщение Chocobo » 07 авг 2018, 06:34

Xiomon, покажи apt policy libssl1.0.0
Изображение
   
Изображение

Аватара пользователя

Chocobo
Сообщения: 9268
Зарегистрирован: 27 авг 2016, 19:57
Решено: 200
Откуда: НН
Благодарил (а): 645 раз
Поблагодарили: 2677 раз

Битые пакеты и зависимости

Сообщение Chocobo » 07 авг 2018, 06:39

Xiomon писал(а):
07 авг 2018, 06:17
libssl1.0.0-1.0.2l-1~bpo8+1
Чет мне этот суффикс подозрительно betsy/jessie напоминает. :scratch:

Заодно покажи еще inxi -r
Изображение
   
Изображение

Аватара пользователя

Unborn
Сообщения: 1778
Зарегистрирован: 03 сен 2016, 10:36
Решено: 24
Благодарил (а): 4 раза
Поблагодарили: 253 раза

Битые пакеты и зависимости

Сообщение Unborn » 07 авг 2018, 06:50

Chocobo писал(а):
07 авг 2018, 06:39
Чет мне этот суффикс подозрительно betsy/jessie напоминает.
Xiomon писал(а):
07 авг 2018, 06:01
хочу установить одну программу ей нужен"npm".
npm - это менеджер пакетов nodejs, но он не обязательная зависимость.
Xiomon писал(а):
07 авг 2018, 06:01
Когда пытаюсь установить мне пишут про зависимости и про битые пакеты.
Попытка установить не понимая что, как, а главное - зачем?
Если просто, что в Синаптике, что в Терминале установить nodejs + npm. Или у Минт нет Node?

Аватара пользователя

Chocobo
Сообщения: 9268
Зарегистрирован: 27 авг 2016, 19:57
Решено: 200
Откуда: НН
Благодарил (а): 645 раз
Поблагодарили: 2677 раз

Битые пакеты и зависимости

Сообщение Chocobo » 07 авг 2018, 06:55

Unborn, да я про сам пакет libssl с суффиксом bpo8 - это же обычно jessie-backports, и откуда он такой нарисовался в 18.3 - абсолютно неясно :)
https://packages.debian.org/jessie-back ... ibssl1.0.0
Изображение
   
Изображение

Аватара пользователя

rogoznik
Сообщения: 5795
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 321 раз
Поблагодарили: 1064 раза

Битые пакеты и зависимости

Сообщение rogoznik » 07 авг 2018, 07:07

Xiomon, а что ты вообще пытался установить?
ИзображениеИзображение


Автор темы
Xiomon
Сообщения: 14
Зарегистрирован: 31 июл 2018, 14:36
Благодарил (а): 2 раза

Битые пакеты и зависимости

Сообщение Xiomon » 07 авг 2018, 07:12

Chocobo писал(а):
07 авг 2018, 06:34
Xiomon, покажи apt policy libssl1.0.0

Код: Выделить всё

libssl1.0.0:
  Установлен: 1.0.2l-1~bpo8+1
  Кандидат:   1.0.2l-1~bpo8+1
  Таблица версий:
 *** 1.0.2l-1~bpo8+1 100
        100 /var/lib/dpkg/status
     1.0.2g-1ubuntu4.13 500
        500 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
     1.0.2g-1ubuntu4 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages


Автор темы
Xiomon
Сообщения: 14
Зарегистрирован: 31 июл 2018, 14:36
Благодарил (а): 2 раза

Битые пакеты и зависимости

Сообщение Xiomon » 07 авг 2018, 07:12

Chocobo писал(а):
07 авг 2018, 06:39
Xiomon писал(а):
07 авг 2018, 06:17
libssl1.0.0-1.0.2l-1~bpo8+1
Чет мне этот суффикс подозрительно betsy/jessie напоминает. :scratch:

Заодно покажи еще inxi -r

Код: Выделить всё

Repos:     Active apt sources in file: /etc/apt/sources.list.d/additional-repositories.list
           deb https://dl.winehq.org/wine-builds/ubuntu/ xenial main
           Active apt sources in file: /etc/apt/sources.list.d/cubic-wizard-release-xenial.list
           deb http://ppa.launchpad.net/cubic-wizard/release/ubuntu xenial main
           deb-src http://ppa.launchpad.net/cubic-wizard/release/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/damien-moore-codeblocks-stable-xenial.list
           deb http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu xenial main
           deb-src http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/gezakovacs-ppa-xenial.list
           deb http://ppa.launchpad.net/gezakovacs/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/gezakovacs/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/gns3-ppa-xenial.list
           deb http://ppa.launchpad.net/gns3/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/gns3/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/google.list
           deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/graphics-drivers-ppa-xenial.list
           deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/haraldhv-shotcut-xenial.list
           deb http://ppa.launchpad.net/haraldhv/shotcut/ubuntu xenial main
           deb-src http://ppa.launchpad.net/haraldhv/shotcut/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/maarten-baert-simplescreenrecorder-xenial.list
           deb http://ppa.launchpad.net/maarten-baert/simplescreenrecorder/ubuntu xenial main
           deb-src http://ppa.launchpad.net/maarten-baert/simplescreenrecorder/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/makehuman-official-makehuman-11x-xenial.list
           deb http://ppa.launchpad.net/makehuman-official/makehuman-11x/ubuntu xenial main
           deb-src http://ppa.launchpad.net/makehuman-official/makehuman-11x/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/morphis-anbox-support-xenial.list
           deb http://ppa.launchpad.net/morphis/anbox-support/ubuntu xenial main
           deb-src http://ppa.launchpad.net/morphis/anbox-support/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/obsproject-obs-studio-xenial.list
           deb http://ppa.launchpad.net/obsproject/obs-studio/ubuntu xenial main
           deb-src http://ppa.launchpad.net/obsproject/obs-studio/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com sylvia main upstream import backport #id:linuxmint_main
           deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
           Active apt sources in file: /etc/apt/sources.list.d/oibaf-graphics-drivers-xenial.list
           deb http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial main
           deb-src http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/openshot_developers-ppa-xenial.list
           deb http://ppa.launchpad.net/openshot.developers/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/openshot.developers/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/skype-stable.list
           deb [arch=amd64] https://repo.skype.com/deb stable main
           Active apt sources in file: /etc/apt/sources.list.d/ubuntu-wine-ppa-xenial.list
           deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/webupd8team-haguichi-xenial.list
           deb http://ppa.launchpad.net/webupd8team/haguichi/ubuntu xenial main
           deb-src http://ppa.launchpad.net/webupd8team/haguichi/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/webupd8team-java-xenial.list
           deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main
           deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/wine-wine-builds-xenial.list
           deb http://ppa.launchpad.net/wine/wine-builds/ubuntu xenial main
           deb-src http://ppa.launchpad.net/wine/wine-builds/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/xorg-edgers-ppa-xenial.list
           deb http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/yandex-browser-beta.list
           deb [arch=amd64] http://repo.yandex.ru/yandex-browser/deb beta main
           Active apt sources in file: /etc/apt/sources.list.d/yandex-disk.list
           deb http://repo.yandex.ru/yandex-disk/deb/ stable main


Автор темы
Xiomon
Сообщения: 14
Зарегистрирован: 31 июл 2018, 14:36
Благодарил (а): 2 раза

Битые пакеты и зависимости

Сообщение Xiomon » 07 авг 2018, 07:14

darkfenix писал(а):
07 авг 2018, 07:07
Xiomon, а что ты вообще пытался установить?
Unity Editor AMD64 2017.2.0b11

Аватара пользователя

Chocobo
Сообщения: 9268
Зарегистрирован: 27 авг 2016, 19:57
Решено: 200
Откуда: НН
Благодарил (а): 645 раз
Поблагодарили: 2677 раз

Битые пакеты и зависимости

Сообщение Chocobo » 07 авг 2018, 07:22

Xiomon писал(а):
07 авг 2018, 07:12
*** 1.0.2l-1~bpo8+1 100
100 /var/lib/dpkg/status
Вручную был натянут этот пакет libssl со стороны зачем-то. Переустанавливай сперва его на те версии что доступны в репозитории.
apt install libssl1.0.0=1.0.2g-1ubuntu4.13
Изображение
   
Изображение


Автор темы
Xiomon
Сообщения: 14
Зарегистрирован: 31 июл 2018, 14:36
Благодарил (а): 2 раза

Битые пакеты и зависимости

Сообщение Xiomon » 07 авг 2018, 07:27

Спасибо, Chocobo

Вернуться в «Cinnamon»