проблемы с видео VIA

Не знаете как установить драйвер? Возникли проблемы? Вам сюда!
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

Автор темы
ReznikOFF
Сообщения: 4
Зарегистрирован: 14 июн 2018, 07:06
Решено: 1
Откуда: Магнитогорск

проблемы с видео VIA

Сообщение ReznikOFF » 21 июн 2018, 05:11

имеем MSI P4900M2 с чипом VT8237A при установке системы разрешение достаточно корректно, скрины ниже с live-CD но после установки системы разрешение 640x480 не меняется :help:

Код: Выделить всё

mint@mint-MS-7255 ~ $ inxi -Fxz
System:    Host: mint-MS-7255 Kernel: 4.13.0-45-generic i686 (32 bit gcc: 5.4.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: DEPO s product: MS-7255 v: 2.0
           Mobo: Micro-Star model: MS-7255 v: 2.0
           Bios: American Megatrends v: V5.5B14 date: 08/29/2007
CPU:       Dual core Intel 2140 (-MCP-) cache: 1024 KB
           flags: (lm nx pae sse sse2 sse3 ssse3) bmips: 6399
           clock speeds: max: 1251 MHz 1: 1251 MHz 2: 1208 MHz
Graphics:  Card: VIA CN896/VN896/P4M900 [Chrome 9 HC] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: fbdev (unloaded: vesa)
           Resolution: 640x480@73.00hz
           GLX Renderer: llvmpipe (LLVM 5.0, 128 bits)
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card VIA VT8237A/VT8251 HDA Controller
           driver: snd_hda_intel bus-ID: 80:01.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-45-generic
Network:   Card: VIA VT6102/VT6103 [Rhine-II]
           driver: via-rhine port: d000 bus-ID: 00:12.0
           IF: enp0s18 state: unknown speed: 100 Mbps duplex: full
           mac: <filter>
Drives:    HDD Total Size: 160.0GB (5.8% used)
           ID-1: /dev/sda model: WDC_WD1600AAJS size: 160.0GB
Partition: ID-1: / size: 74G used: 5.9G (9%) fs: ext4 dev: /dev/sda5
           ID-2: /home size: 71G used: 812M (2%) fs: ext4 dev: /dev/sda7
           ID-3: /boot size: 453M used: 125M (30%) fs: ext4 dev: /dev/sda1
           ID-4: swap-1 size: 2.05GB used: 0.01GB (1%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 49.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 150 Uptime: 22 min Memory: 209.3/868.9MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
хотя по железу всё определяется корректно но вот разрешение остается не совсем удобным

Код: Выделить всё

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
   640x480       73.00* 

Код: Выделить всё

lspci | grep VGA
01:00.0 VGA compatible controller: VIA Technologies, Inc. CN896/VN896/P4M900 [Chrome 9 HC] (rev 01)
перелопатил кучу инфы но не чего не помогает, подскажите куда копать?

Решение ReznikOFF » 21 июн 2018, 07:51
решено :yahoo:

Код: Выделить всё

sudo apt-get install xserver-xorg-video-openchrome
после этого видео на чипе VIA работает корректно

пытался решить эту проблему больше месяца, все форумы перерыл, и тут наткнулся на эту статью

Код: Выделить всё

https://itshaman.ru/articles/57/draivera-na-videokarty-nvidia-radeon-intel-i-via-chrome-v-linux-ubuntu
мне достаточно было установить xorg, всем спасибо за проявленный интерес :hshake:

Перейти к ответу ➙
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя

WWolf
Сообщения: 1275
Зарегистрирован: 13 фев 2018, 21:51
Решено: 5
Откуда: Краснодар
Благодарил (а): 445 раз
Поблагодарили: 293 раза

проблемы с видео VIA

Сообщение WWolf » 21 июн 2018, 05:20

ReznikOFF, в ядро... Лайв на 4.10, а ты на 4.13 сидишь...

Аватара пользователя

darkfenix
Сообщения: 5404
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 295 раз
Поблагодарили: 1004 раза

проблемы с видео VIA

Сообщение darkfenix » 21 июн 2018, 05:24

Открой Менеджер обновлений, Вид, Обновление ядра линукс. И поставь крайнее ядро из ветки 4.4.
Изображение


Автор темы
ReznikOFF
Сообщения: 4
Зарегистрирован: 14 июн 2018, 07:06
Решено: 1
Откуда: Магнитогорск

проблемы с видео VIA

Сообщение ReznikOFF » 21 июн 2018, 05:45

хм народ я не знаю что произошло, но система после переустановки пришла в норму, хотя до этого обновлял, и перезагружал 100500 раз

Код: Выделить всё

mint@mint-MS-7255 ~ $ inxi -Fxz
System:    Host: mint-MS-7255 Kernel: 4.13.0-45-generic i686 (32 bit gcc: 5.4.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18.3 Sylvia
Machine:   System: DEPO s product: MS-7255 v: 2.0
           Mobo: Micro-Star model: MS-7255 v: 2.0
           Bios: American Megatrends v: V5.5B14 date: 08/29/2007
CPU:       Dual core Intel 2140 (-MCP-) cache: 1024 KB
           flags: (lm nx pae sse sse2 sse3 ssse3) bmips: 6399
           clock speeds: max: 1256 MHz 1: 1256 MHz 2: 1205 MHz
Graphics:  Card: VIA CN896/VN896/P4M900 [Chrome 9 HC] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: openchrome (unloaded: fbdev,vesa)
           Resolution: 1280x1024@60.02hz
           GLX Renderer: llvmpipe (LLVM 5.0, 128 bits)
           GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio:     Card VIA VT8237A/VT8251 HDA Controller
           driver: snd_hda_intel bus-ID: 80:01.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-45-generic
Network:   Card: VIA VT6102/VT6103 [Rhine-II]
           driver: via-rhine port: d000 bus-ID: 00:12.0
           IF: enp0s18 state: unknown speed: 100 Mbps duplex: full
           mac: <filter>
Drives:    HDD Total Size: 160.0GB (5.8% used)
           ID-1: /dev/sda model: WDC_WD1600AAJS size: 160.0GB
Partition: ID-1: / size: 74G used: 5.9G (9%) fs: ext4 dev: /dev/sda5
           ID-2: /boot size: 453M used: 125M (30%) fs: ext4 dev: /dev/sda1
           ID-3: /home size: 71G used: 842M (2%) fs: ext4 dev: /dev/sda7
           ID-4: swap-1 size: 2.05GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 55.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 153 Uptime: 9 min Memory: 261.1/869.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
буду смотреть и разбираться, о результатах напишу

Аватара пользователя

Unborn
Сообщения: 1778
Зарегистрирован: 03 сен 2016, 10:36
Решено: 24
Благодарил (а): 4 раза
Поблагодарили: 253 раза

проблемы с видео VIA

Сообщение Unborn » 21 июн 2018, 06:15

ReznikOFF писал(а):
21 июн 2018, 05:45
Graphics: Card: VIA CN896/VN896/P4M900 [Chrome 9 HC] bus-ID: 01:00.0
Display Server: X.Org 1.18.4 drivers: openchrome (unloaded: fbdev,vesa)
Resolution: 1280x1024@60.02hz
Вот так должно быть сразу. С nomodeset что-ли загружался-устанавливал? Хотя бестолковый Каноникалский установщик в порядке вещей через жопу оборудование определяет. Если что, то в Синаптике в поиске via - и руками можно установить пакеты для графики via.


Автор темы
ReznikOFF
Сообщения: 4
Зарегистрирован: 14 июн 2018, 07:06
Решено: 1
Откуда: Магнитогорск

проблемы с видео VIA

Сообщение ReznikOFF » 21 июн 2018, 06:37

Unborn писал(а):
21 июн 2018, 06:15
Вот так должно быть сразу. С nomodeset что-ли загружался-устанавливал? Хотя бестолковый Каноникалский установщик в порядке вещей через жопу оборудование определяет. Если что, то в Синаптике в поиске via - и руками можно установить пакеты для графики via.
возможно пытался поставить драйвера 5.74.33.85a-44597, сейчас пробую на другой машине, что бы понять что помогло, до этого что бы я ни делал всё было без толку :dash2:


Автор темы
ReznikOFF
Сообщения: 4
Зарегистрирован: 14 июн 2018, 07:06
Решено: 1
Откуда: Магнитогорск

проблемы с видео VIA

Сообщение ReznikOFF » 21 июн 2018, 07:51

решено :yahoo:

Код: Выделить всё

sudo apt-get install xserver-xorg-video-openchrome
после этого видео на чипе VIA работает корректно

пытался решить эту проблему больше месяца, все форумы перерыл, и тут наткнулся на эту статью

Код: Выделить всё

https://itshaman.ru/articles/57/draivera-na-videokarty-nvidia-radeon-intel-i-via-chrome-v-linux-ubuntu
мне достаточно было установить xorg, всем спасибо за проявленный интерес :hshake:

Аватара пользователя

darkfenix
Сообщения: 5404
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 295 раз
Поблагодарили: 1004 раза

проблемы с видео VIA

Сообщение darkfenix » 21 июн 2018, 08:19

Закрываю :close:
Изображение

Вернуться в «Видеокарты»