Невозможно исправить ошибки у вас отложены (held) битые пакеты

Программы для конфигурации и управления операционной системой
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
Аватара пользователя

Автор темы
FliXis
Сообщения: 248
Зарегистрирован: 31 авг 2016, 11:01
Решено: 5
Благодарил (а): 63 раза
Поблагодарили: 15 раз

Невозможно исправить ошибки у вас отложены (held) битые пакеты

Сообщение FliXis » 24 окт 2016, 18:44

mint 18 cinnamon
Очень нужны эти пакеты, как форсировать установку?
apt install -f не помогает, там все по нулям пишет.

Решение FliXis » 25 окт 2016, 17:26
Переустановил систему, на этот раз ставил бумблиби из оф-репозиториев и эти пакеты смогли установится. :smile:

Перейти к ответу ➙
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя

x230
Сообщения: 703
Зарегистрирован: 02 сен 2016, 19:07
Решено: 3
Благодарил (а): 153 раза
Поблагодарили: 143 раза

Re: Невозможно исправить ошибки у вас отложены (held) битые пакеты

Сообщение x230 » 24 окт 2016, 18:51

Synaptic -> Правка -> Исправить пакеты с ошибками.
Возможно придется искать искомое (сорри за тавтологию) в другом месте, ибо из этого не пойдет... - я про пакеты, про обновление/установку чего-то там... драйвер?, ну вот его...
моя платформа :
ОС: Linux Mint 18.2 Sonya, 64-bits. DE: Cinnamon 3.4.3 Ядро: 4.10.0-38-generic x86_64 Browser: Pale Moon 27.6.*
Железо: Intel Core i3-3210; CPU 3.20GHz x 2; Mem 4GB; VGA - на борту.

Аватара пользователя

Chocobo
Сообщения: 5967
Зарегистрирован: 27 авг 2016, 19:57
Решено: 136
Откуда: НН
Благодарил (а): 424 раза
Поблагодарили: 1548 раз

Re: Невозможно исправить ошибки у вас отложены (held) битые пакеты

Сообщение Chocobo » 24 окт 2016, 18:55

FliXis, У меня эти пакеты в Саре "установлены вручную" как пишет апт. Прилетели с установкой fglrx
FliXis писал(а): Очень нужны эти пакеты, как форсировать установку?
Игнорировать то что апт не может разрулить сам - может быть чревато...
Опиши подробней, что хочешь получить в итоге - может получится обойти этот конфликт.

Аватара пользователя

Автор темы
FliXis
Сообщения: 248
Зарегистрирован: 31 авг 2016, 11:01
Решено: 5
Благодарил (а): 63 раза
Поблагодарили: 15 раз

Re: Невозможно исправить ошибки у вас отложены (held) битые пакеты

Сообщение FliXis » 24 окт 2016, 19:10

У меня на другом ноуте, тоже 18 корица, эти пакеты тройку месяцев назад поставились совершенно без всяких проблем.
А вчера накатил 18 на старый ноут(у меня новый в сервис поедет) и засада.
Пакеты эти нужны для qt, ибо cannot find -lGL. А собирать qt сам (уже без опенгл) не хочу, лишний гемор.
У меня стоит bublebee (и из сторонних репозитариев), т.к. видюха отдала концы и все пашет на встроенной в проц, может из-за этого.

Аватара пользователя

Chocobo
Сообщения: 5967
Зарегистрирован: 27 авг 2016, 19:57
Решено: 136
Откуда: НН
Благодарил (а): 424 раза
Поблагодарили: 1548 раз

Re: Невозможно исправить ошибки у вас отложены (held) битые пакеты

Сообщение Chocobo » 24 окт 2016, 19:17

FliXis писал(а): У меня стоит bublebee (и из сторонних репозитариев), т.к. видюха отдала концы и все пашет на встроенной в проц, может из-за этого.
Возможно. Попробуй скармливать по очереди ему пакеты что он просит как зависимости - эта цепочка не вечная. Заодно может и проясниться во что именно он упирается.

Только аккуратней смотри на те зависимости которые он захочет удалить при замене пакета - там вполне может оказаться полсистемы :smile:


symon2014

Re: Невозможно исправить ошибки у вас отложены (held) битые пакеты

Сообщение symon2014 » 24 окт 2016, 19:35

Код: Выделить всё

sudo dpkg --configure -a

Аватара пользователя

Автор темы
FliXis
Сообщения: 248
Зарегистрирован: 31 авг 2016, 11:01
Решено: 5
Благодарил (а): 63 раза
Поблагодарили: 15 раз

Re: Невозможно исправить ошибки у вас отложены (held) битые пакеты

Сообщение FliXis » 25 окт 2016, 12:19

sudo dpkg --configure -a не помог(
Установил все пакеты, что требовались зависимостями от mesa-common-dev и libglu1-mesa-dev, но они все равно не ставятся, пишут тоже самое.

Аватара пользователя

gandic
Сообщения: 58
Зарегистрирован: 23 сен 2016, 09:32
Благодарил (а): 10 раз
Поблагодарили: 7 раз

Re: Невозможно исправить ошибки у вас отложены (held) битые пакеты

Сообщение gandic » 25 окт 2016, 13:22

FliXis писал(а): sudo dpkg --configure -a не помог(
Установил все пакеты, что требовались зависимостями от mesa-common-dev и libglu1-mesa-dev, но они все равно не ставятся, пишут тоже самое.
попробуй в консоли от рута запустить apt-get install -f
....
PS
извини, первое сообщение не прочел
может конфликт в версиях пакетов и зависимостей??
Попробуй репозиторий добавить unstable
Последний раз редактировалось пользователем 3 gandic; всего редактировалось раз: 25
Linux: Debian 9.0 stretch KDE Plasma 5


symon2014

Re: Невозможно исправить ошибки у вас отложены (held) битые пакеты

Сообщение symon2014 » 25 окт 2016, 13:34

В синаптике фильтр, пакеты с ошибками.

Аватара пользователя

Автор темы
FliXis
Сообщения: 248
Зарегистрирован: 31 авг 2016, 11:01
Решено: 5
Благодарил (а): 63 раза
Поблагодарили: 15 раз

Re: Невозможно исправить ошибки у вас отложены (held) битые пакеты

Сообщение FliXis » 25 окт 2016, 14:10

symon2014 писал(а): В синаптике фильтр, пакеты с ошибками.
Пишет 0 с ошибками.

Аватара пользователя

Автор темы
FliXis
Сообщения: 248
Зарегистрирован: 31 авг 2016, 11:01
Решено: 5
Благодарил (а): 63 раза
Поблагодарили: 15 раз

Re: Невозможно исправить ошибки у вас отложены (held) битые пакеты

Сообщение FliXis » 25 окт 2016, 17:26

Переустановил систему, на этот раз ставил бумблиби из оф-репозиториев и эти пакеты смогли установится. :smile:

Вернуться в «Системные утилиты»