apt update не работает.

Программы для конфигурации и управления операционной системой
Правила форума
Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа.
Аватара пользователя
FliXis
Сообщения: 137
Зарегистрирован: 31 авг 2016, 14:01
Решено: 3
Благодарил (а): 42 раза
Поблагодарили: 11 раз
Контактная информация:

apt update не работает.

Сообщение #1 FliXis » 24 окт 2016, 21:37

Mint 18 cinnamon

Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.

PPA нет, доп репозитарии отключил.
На втором ноуте с яндекс-зеркалами тоже самое.(на этом ноуте дефолтные)
Примерно тоже самое происходило еще на 17м минте года два назад.

В сети
Аватара пользователя
Chocobo
Сообщения: 3995
Зарегистрирован: 27 авг 2016, 22:57
Решено: 96
Откуда: НН
Благодарил (а): 347 раз
Поблагодарили: 1051 раз
Контактная информация:

Re: apt update не работает.

Сообщение #2 Chocobo » 24 окт 2016, 21:48

FliXis, А сам адрес http://archive.canonical.com/ubuntu/dis ... /InRelease доступен норм по пингам на домен и в браузере?

Также кака-то встречалось, что apt зачем-то лез в сеть по ipv6 - не помешает отключить, если явно не требуется
Изображение

Аватара пользователя
FliXis
Сообщения: 137
Зарегистрирован: 31 авг 2016, 14:01
Решено: 3
Благодарил (а): 42 раза
Поблагодарили: 11 раз
Контактная информация:

Re: apt update не работает.

Сообщение #3 FliXis » 24 окт 2016, 21:51

Доступен в браузере и пинговался.
А как отключить?

В сети
Аватара пользователя
Chocobo
Сообщения: 3995
Зарегистрирован: 27 авг 2016, 22:57
Решено: 96
Откуда: НН
Благодарил (а): 347 раз
Поблагодарили: 1051 раз
Контактная информация:

Re: apt update не работает.

Сообщение #4 Chocobo » 24 окт 2016, 22:06

Проверь для начала с опцией на ipv4

Код: Выделить всё

sudo apt-get -o Acquire::ForceIPv4=true update

Если это оно - то уже можно будет гасить и на уровне системы
Изображение

Аватара пользователя
FliXis
Сообщения: 137
Зарегистрирован: 31 авг 2016, 14:01
Решено: 3
Благодарил (а): 42 раза
Поблагодарили: 11 раз
Контактная информация:

Re: apt update не работает.

Сообщение #5 FliXis » 25 окт 2016, 14:46

Отрабатывает! Значит из-за IPv6, я правда, совершенно не знаю, что это, ничего не секу в сетях.

В сети
Аватара пользователя
Chocobo
Сообщения: 3995
Зарегистрирован: 27 авг 2016, 22:57
Решено: 96
Откуда: НН
Благодарил (а): 347 раз
Поблагодарили: 1051 раз
Контактная информация:

Re: apt update не работает.

Сообщение #6 Chocobo » 25 окт 2016, 14:49

Тогда эти строчки

Код: Выделить всё

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1


Добавь к файлу /etc/sysctl.conf, затем дай sudo sysctl -p
И перезапусти сетевые службы (или перезагрузись) - так ipv6 будет загашен на всю систему
Изображение

Аватара пользователя
symon2014
Сообщения: 1313
Зарегистрирован: 29 авг 2016, 05:17
Решено: 16
Откуда: Феодосия
Благодарил (а): 41 раз
Поблагодарили: 343 раза
Контактная информация:

Re: apt update не работает.

Сообщение #7 symon2014 » 25 окт 2016, 15:16

Можно так - gksu ФМ /etc/default/grub

Найдите параметр GRUB_CMDLINE_LINUX_DEFAULT и аккуратно дополните значением ipv6.disable=1 Сохраните изменения. Вызовите sudo update-grub
:sry:
Debian (8.8) , LMDE2 , LM 18.2 Mate .

Аватара пользователя
FliXis
Сообщения: 137
Зарегистрирован: 31 авг 2016, 14:01
Решено: 3
Благодарил (а): 42 раза
Поблагодарили: 11 раз
Контактная информация:

Re: apt update не работает.

Сообщение #8 FliXis » 25 окт 2016, 16:01

symon2014 писал(а):Источник цитаты Можно так - gksu ФМ /etc/default/grub

Найдите параметр GRUB_CMDLINE_LINUX_DEFAULT и аккуратно дополните значением ipv6.disable=1 Сохраните изменения. Вызовите sudo update-grub

Дополнил этот аргумент, но после перезагрузки ничего не изменилось.

Chocobo писал(а):Источник цитаты Тогда эти строчки

Код: Выделить всё

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1


Добавь к файлу /etc/sysctl.conf, затем дай sudo systemctl -p
И перезапусти сетевые службы (или перезагрузись) - так ipv6 будет загашен на всю систему


После перезагрузки тоже ничего не изменилось, а на команду sudo systemctl -p жалуется, мол systemctl: ключ должен быть с аргументом - "p"

Аватара пользователя
symon2014
Сообщения: 1313
Зарегистрирован: 29 авг 2016, 05:17
Решено: 16
Откуда: Феодосия
Благодарил (а): 41 раз
Поблагодарили: 343 раза
Контактная информация:

Re: apt update не работает.

Сообщение #9 symon2014 » 25 окт 2016, 16:05

Попробуй без дефиса.
:sry:
Debian (8.8) , LMDE2 , LM 18.2 Mate .

Аватара пользователя
FliXis
Сообщения: 137
Зарегистрирован: 31 авг 2016, 14:01
Решено: 3
Благодарил (а): 42 раза
Поблагодарили: 11 раз
Контактная информация:

Re: apt update не работает.

Сообщение #10 FliXis » 25 окт 2016, 16:06

symon2014 писал(а):Источник цитаты Попробуй без дефиса.

ПРобовал, пишет не знает операции p

В сети
Аватара пользователя
Chocobo
Сообщения: 3995
Зарегистрирован: 27 авг 2016, 22:57
Решено: 96
Откуда: НН
Благодарил (а): 347 раз
Поблагодарили: 1051 раз
Контактная информация:

Re: apt update не работает.

Сообщение #11 Chocobo » 25 окт 2016, 16:14

sysctl -p, ошибся немножко :smile:
Но фактически после перезагрузки должны были подцепиться сами эти параметры.

Покажи ip a - строк inet6 там быть не должно уже на активных интерфейсах
Изображение

Аватара пользователя
symon2014
Сообщения: 1313
Зарегистрирован: 29 авг 2016, 05:17
Решено: 16
Откуда: Феодосия
Благодарил (а): 41 раз
Поблагодарили: 343 раза
Контактная информация:

Re: apt update не работает.

Сообщение #12 symon2014 » 25 окт 2016, 16:21

Покажи cat /etc/default/grub
:sry:
Debian (8.8) , LMDE2 , LM 18.2 Mate .

Аватара пользователя
FliXis
Сообщения: 137
Зарегистрирован: 31 авг 2016, 14:01
Решено: 3
Благодарил (а): 42 раза
Поблагодарили: 11 раз
Контактная информация:

Re: apt update не работает.

Сообщение #13 FliXis » 25 окт 2016, 17:07

Chocobo писал(а):Источник цитаты sysctl -p, ошибся немножко :smile:
Но фактически после перезагрузки должны были подцепиться сами эти параметры.

Покажи ip a - строк inet6 там быть не должно уже на активных интерфейсах

Выполнил, написало вот такое в приложении.
Вложения
b4a66c1aee.jpg
434d294035.jpg

Аватара пользователя
FliXis
Сообщения: 137
Зарегистрирован: 31 авг 2016, 14:01
Решено: 3
Благодарил (а): 42 раза
Поблагодарили: 11 раз
Контактная информация:

Re: apt update не работает.

Сообщение #14 FliXis » 25 окт 2016, 17:08

symon2014 писал(а):Источник цитаты Покажи cat /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash ipv6.disable=1"
Вот так дописывал.

Аватара пользователя
symon2014
Сообщения: 1313
Зарегистрирован: 29 авг 2016, 05:17
Решено: 16
Откуда: Феодосия
Благодарил (а): 41 раз
Поблагодарили: 343 раза
Контактная информация:

Re: apt update не работает.

Сообщение #15 symon2014 » 25 окт 2016, 17:16

update-grub после делал?
:sry:
Debian (8.8) , LMDE2 , LM 18.2 Mate .

Аватара пользователя
FliXis
Сообщения: 137
Зарегистрирован: 31 авг 2016, 14:01
Решено: 3
Благодарил (а): 42 раза
Поблагодарили: 11 раз
Контактная информация:

Re: apt update не работает.

Сообщение #16 FliXis » 25 окт 2016, 17:20

symon2014 писал(а):Источник цитаты update-grub после делал?

Забыл :dash2:

А тут я в строке ошибся:
net.ipv6.conf.lo.disable_ipv6 = 1
Сейчас исправил и перезагружаюсь.

В сети
Аватара пользователя
Chocobo
Сообщения: 3995
Зарегистрирован: 27 авг 2016, 22:57
Решено: 96
Откуда: НН
Благодарил (а): 347 раз
Поблагодарили: 1051 раз
Контактная информация:

Re: apt update не работает.

Сообщение #17 Chocobo » 25 окт 2016, 17:23

FliXis писал(а):Источник цитаты написало вот такое в приложении.

На permission denied - дай с sudo.

Код: Выделить всё

sudo sysctl -p


И в третьей строчке ошибка у тебя на лупбеке -там lo (эль-о) имя интерфейса должно быть вместо io
Изображение

Аватара пользователя
FliXis
Сообщения: 137
Зарегистрирован: 31 авг 2016, 14:01
Решено: 3
Благодарил (а): 42 раза
Поблагодарили: 11 раз
Контактная информация:

Re: apt update не работает.

Сообщение #18 FliXis » 25 окт 2016, 17:24

ip a
Вложения
0b065b3138.jpg

Аватара пользователя
FliXis
Сообщения: 137
Зарегистрирован: 31 авг 2016, 14:01
Решено: 3
Благодарил (а): 42 раза
Поблагодарили: 11 раз
Контактная информация:

Re: apt update не работает.

Сообщение #19 FliXis » 25 окт 2016, 17:25

Chocobo писал(а):Источник цитаты
FliXis писал(а):Источник цитаты написало вот такое в приложении.

На permission denied - дай с sudo.

Код: Выделить всё

sudo sysctl -p


И в третьей строчке ошибка у тебя на лупбеке -там lo (эль-о) имя интерфейса должно быть вместо io

Ага, уже исправил

Аватара пользователя
FliXis
Сообщения: 137
Зарегистрирован: 31 авг 2016, 14:01
Решено: 3
Благодарил (а): 42 раза
Поблагодарили: 11 раз
Контактная информация:

Re: apt update не работает.

Сообщение #20 FliXis » 25 окт 2016, 17:38

update-grub помог. Теперь на старом ноуте, где я провел все эти процедуры, update происходит корректно.
Но самое удивительное, что на новом ноуте, где я ничего не делал, тоже теперь все стало нормально, а там ведь остался ipv6.
Такое впечатление, что ноуты в одной сетке мешают друг-другу. Помню, был у меня случай один, когда при выключении одного из ноутов, отрубалась сеть у второго ноута, а в вай-фай роутере все было по дефолту при этом, чудеса да и только. :magic:

P.S> да и глюки эти с обновой начались после того, как в сети появился второй ноут.

Спасибо Вам большое!


Вернуться в «Системные утилиты»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей