Компилятор неудовлетворён... помогите идентифицировать пакеты

Языки программирования, IDE, компиляторы, интерпретаторы, гипервизоры и виртуальные среды
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
Аватара пользователя

svtv1
Сообщения: 278
Зарегистрирован: 26 дек 2017, 12:27
Решено: 2
1
Благодарил (а): 39 раз
Поблагодарили: 23 раза

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение svtv1 » 28 мар 2018, 21:30

Дмитрий
Попробуй это и желательно запомни или запиши, это часто бывает:
Следующие пакеты имеют неудовлетворенные зависимости: (...)
Ты можешь попробовать различные типы решений, которые могут помочь восстановить базу данных пакетов из приведённых ниже:
Совет 1
Введи и выполни в терминале, эту команду, чтобы исправить битые пакеты:
sudo apt-get --fix-broken install
Совет 2
Если приведенная выше команда не помогла, попробуй выполнить
sudo rm /var/lib/apt/lists/* -vf
sudo apt-get clean
sudo apt-get update

Совет 3
Ты также можешь попробовать следующие команды:
sudo apt-get clean
sudo apt-get autoclean
sudo apt-get autoremove

Совет 4
И ещё:
sudo dpkg --configure -a
sudo apt-get update

Совет 5
Открой Центр приложений попробуй что нибудь устоновить и если увидишь запрос на восстановление сломанных пакетов, нажми на кнопку Исправить.
"Если достаточно долго сидеть возле реки - мимо проплывет труп твоего врага"

Аватара пользователя

Автор темы
Дмитрий
Сообщения: 139
Зарегистрирован: 02 дек 2016, 13:42
Решено: 1
Откуда: Россия
Благодарил (а): 9 раз
Поблагодарили: 12 раз

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение Дмитрий » 29 мар 2018, 08:18

Chocobo писал(а):
28 мар 2018, 16:20
Лучше не удалять а пробуй сразу вернуть родной, вместо ппашного
apt install libpng12-0=1.2.54-1ubuntu1
Не знаю сломалось ли что то из установленных программ, пока не проверял. Но по крайней мере вопрос установки пакета libgtk-3-dev это решило.

svtv1 писал(а):
28 мар 2018, 21:30
Дмитрий
Попробуй это и желательно запомни или запиши, это часто бывает:
Ну поломка базы пакетов меня не пугает, это уже проходил и не раз, дело как раз в том что база не была сломанной, ошибка базывозникала только в момент попытки установить пакет у которого в зависимостях был пакет более низкой версии чем уже установленный в системе, как и сказал Chocobo.

Возвращаясь к стартовому посту, в данном случае для удовлетворения компилятора необходимо было установить:

Код: Выделить всё

sudo apt-get install libgtk-3-dev
sudo apt-get install libncurses5-dev
в комплекте с их зависимостями. Так что огромное спасибо за активную помощь в решении вопроса. Вопрос решён, можно закрыть.

Аватара пользователя

darkfenix
Сообщения: 5597
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 309 раз
Поблагодарили: 1038 раз

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение darkfenix » 29 мар 2018, 08:45

Закрываю. :close:
Изображение

Вернуться в «Программирование, скриптинг, виртуализация»