Компилятор неудовлетворён... помогите идентифицировать пакеты

Языки программирования, IDE, компиляторы, интерпретаторы, гипервизоры и виртуальные среды
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
Аватара пользователя

Автор темы
Дмитрий
Сообщения: 139
Зарегистрирован: 02 дек 2016, 13:42
Решено: 1
Откуда: Россия
Благодарил (а): 9 раз
Поблагодарили: 12 раз

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение Дмитрий » 28 мар 2018, 13:46

Linux Mint корица 18.3

Один компилятор с меня просит это:
ld: cannot find -lgtk-3
ld: cannot find -lgdk-3
ld: cannot find -lglib-2.0
ld: cannot find -lgio-2.0
ld: cannot find -lgobject-2.0
ld: cannot find -lgmodule-2.0
ld: cannot find -lpango-1.0
ld: cannot find -lcairo
ld: cannot find -lgdk_pixbuf-2.0
ld: cannot find -lpangocairo-1.0
ld: cannot find -latk-1.0
ld: cannot find -lfb
ld: cannot find -lncurses
Как я понимаю он хочет dev пакеты, проблема в том что я не понимаю как преобразовать например (но нужен весь список): "-lgtk-3" в имя необходимого пакета, помогите пожалуйста.

Аватара пользователя

Chocobo
Сообщения: 9256
Зарегистрирован: 27 авг 2016, 19:57
Решено: 200
Откуда: НН
Благодарил (а): 645 раз
Поблагодарили: 2663 раза

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение Chocobo » 28 мар 2018, 13:49

Дмитрий, Предысторию бы,
увидеть что собираешь, и с какими ключами.
Изображение
   
Изображение

Аватара пользователя

Автор темы
Дмитрий
Сообщения: 139
Зарегистрирован: 02 дек 2016, 13:42
Решено: 1
Откуда: Россия
Благодарил (а): 9 раз
Поблагодарили: 12 раз

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение Дмитрий » 28 мар 2018, 14:12

Предыстория такая, надо поупрожняться с фреебасиком, пытюсь скомпилировать демку, получаю то что выше.
Я с подобным широко сталкивался под FPC + Lazarus, ставиш пакеты с постфиксом "dev" и едиш дальше.

Пытаюсь поставить пакет libgtk-3-dev:

Код: Выделить всё

uzver@S9p ~/fb $ sudo apt-get install libgtk-3-dev
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 libgtk-3-dev : Зависит: libgdk-pixbuf2.0-dev (>= 2.30.0) но он не будет установлен
                Зависит: libpango1.0-dev (>= 1.37.3) но он не будет установлен
                Зависит: libcairo2-dev (>= 1.14.0) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

Я что то не так делаю? Он устарел? Что-то заместо него?

Аватара пользователя

Chocobo
Сообщения: 9256
Зарегистрирован: 27 авг 2016, 19:57
Решено: 200
Откуда: НН
Благодарил (а): 645 раз
Поблагодарили: 2663 раза

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение Chocobo » 28 мар 2018, 14:26

Сам пакет норм, жив здоров https://packages.ubuntu.com/xenial/libgtk-3-dev
Систему обновляешь периодически?
попробуй сперва sudo dpkg --configure -a
ну и apt update
Изображение
   
Изображение

Аватара пользователя

Автор темы
Дмитрий
Сообщения: 139
Зарегистрирован: 02 дек 2016, 13:42
Решено: 1
Откуда: Россия
Благодарил (а): 9 раз
Поблагодарили: 12 раз

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение Дмитрий » 28 мар 2018, 14:38

Не обновления регулярное, в автомате. Когда пакет не встал, выполнил принудительное обновление... но результат был тот же.
Выполнил команду

Код: Выделить всё

sudo dpkg --configure -a
, ещё раз запустил обновление...

Не встаёт мой пакет :cray2:

Аватара пользователя

Chocobo
Сообщения: 9256
Зарегистрирован: 27 авг 2016, 19:57
Решено: 200
Откуда: НН
Благодарил (а): 645 раз
Поблагодарили: 2663 раза

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение Chocobo » 28 мар 2018, 14:41

Дмитрий, Если индексы репов актуальные, проверь точечно по зависимостям на которые он ругается, кто-то из них мешает ему
libgdk-pixbuf2.0-dev
libpango1.0-dev
libcairo2-dev
Изображение
   
Изображение

Аватара пользователя

darkfenix
Сообщения: 5710
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 314 раз
Поблагодарили: 1054 раза

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение darkfenix » 28 мар 2018, 14:43

Собственно вот пытается установиться
darkfenix@darkfenix  ~  apti libgtk-3-dev
[sudo] пароль для darkfenix:
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Будут установлены следующие дополнительные пакеты:
libatk-bridge2.0-dev libatk1.0-dev libatspi2.0-dev libcairo-script-interpreter2 libcairo2-dev
libdbus-1-dev libdrm-dev libegl1-mesa-dev libepoxy-dev libexpat1-dev libfontconfig1-dev
libfreetype6-dev libgdk-pixbuf2.0-dev libglib2.0-dev libgmp-dev libgmpxx4ldbl libharfbuzz-dev
libharfbuzz-gobject0 libice-dev libmirclient-dev libmircommon-dev libmircookie-dev libmircookie2
libmircore-dev libpango1.0-dev libpcre3-dev libpcre32-3 libpcrecpp0v5 libpixman-1-dev
libpng12-dev libprotobuf-dev libpthread-stubs0-dev libsm-dev libwayland-bin libwayland-dev
libx11-dev libx11-xcb-dev libxau-dev libxcb-dri2-0-dev libxcb-dri3-dev libxcb-glx0-dev
libxcb-present-dev libxcb-randr0-dev libxcb-render0-dev libxcb-shape0-dev libxcb-shm0-dev
libxcb-sync-dev libxcb-xfixes0-dev libxcb1-dev libxcomposite-dev libxcursor-dev libxdamage-dev
libxdmcp-dev libxext-dev libxfixes-dev libxft-dev libxi-dev libxinerama-dev libxkbcommon-dev
libxrandr-dev libxrender-dev libxshmfence-dev libxtst-dev libxxf86vm-dev nettle-dev
x11proto-composite-dev x11proto-core-dev x11proto-damage-dev x11proto-dri2-dev
x11proto-fixes-dev x11proto-gl-dev x11proto-input-dev x11proto-kb-dev x11proto-randr-dev
x11proto-record-dev x11proto-render-dev x11proto-xext-dev x11proto-xf86vidmode-dev
x11proto-xinerama-dev xorg-sgml-doctools xtrans-dev
Все 3 есть в зависимостях
Изображение

Аватара пользователя

Автор темы
Дмитрий
Сообщения: 139
Зарегистрирован: 02 дек 2016, 13:42
Решено: 1
Откуда: Россия
Благодарил (а): 9 раз
Поблагодарили: 12 раз

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение Дмитрий » 28 мар 2018, 14:56

Всё три пакета доступны в репах... но установка каждого в отдельности заканчивается ошибкой:

Код: Выделить всё

uzver@S9p ~/fb $ sudo apt-get install libgdk-pixbuf2.0-dev 
[sudo] пароль для dimitriyps: 
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 libgdk-pixbuf2.0-dev : Зависит: libpng12-dev но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
uzver@S9p ~/fb $ sudo apt-get install libpng12-dev
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 libpng12-dev : Зависит: libpng12-0 (= 1.2.54-1ubuntu1) но 1.2.54-5x0~ppa будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
В общем какой то косяк у меня в системе?

Аватара пользователя

darkfenix
Сообщения: 5710
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 314 раз
Поблагодарили: 1054 раза

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение darkfenix » 28 мар 2018, 15:07

Попробуй sudo apt-get install -f или в Synaptic "Исправить пакеты с ошибками"
18-03-28-200659.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Изображение

Аватара пользователя

Автор темы
Дмитрий
Сообщения: 139
Зарегистрирован: 02 дек 2016, 13:42
Решено: 1
Откуда: Россия
Благодарил (а): 9 раз
Поблагодарили: 12 раз

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение Дмитрий » 28 мар 2018, 15:16

Код: Выделить всё

uzver@S9p ~ $ sudo apt-get install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Ошибок нету, к ошибкам приводит попытка установки вышеназванных пакетаов.

У меня Блендер, Инскапе, Аудацити и поему Джимп из ППА реп... может у меня из за этого накладка версий каких либо библиотек?

Аватара пользователя

darkfenix
Сообщения: 5710
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 314 раз
Поблагодарили: 1054 раза

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение darkfenix » 28 мар 2018, 15:20

Дмитрий писал(а):
28 мар 2018, 15:16
может у меня из за этого накладка версий каких либо библиотек?
Вполне может быть. Открой "Источники обновлений" -> "PPA репозитории". Там выключи тот реп(сними галочку с него). Обнови инфу о пакетах и попробуй снова поставить libgtk-3-dev
Изображение

Аватара пользователя

Автор темы
Дмитрий
Сообщения: 139
Зарегистрирован: 02 дек 2016, 13:42
Решено: 1
Откуда: Россия
Благодарил (а): 9 раз
Поблагодарили: 12 раз

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение Дмитрий » 28 мар 2018, 15:32

Отключил в источниках программ все ППА репы, обновил кеш пакетов, запустил установку libgtk-3-dev... и всё по старому :dash2:

Аватара пользователя

darkfenix
Сообщения: 5710
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 314 раз
Поблагодарили: 1054 раза

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение darkfenix » 28 мар 2018, 15:42

А в Synaptic пробовал "Исправить пакеты с ошибками". Просто дело в том, что апт ругается на битые пакеты.
Изображение

Аватара пользователя

Автор темы
Дмитрий
Сообщения: 139
Зарегистрирован: 02 дек 2016, 13:42
Решено: 1
Откуда: Россия
Благодарил (а): 9 раз
Поблагодарили: 12 раз

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение Дмитрий » 28 мар 2018, 15:46

Да, пишет что "Все проблемы зависимостей пакетов разрешены"... но стоит попробовать поставить отметку на установку на libgtk-3-dev, как сразу возникает ошибка. Точно так же как и в консоли.

Аватара пользователя

darkfenix
Сообщения: 5710
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 314 раз
Поблагодарили: 1054 раза

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение darkfenix » 28 мар 2018, 16:03

Официальные репозитории менял? Покажи скрин какие стоят?
Изображение

Аватара пользователя

Chocobo
Сообщения: 9256
Зарегистрирован: 27 авг 2016, 19:57
Решено: 200
Откуда: НН
Благодарил (а): 645 раз
Поблагодарили: 2663 раза

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение Chocobo » 28 мар 2018, 16:11

Дмитрий писал(а):
28 мар 2018, 14:56
Пакеты, имеющие неудовлетворённые зависимости: libpng12-dev : Зависит: libpng12-0 (= 1.2.54-1ubuntu1) но 1.2.54-5x0~ppa будет установлен
Ну вот и конфликт, этот либпнг из другой некой репы летит, и все ломает отличием версии
Изображение
   
Изображение

Аватара пользователя

darkfenix
Сообщения: 5710
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 314 раз
Поблагодарили: 1054 раза

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение darkfenix » 28 мар 2018, 16:13

Chocobo писал(а):
28 мар 2018, 16:11
все ломает отличием версии
Там еще битые пакеты. А ппа я просил отключить.
Изображение

Аватара пользователя

Автор темы
Дмитрий
Сообщения: 139
Зарегистрирован: 02 дек 2016, 13:42
Решено: 1
Откуда: Россия
Благодарил (а): 9 раз
Поблагодарили: 12 раз

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение Дмитрий » 28 мар 2018, 16:16



Ну вот и конфликт, этот либпнг из другой некой репы летит, и все ломает отличием версии
Удалять пакет и смотреть что с ним вылетит?

Аватара пользователя

Chocobo
Сообщения: 9256
Зарегистрирован: 27 авг 2016, 19:57
Решено: 200
Откуда: НН
Благодарил (а): 645 раз
Поблагодарили: 2663 раза

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение Chocobo » 28 мар 2018, 16:20

Лучше не удалять а пробуй сразу вернуть родной, вместо ппашного
apt install libpng12-0=1.2.54-1ubuntu1
Изображение
   
Изображение

Аватара пользователя

Dja
Сообщения: 6206
Зарегистрирован: 27 авг 2016, 17:03
Решено: 27
Откуда: Voskresensk
Благодарил (а): 918 раз
Поблагодарили: 657 раз

Компилятор неудовлетворён... помогите идентифицировать пакеты

Сообщение Dja » 28 мар 2018, 20:46

Chocobo писал(а):
28 мар 2018, 16:11
Пакеты, имеющие неудовлетворённые зависимости: libpng12-dev : Зависит: libpng12-0 (= 1.2.54-1ubuntu1) но 1.2.54-5x0~ppa будет установлен
т.е. в таких ситуациях надо просто скобки убирать? Ибо
libpng12-0 (= 1.2.54-1ubuntu1) минус () получается libpng12-0=1.2.54-1ubuntu1
:hm:

Вернуться в «Программирование, скриптинг, виртуализация»