Krusader. Дочерние окна теряют фокус клавиатуры

Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

Автор темы
AxaRu
Сообщения: 22
Зарегистрирован: 11 мар 2018, 05:46
Благодарил (а): 5 раз
Поблагодарили: 8 раз

Krusader. Дочерние окна теряют фокус клавиатуры

Сообщение AxaRu » 11 мар 2018, 06:02

Приветствую всех.

Столкнулся с таким багом.
При операциях копирования, перемещения в krusader всплывающие окна теряют фокус клавиатуры.
Нажимание клавиш <табуляция>, <стрелки> игнорируется. Чтобы продолжить нужно либо мышкой пнуть в нужную кнопку, либо <Alt-Tab> выбрать krusader.

Кто нибудь знает как это лечить?
Krusader Version 2.4.0-beta3 "Single Step"
Using KDE Development Platform 4.14.16

EDITION="Cinnamon 64-bit"
DESCRIPTION="Linux Mint 18.3 Sylvia"
С уважением, Алексей.

Аватара пользователя

Bill Williamson
Сообщения: 927
Зарегистрирован: 31 авг 2016, 10:38
Решено: 34
Благодарил (а): 290 раз
Поблагодарили: 247 раз

Krusader. Дочерние окна теряют фокус клавиатуры

Сообщение Bill Williamson » 11 мар 2018, 07:54

AxaRu, попробуйте для начала последнюю версию (krusader 2.6.0).
Изображение


Автор темы
AxaRu
Сообщения: 22
Зарегистрирован: 11 мар 2018, 05:46
Благодарил (а): 5 раз
Поблагодарили: 8 раз

Krusader. Дочерние окна теряют фокус клавиатуры

Сообщение AxaRu » 11 мар 2018, 08:17

Bill Williamson, Спасибо за реакцию.
Да, я видел, чето есть последняя версия, но не нашел ppa c ней.
Не подскажите, есть ли где? Или нужно собирать?

Пробовал поставить deb пакет по ссылке, получил неразрешенные зависимости.

Аватара пользователя

Bill Williamson
Сообщения: 927
Зарегистрирован: 31 авг 2016, 10:38
Решено: 34
Благодарил (а): 290 раз
Поблагодарили: 247 раз

Krusader. Дочерние окна теряют фокус клавиатуры

Сообщение Bill Williamson » 11 мар 2018, 11:39

AxaRu, есть тут версии 5.38.0: https://packages.ubuntu.com/artful/libkf5kiocore5
Изображение


Автор темы
AxaRu
Сообщения: 22
Зарегистрирован: 11 мар 2018, 05:46
Благодарил (а): 5 раз
Поблагодарили: 8 раз

Krusader. Дочерние окна теряют фокус клавиатуры

Сообщение AxaRu » 11 мар 2018, 11:51

Bill Williamson, спасибо, но установка этого пакета ничего не дала.

Аватара пользователя

Bill Williamson
Сообщения: 927
Зарегистрирован: 31 авг 2016, 10:38
Решено: 34
Благодарил (а): 290 раз
Поблагодарили: 247 раз

Krusader. Дочерние окна теряют фокус клавиатуры

Сообщение Bill Williamson » 11 мар 2018, 12:23

AxaRu, значит еще чего-то не хватает. Попробуйте установить через dpkg -i <Название пакета.deb>. Должен появиться список того, чего не хватает.
Изображение


Автор темы
AxaRu
Сообщения: 22
Зарегистрирован: 11 мар 2018, 05:46
Благодарил (а): 5 раз
Поблагодарили: 8 раз

Krusader. Дочерние окна теряют фокус клавиатуры

Сообщение AxaRu » 13 мар 2018, 08:52

Он видимо тянет за собой половину kde
dpkg: dependency problems prevent configuration of krusader:
krusader depends on kinit; however:
Package kinit is not installed.
krusader depends on kio; however:
Package kio is not installed.
krusader depends on libkf5archive5 (>= 4.96.0); however:
Package libkf5archive5 is not installed.
krusader depends on libkf5bookmarks5 (>= 4.96.0); however:
Package libkf5bookmarks5 is not installed.
krusader depends on libkf5completion5 (>= 4.97.0); however:
Package libkf5completion5 is not installed.
krusader depends on libkf5jobwidgets5 (>= 4.96.0); however:
Package libkf5jobwidgets5 is not installed.
krusader depends on libkf5kiocore5 (>= 5.23.0); however:
Version of libkf5kiocore5:amd64 on system is 5.18.0-0ubuntu1.1.
krusader depends on libkf5kiofilewidgets5 (>= 4.96.0); however:
Package libkf5kiofilewidgets5 is not installed.
krusader depends on libkf5kiowidgets5 (>= 5.5.0+git20141226.0011+15.04); however:
Package libkf5kiowidgets5 is not installed.
krusader depends on libkf5parts5 (>= 4.96
dpkg: error processing package krusader (--install):
В итоге не запускается ни старый, ни новый
Последний раз редактировалось пользователем 1 AxaRu; всего редактировалось раз: 13

Аватара пользователя

Dja
Сообщения: 6140
Зарегистрирован: 27 авг 2016, 17:03
Решено: 27
Откуда: Voskresensk
Благодарил (а): 895 раз
Поблагодарили: 653 раза

Krusader. Дочерние окна теряют фокус клавиатуры

Сообщение Dja » 13 мар 2018, 08:55

логично. Krusader он же кедошный. Почему он не должен тянуть кеды?

Аватара пользователя

darkfenix
Сообщения: 5498
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 308 раз
Поблагодарили: 1026 раз

Krusader. Дочерние окна теряют фокус клавиатуры

Сообщение darkfenix » 13 мар 2018, 09:13

AxaRu писал(а):
13 мар 2018, 08:52
тянет за собой половину kde
А ты думал в сказку попал?
Изображение

Аватара пользователя

Bill Williamson
Сообщения: 927
Зарегистрирован: 31 авг 2016, 10:38
Решено: 34
Благодарил (а): 290 раз
Поблагодарили: 247 раз

Krusader. Дочерние окна теряют фокус клавиатуры

Сообщение Bill Williamson » 13 мар 2018, 11:59

AxaRu писал(а):
13 мар 2018, 08:52
Он видимо тянет за собой половину kde
Нужно малость повозиться. Но как вариант, сначала можно потестить в виртуальной машине на дистрибутивах с последними версиями этих пакетов. Еще хорошо бы посмотреть на его поведение в родной среде.
AxaRu писал(а):
13 мар 2018, 08:52
В итоге не запускается ни старый, ни новый
Удалите новые пакеты, которые успели установить, чтобы запустить старую версию. Введенное раннее можно увидеть по команде history.
Изображение

Вернуться в «Cinnamon»