Linux Mint. Проблема с Wi-Fi.

И прочие интерфейсы передачи данных
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

Автор темы
Kenan2151
Сообщения: 6
Зарегистрирован: 02 фев 2018, 21:42

Linux Mint. Проблема с Wi-Fi.

Сообщение Kenan2151 » 02 фев 2018, 22:18

Здравствуйте, у меня проблема с Wi-Fi. Интернет у меня хороший, роутер нормально работает. Ноутбук видит мой wi-fi, но сигнал слабый. Проблема точно в ноутбуке. Сигнал на столько слабый, что его хватает только на сайты, а если смотреть видео, то оно долго грузится и каждые 30сек-2 минуту снова грузится. Хотя бывают моменты, когда сигнал неплохой и видео можно смотреть долго и даже можно что-то скачать, но сам сигнал вечно меняется, то он слабый, то средний. Когда я купил ноутбук, то в нём установлен Windows 10 и с Wi-Fi никогда проблем не было, однако после того как я установил на ноутбук линукс, проблемный wi-fi сразу дал о себе знать. Мне говорили, что ОС никак не влияет на ноутбук (ну типа на железо (Wi-FI модуль)), но тогда из-за чего проблема то. Помогите пожалуйста решить эту проблему.

1. Linux Mint 18.3 Sylvia Cinnamon Ubuntu, 64-bit
2. Cinnamon
3. Я не знаю, что за железо, но если вы про ноутбук, то мой: HP - 15ba502ur

Скачал я линукс тут:
https://linuxmint.com/download.php
Выбрал Cinnamon 64-bit

Аватара пользователя

slant
Сообщения: 1744
Зарегистрирован: 21 июн 2017, 15:09
Решено: 26
Благодарил (а): 12 раз
Поблагодарили: 757 раз

Linux Mint. Проблема с Wi-Fi.

Сообщение slant » 02 фев 2018, 22:27

Сверху твоего сообщения в красной рамке написано "Правила форума".
1. Прочитать.
2. Осознать.
3. Выполнить.


Автор темы
Kenan2151
Сообщения: 6
Зарегистрирован: 02 фев 2018, 21:42

Linux Mint. Проблема с Wi-Fi.

Сообщение Kenan2151 » 02 фев 2018, 23:15

Код: Выделить всё

kenan@kenan-HP-Notebook ~ $ inxi -Fxz 
System:    Host: kenan-HP-Notebook Kernel: 4.13.0-32-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: HP product: HP Notebook v: Type1ProductConfigId
           Mobo: HP model: 82F6 v: 40.41 Bios: Insyde v: F.24 date: 06/15/2017
CPU:       Quad core AMD E2-7110 APU with AMD Radeon R2 Graphics (-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 14373
           clock speeds: max: 1800 MHz 1: 1350 MHz 2: 1000 MHz 3: 1000 MHz
           4: 1000 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R3 Graphics]
           bus-ID: 00:01.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: AMD MULLINS (DRM 2.50.0 / 4.13.0-32-generic, LLVM 5.0.0)
           GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
           driver: snd_hda_intel bus-ID: 00:14.2
           Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio
           driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k4.13.0-32-generic
Network:   Card-1: Realtek RTL8723BE PCIe Wireless Network Adapter
           driver: rtl8723be port: 3000 bus-ID: 02:00.0
           IF: wlo1 state: up mac: <filter>
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (4.1% used)
           ID-1: /dev/sda model: ST500LT012 size: 500.1GB
Partition: ID-1: / size: 455G used: 16G (4%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 3.72GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 47.0C mobo: 20.0C gpu: 48.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 230 Uptime: 2:38 Memory: 1049.8/3408.8MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
Последний раз редактировалось пользователем 1 darkfenix; всего редактировалось раз: 3
Причина: BBcode

Аватара пользователя

slant
Сообщения: 1744
Зарегистрирован: 21 июн 2017, 15:09
Решено: 26
Благодарил (а): 12 раз
Поблагодарили: 757 раз

Linux Mint. Проблема с Wi-Fi.

Сообщение slant » 03 фев 2018, 00:08

Судя по всему тут вас угораздило наткнуться на очень неудачную комбинацию модели адаптера и производителя. У HP это оказывает типичная проблема с данной вафлей. Стоило загуглить по модели адаптера, как сразу нашлась куча вопросов про слабый сигнал при переходе на линукс. Решение походу аппаратное. Вот что про нее пишут:
Quote Originally Posted by Jerry_Gorland View Post
SOLUTION for my particular case (HP Stream 11-r010 Cloudbook with N3050 Celeron and HP Model No. 792204-001 30x22mm M.2 Wi-Fi card): Moving the single antenna cable from one connector to the other (as shown in the attached diagram) solved the problem. This would explain why the laptop worked only when sitting right next to the Wi-Fi router: With Linux the card is configured to use the other connector compared to Windows. Now I am two floors up from my router and connected well with Xubuntu 14.04. With Xubuntu, all the hotkeys work. I tried Mint 17.2, but I was unable to adjust the display brightness. I am still going to test out the Panda Wi-Fi dongle when I get it.
Это отсюда: https://ubuntuforums.org/showthread.php ... st13406187

Как я понял: у этого адаптера Wi-Fi два разъема под антенны, а HP из экономии, или нехватки места ставит только одну. Драйвер под виндой задействует одно гнездо, а драйвер под линуксом - другое, пустое. Без антенны в нем сигнал разумеется никакой. Решение - разобрать агрегат и переставить разъем антенны в другое гнездо.

P.S. Может это можно и программно решить, но дальше уже сами ищите.

Аватара пользователя

Unborn
Сообщения: 1775
Зарегистрирован: 03 сен 2016, 10:36
Решено: 24
Благодарил (а): 4 раза
Поблагодарили: 252 раза

Linux Mint. Проблема с Wi-Fi.

Сообщение Unborn » 03 фев 2018, 06:23

slant писал(а):
03 фев 2018, 00:08
У HP это оказывает типичная проблема с данной вафлей.
Это не только у НР, это у многих вендоров в нищебродских моделях.
slant писал(а):
03 фев 2018, 00:08
Как я понял: у этого адаптера Wi-Fi два разъема под антенны, а HP из экономии, или нехватки места ставит только одну. Драйвер под виндой задействует одно гнездо, а драйвер под линуксом - другое, пустое. Без антенны в нем сигнал разумеется никакой. Решение - разобрать агрегат и переставить разъем антенны в другое гнездо.
Не другое пустое, и не нужно ничего разбирать. Виндозный драйвер от вендора собран для работы с одной антенной, а линуксовый - как положено. Поэтому -

Код: Выделить всё

sudo tee /etc/modprobe.d/rtl8723be.conf <<< "options rtl8723be ant_sel=1"

Это если больше нет претензий к работе.
Драйвер - https://github.com/lwfinger/rtlwifi_new


pakistanec
Сообщения: 35
Зарегистрирован: 31 май 2018, 08:25
Благодарил (а): 9 раз
Поблагодарили: 1 раз

Linux Mint. Проблема с Wi-Fi.

Сообщение pakistanec » 02 июн 2018, 09:28

Unborn, подскажите пожалуйста если после этой команды сеть стала сто процентов но от роутора не могу отойти так как обрывается связь

Аватара пользователя

Глеб
Сообщения: 21
Зарегистрирован: 20 дек 2017, 02:31
Благодарил (а): 5 раз
Поблагодарили: 1 раз

Linux Mint. Проблема с Wi-Fi.

Сообщение Глеб » 02 июн 2018, 09:32

Я со своим HP тоже намучался помогла эта статья http://localstorage.ru/ustranieniie-sla ... rtl8723be/

Аватара пользователя

Unborn
Сообщения: 1775
Зарегистрирован: 03 сен 2016, 10:36
Решено: 24
Благодарил (а): 4 раза
Поблагодарили: 252 раза

Linux Mint. Проблема с Wi-Fi.

Сообщение Unborn » 19 июн 2018, 07:10

pakistanec писал(а):
02 июн 2018, 09:28
от роутора не могу отойти так как обрывается связь
Проверь включено ли управление питанием драйвером вафли. В выводе iwconfig повер медеджмент должно быть выкл. Также может влиять установленный в Винде режим работы вай-фай. При перезагрузке режим энергосбережения может остается вкл.


shirdon
Сообщения: 2
Зарегистрирован: 27 дек 2018, 18:05

Linux Mint. Проблема с Wi-Fi.

Сообщение shirdon » 27 дек 2018, 18:23

Добрый вечер. Установил на ноутбук HP 250 G4 "Linux Mint 19 Tara". Естество Wi-fi сразу не заработал. Копал, копал и докопался до этого https://github.com/lwfinger/rtlwifi_new. Все отлично запустилось и даже, очень продолжительное, время работало. Проблема возникла буквально недавно. Решил все таки скачать и установить обновления. После этого WI-fi стал ловить только в непосредственной близости от роутера и то сигнал 40-50 % . На 3-4 метра отходишь и все, интернета нет. Никак не могу понять, что делать. Устанавливал драйвера заново, не помогло. Настройками тоже баловался, бесполезно. Может кто подскажет, в каком направлении копать?

Код: Выделить всё

System:    Host: loris-HP-250-G4-Notebook-PC Kernel: 4.15.0-43-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1) Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: HP product: HP 250 G4 Notebook PC v: Type1ProductConfigId serial: N/A
           Mobo: HP model: 80C5 v: 97.41 serial: N/A UEFI: Insyde v: F.1B date: 10/19/2015
Battery    BAT1: charge: 18.6 Wh 60.5% condition: 30.7/31.1 Wh (99%)
           model: COMPAL PABAS0241231 status: Discharging
CPU:       Dual core Intel Celeron N3050 (-MCP-) arch: Airmont rev.3 cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 6400
           clock speeds: max: 2160 MHz 1: 575 MHz 2: 767 MHz
Graphics:  Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 400 (Braswell)
           version: 4.5 Mesa 18.0.5 Direct Render: Yes
Audio:     Card Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-43-generic
Network:   Card-1: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be port: 2000 bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 1000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 515.8GB (10.6% used)
           ID-1: /dev/sda model: HGST_HTS545050A7 size: 500.1GB temp: 0C
           ID-2: USB /dev/sdb model: SD/MMC/MS_PRO size: 15.7GB temp: 0C
Partition: ID-1: / size: 48G used: 21G (45%) fs: ext4 dev: /dev/sda2
           ID-2: /home size: 410G used: 30G (8%) fs: ext4 dev: /dev/sda4
           ID-3: swap-1 size: 0.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 51.0C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 221 Uptime: 1:00 Memory: 1959.8/3789.7MB Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
В общем не столько действий проделал. Вроде помогло вот это.
/etc/modprobe.d/blacklist.conf
Сюда добавил: blacklist r8723be
Перегрузил. И о чудо, заработало.
Последний раз редактировалось пользователем 1 shirdon; всего редактировалось раз: 27

Аватара пользователя

WWolf
Сообщения: 1147
Зарегистрирован: 13 фев 2018, 21:51
Решено: 5
Откуда: Краснодар
Благодарил (а): 410 раз
Поблагодарили: 259 раз

Linux Mint. Проблема с Wi-Fi.

Сообщение WWolf » 27 дек 2018, 18:48

shirdon, переключение антенн... Поиск по форуму в помощь


shirdon
Сообщения: 2
Зарегистрирован: 27 дек 2018, 18:05

Linux Mint. Проблема с Wi-Fi.

Сообщение shirdon » 27 дек 2018, 19:02

WWolf писал(а):
27 дек 2018, 18:48
shirdon, переключение антенн... Поиск по форуму в помощь
Переключение антенн, это первое что я сделал. Не помогло. Потом переустановил драйвера. Тоже безуспешно. В итоге проблему решил.
Вроде помогло вот это. Как я понял нужно добавить родной драйвер(кривой) сюда: /etc/modprobe.d/blacklist.conf
Добавляем в файл: blacklist r8723be
Перегрузил. И о чудо, заработало.

Аватара пользователя

AlexZ
Сообщения: 1117
Зарегистрирован: 06 янв 2018, 18:06
Решено: 3
Откуда: Горно-Алтайск
Благодарил (а): 168 раз
Поблагодарили: 139 раз

Linux Mint. Проблема с Wi-Fi.

Сообщение AlexZ » 27 дек 2018, 19:36

shirdon писал(а):
27 дек 2018, 18:23
UEFI: Insyde v: F.1B date: 10/19/2015
Card-1: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be
И чой это в УЕФИ вай-фай отваливается? :hoho:

Вернуться в «Сетевые карты, модемы, Wi-Fi, bluetooth»