Python 3.6

Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
Аватара пользователя

Автор темы
zxc12
Сообщения: 29
Зарегистрирован: 22 ноя 2017, 12:04
Решено: 1
Благодарил (а): 5 раз

Python 3.6

Сообщение zxc12 » 14 янв 2018, 11:05

Приветствую форумчане!

Установил Python 3.6 по этой инструкции,
по умолчанию выставил python 3.6,
отвалился менеджер обновлений и не стартует IDLE.
Выставил заново 3.5 всё работает на ура.
Подскажите, как мне снести 3.6?
Ковырять config-и 3.6-го просто в лом да и времени пока нет.

P.s.
Забыл самое главное, после установки не могу ни updat-ить ни заинсталить любой софт, выдаёт - Пакет libglib2.0-dev пока не настроен
но с этим я разберусь, главное снести 3.6.

Решение zxc12 » 14 янв 2018, 13:32
Разобрался.
При установке питона он встал не /usr/bin/ а в /usr/local/bin/, я из-за невнимательности сделал линк файла python из каталога /usr/bin/ на python 3.6, в этом и была вся ошибка, так как надо было делать, что бы ссылка python3 (именно python3 а не просто python) из того же каталога /usr/bin/ направляла на 3.6, вот и получалось что при работе apt-а он ссылался на файл python который и линковал на python 3.6 который не имеет ConfigParser.

Получается с ошибкой "Пакет libglib2.0-dev пока не настроен" из моего первого поста я разобрался, она мне мешала снести удава, ну а раз уж начал ковыряться может щас и питона подредактирую что бы не сносить, он пока почему то не хочет импортировать модуль Tkinter для работы IDLE, думаю что просто сейчас обновлю/установлю python3-tk и должно завестись.

Всем Спасибо!

Перейти к ответу ➙
Последний раз редактировалось пользователем 1 zxc12; всего редактировалось раз: 14
Читать написанное транслитом — это как читать написанное фекалиями на стене: вроде и понятно все, и все равно неприятно.


Anonim19992
Сообщения: 65
Зарегистрирован: 16 ноя 2016, 08:53
Благодарил (а): 6 раз
Поблагодарили: 4 раза

Python 3.6

Сообщение Anonim19992 » 14 янв 2018, 11:33

Не по теме
zxc12 вовремя созданный бэкап уберегает от большинства проблем)

Аватара пользователя

darkfenix
Сообщения: 5613
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 309 раз
Поблагодарили: 1038 раз

Python 3.6

Сообщение darkfenix » 14 янв 2018, 11:46

zxc12 писал(а):
14 янв 2018, 11:05
Установил Python 3.6 по этой инструкции,
Опиши шаги, которые ты делал для установки. Там для Ubuntu 16.04, а LM 18 - это то же самое, 2 варианта. У нас нет экстрасенса, чтоб угадать что делал.
Изображение

Аватара пользователя

Автор темы
zxc12
Сообщения: 29
Зарегистрирован: 22 ноя 2017, 12:04
Решено: 1
Благодарил (а): 5 раз

Python 3.6

Сообщение zxc12 » 14 янв 2018, 12:13

darkfenix писал(а):
14 янв 2018, 11:46
Там для Ubuntu 16.04
Linux Mint 18.x формируется на пакетной базе Ubuntu 16.04 LTS чё тут сенсорить то, ставил всё из PPA, не из исходников.
Читать написанное транслитом — это как читать написанное фекалиями на стене: вроде и понятно все, и все равно неприятно.

Аватара пользователя

darkfenix
Сообщения: 5613
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 309 раз
Поблагодарили: 1038 раз

Python 3.6

Сообщение darkfenix » 14 янв 2018, 12:17

zxc12 писал(а):
14 янв 2018, 12:13
ставил всё из PPA
Ну так apt purge python3.6 не работает?
Изображение

Аватара пользователя

Автор темы
zxc12
Сообщения: 29
Зарегистрирован: 22 ноя 2017, 12:04
Решено: 1
Благодарил (а): 5 раз

Python 3.6

Сообщение zxc12 » 14 янв 2018, 13:32

Разобрался.
При установке питона он встал не /usr/bin/ а в /usr/local/bin/, я из-за невнимательности сделал линк файла python из каталога /usr/bin/ на python 3.6, в этом и была вся ошибка, так как надо было делать, что бы ссылка python3 (именно python3 а не просто python) из того же каталога /usr/bin/ направляла на 3.6, вот и получалось что при работе apt-а он ссылался на файл python который и линковал на python 3.6 который не имеет ConfigParser.

Получается с ошибкой "Пакет libglib2.0-dev пока не настроен" из моего первого поста я разобрался, она мне мешала снести удава, ну а раз уж начал ковыряться может щас и питона подредактирую что бы не сносить, он пока почему то не хочет импортировать модуль Tkinter для работы IDLE, думаю что просто сейчас обновлю/установлю python3-tk и должно завестись.

Всем Спасибо!
Последний раз редактировалось пользователем 3 zxc12; всего редактировалось раз: 14
Читать написанное транслитом — это как читать написанное фекалиями на стене: вроде и понятно все, и все равно неприятно.

Аватара пользователя

darkfenix
Сообщения: 5613
Зарегистрирован: 27 июн 2017, 10:36
Решено: 62
Откуда: Нижний Тагил
Благодарил (а): 309 раз
Поблагодарили: 1038 раз

Python 3.6

Сообщение darkfenix » 14 янв 2018, 13:37

zxc12 писал(а):
14 янв 2018, 13:32
может щас и питона подредактирую
Удачи :thumbs:
Изображение

Аватара пользователя

epsicore
Сообщения: 11
Зарегистрирован: 03 фев 2018, 06:23
Благодарил (а): 10 раз

Python 3.6

Сообщение epsicore » 09 фев 2018, 16:55

Хех, странно, а у меня почему-то при таких командах всё равно установился питон 3.5.2.
25 sudo apt update
26 sudo apt install python3.6
27 sudo apt install build-essential checkinstall
28 sudo apt install libreadline-gplv2-dev libncursesw5-dev libssl-dev libsqlite3-dev tk-dev libgdbm-dev libc6-dev libbz2-dev
29 wget https://www.python.org/ftp/python/3.6.3 ... 6.3.tar.xz
30 tar xvf Python-3.6.3.tar.xz
31 cd Python-3.6.3/
32 ./configure
33 sudo make altinstall
34 python3 -V
35 cd
36 history

Аватара пользователя

Chocobo
Сообщения: 9252
Зарегистрирован: 27 авг 2016, 19:57
Решено: 200
Откуда: НН
Благодарил (а): 645 раз
Поблагодарили: 2661 раз

Python 3.6

Сообщение Chocobo » 09 фев 2018, 17:52

epsicore, whereis python ведет к тому же бинарнику, который был указан на этапе ./configure ?

Ну и вопрос - а чем 3.5.Х не устроил, нету какой-то конкретной штуки в предыдущей версии, или просто так захотелось? :)
Изображение
   
Изображение

Вернуться в «Иные системные ошибки»