Проблемы с установкой sparkle

Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
Аватара пользователя

Автор темы
vir0id
Сообщения: 2206
Зарегистрирован: 19 дек 2017, 15:48
Решено: 13
Откуда: Рига
Благодарил (а): 149 раз
Поблагодарили: 235 раз

Проблемы с установкой sparkle

Сообщение vir0id » 03 янв 2018, 21:05

Вообщем не выходит запустить. Кто решил? Вообщем у меня есть 2-а пакета, мол для ubuntu и mint. Оба 64 битовые. При попытке утановить разбивается dpkg, решение снизу:
vir0id@15-bw0xx ~/Загрузки/Барахло $ sudo dpkg -i sparkle-repository_1-1_all.deb
dpkg: предупреждение: список файлов пакета «sparkle-repository» отсутствует; предполагаем, что на данный момент у пакета нет установленных файлов
(Чтение базы данных … на данный момент установлено 583926 файлов и каталогов.)
Подготовка к распаковке sparkle-repository_1-1_all.deb …
Распаковывается sparkle-repository (1-1) на замену (1-1) …
Настраивается пакет sparkle-repository (1-1) …
Unknown distribution. Can't setup repository.
dpkg: ошибка при обработке пакета sparkle-repository (--install):
подпроцесс установлен сценарий post-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
sparkle-repository
vir0id@15-bw0xx ~/Загрузки/Барахло $ sudo apt install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
После данной операции, объём занятого дискового пространства возрастёт на 0 B.
Настраивается пакет sparkle-repository (1-1) …
Unknown distribution. Can't setup repository.
dpkg: ошибка при обработке пакета sparkle-repository (--configure):
подпроцесс установлен сценарий post-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
sparkle-repository
E: Sub-process /usr/bin/dpkg returned an error code (1)
vir0id@15-bw0xx ~/Загрузки/Барахло $ sudo dpkg --configure -a
Настраивается пакет sparkle-repository (1-1) …
Unknown distribution. Can't setup repository.
dpkg: ошибка при обработке пакета sparkle-repository (--configure):
подпроцесс установлен сценарий post-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
sparkle-repository
vir0id@15-bw0xx ~/Загрузки/Барахло $ cd /var/lib/dpkg/info
vir0id@15-bw0xx /var/lib/dpkg/info $ sudo rm -rf sparkle-repository.*
vir0id@15-bw0xx /var/lib/dpkg/info $ sudo apt install -f

Аватара пользователя

val
Сообщения: 49
Зарегистрирован: 02 сен 2016, 22:17
Решено: 2
Поблагодарили: 11 раз

Проблемы с установкой sparkle

Сообщение val » 03 янв 2018, 23:52

Gdebi пробуйте для установки пакета, там понадобиться пару зависимостей притянуть
В чем Сила Брат?!А Сила,она во Сне! :smoke:

Аватара пользователя

Chocobo
Сообщения: 9268
Зарегистрирован: 27 авг 2016, 19:57
Решено: 200
Откуда: НН
Благодарил (а): 645 раз
Поблагодарили: 2677 раз

Проблемы с установкой sparkle

Сообщение Chocobo » 04 янв 2018, 05:06

vir0id писал(а):
03 янв 2018, 21:05
Кто решил?
Как-то расковыривал эту кривоту - Альтернатива Zona для Linux. Sparkle (Пост Chocobo #24946)
Изображение
   
Изображение

Аватара пользователя

Автор темы
vir0id
Сообщения: 2206
Зарегистрирован: 19 дек 2017, 15:48
Решено: 13
Откуда: Рига
Благодарил (а): 149 раз
Поблагодарили: 235 раз

Проблемы с установкой sparkle

Сообщение vir0id » 04 янв 2018, 05:11

Извиняюсь. Сперва написал, потом подумал

Вернуться в «Иное программное обеспечение»