Viber.deb - не debian пакет!

Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

Автор темы
dwais
Сообщения: 49
Зарегистрирован: 05 ноя 2017, 12:32
Благодарил (а): 6 раз

Viber.deb - не debian пакет!

Сообщение dwais » 09 ноя 2017, 22:10

Вот отчет https://linux-hardware.org/index.php?pr ... 102ebbfb2a
При попытке установить Viber вот такое:
viber.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя

Dja
Сообщения: 3162
Зарегистрирован: 27 авг 2016, 17:03
Решено: 12
Откуда: Воскресенск
Благодарил (а): 423 раза
Поблагодарили: 339 раз

Viber.deb - не debian пакет!

Сообщение Dja » 09 ноя 2017, 22:16

dwais, в каталоге с пакетом "открыть терминал здесь" и там

Код: Выделить всё

sudo dpkg -i viber.deb
Затем

Код: Выделить всё

sudo apt install -f
Новичок? - ознакомься с правилами
и Панель форматирования
В поисках истины :grabli:


Автор темы
dwais
Сообщения: 49
Зарегистрирован: 05 ноя 2017, 12:32
Благодарил (а): 6 раз

Viber.deb - не debian пакет!

Сообщение dwais » 09 ноя 2017, 22:18

ок, спасибо. Почему-то до этого без проблем запускалось по двойному клику.
А почему не распознает debian пакет?

Аватара пользователя

Dja
Сообщения: 3162
Зарегистрирован: 27 авг 2016, 17:03
Решено: 12
Откуда: Воскресенск
Благодарил (а): 423 раза
Поблагодарили: 339 раз

Viber.deb - не debian пакет!

Сообщение Dja » 09 ноя 2017, 22:21

потому что 18.2 (жиденький такой на данный момент дистрибутив)
Потому у меня 18.1
Новичок? - ознакомься с правилами
и Панель форматирования
В поисках истины :grabli:


Автор темы
dwais
Сообщения: 49
Зарегистрирован: 05 ноя 2017, 12:32
Благодарил (а): 6 раз

Viber.deb - не debian пакет!

Сообщение dwais » 09 ноя 2017, 22:25

потому что 18.2 (жиденький такой на данный момент дистрибутив)
Потому у меня 18.1
Так у меня 18.1 тоже :blink2:
system.png
и отчет в первом посте
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя

Dja
Сообщения: 3162
Зарегистрирован: 27 авг 2016, 17:03
Решено: 12
Откуда: Воскресенск
Благодарил (а): 423 раза
Поблагодарили: 339 раз

Viber.deb - не debian пакет!

Сообщение Dja » 09 ноя 2017, 22:28

dwais, вообщем помогло же ) Я как правило всё ставлю через консоль.
Новичок? - ознакомься с правилами
и Панель форматирования
В поисках истины :grabli:

В сети
Аватара пользователя

darkfenix
Сообщения: 1133
Зарегистрирован: 27 июн 2017, 10:36
Решено: 12
Благодарил (а): 67 раз
Поблагодарили: 185 раз

Viber.deb - не debian пакет!

Сообщение darkfenix » 10 ноя 2017, 03:19

Не по теме
Dja писал(а):
09 ноя 2017, 22:21
потому что 18.2
Ну что ты так его не взлюбил, прекрасно же работает. У меня вот прекрасно ставятся скачанные deb-пакеты.

Аватара пользователя

sher424
Сообщения: 2
Зарегистрирован: 27 дек 2017, 13:14

Viber.deb - не debian пакет!

Сообщение sher424 » 27 дек 2017, 13:23

На Debian 9.3 amd64 тоже не работает.
GDebi выдаёт, что viber.deb - не deb-пакет.
dpkg устанавливает с сообщением об неудовлетворённых зависимостях и отсутствии пакета libssl1.0.0, хотя стоят libssl1.0.2 и libssl1.1. Неужто они не подходят?
apt install -f удаляет viber

Код: Выделить всё

root@deb:/home/sher# dpkg -i Рабочий\ стол/viber.deb 
Выбор ранее не выбранного пакета viber.
(Чтение базы данных … на данный момент установлен 232751 файл и каталог.)
Подготовка к распаковке …/viber.deb …
chown: невозможно получить доступ к '/home/sher/Documents/ViberDownloads': Нет такого файла или каталога
Распаковывается viber (7.0.0.1035) …
dpkg: зависимости пакетов не позволяют настроить пакет viber:
 viber зависит от libssl1.0.0, однако:
  Пакет libssl1.0.0 не установлен.

dpkg: ошибка при обработке пакета viber (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils (0.23-1) …
Обрабатываются триггеры для mime-support (3.60) …
Обрабатываются триггеры для hicolor-icon-theme (0.15-1) …
При обработке следующих пакетов произошли ошибки:
 viber
root@deb:/home/sher# apt install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Пакеты, которые будут УДАЛЕНЫ:
  viber
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 1 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
После данной операции, объём занятого дискового пространства уменьшится на 431 MB.
Хотите продолжить? [Д/н] 

В сети
Аватара пользователя

Chocobo
Сообщения: 6247
Зарегистрирован: 27 авг 2016, 19:57
Решено: 138
Откуда: НН
Благодарил (а): 442 раза
Поблагодарили: 1615 раз

Viber.deb - не debian пакет!

Сообщение Chocobo » 27 дек 2017, 13:45

sher424 писал(а):
27 дек 2017, 13:23
GDebi выдаёт, что viber.deb - не deb-пакет.
Возможно кривенько собран, что gdebi вышибает на нем/

Код: Выделить всё

~▶ gdebi viber.deb 
Package: viber
Version: 7.0.0.1035
...
Не удалось открыть пакет
Возможно, пакет повреждён, или вам не позволено открывать файл. Проверьте права файла.
sher424 писал(а):
27 дек 2017, 13:23
с сообщением об неудовлетворённых зависимостях и отсутствии пакета libssl1.0.0, хотя стоят libssl1.0.2
А у него в зависимостях прописан конректно 1.0.0, который из 9-го дебиана выпилили. Можешь стянуть со снепшотов
Ну а сами и вопросы по 9-му дебиану до выхода Cindy(LMDE3) - нам пока не особо профильны :smile:

Аватара пользователя

sher424
Сообщения: 2
Зарегистрирован: 27 дек 2017, 13:14

Viber.deb - не debian пакет!

Сообщение sher424 » 27 дек 2017, 17:26

Chocobo писал(а):А у него в зависимостях прописан конректно 1.0.0, который из 9-го дебиана выпилили. Можешь стянуть со снепшотов
Ну а сами и вопросы по 9-му дебиану до выхода Cindy(LMDE3) - нам пока не особо профильны :smile:
)))
Не работат (((

Вернуться в «Иное программное обеспечение»