✓ Решено Ошибка mysql-server при обновлении.

В сети
Аватара пользователя
symon2014
Сообщения: 923
Зарегистрирован: 29 авг 2016, 05:17
Решено: 14
Откуда: Феодосия
Благодарил (а): 32 раза
Поблагодарили: 239 раз
Контактная информация:

Ошибка mysql-server при обновлении.

Сообщение #1 symon2014 » 15 сен 2016, 13:47

Привет, делал сегодня очередное обновление (терминалом), в процессе вылезло такое
insserv: warning: current start runlevel(s) (empty) of script `mysql' overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `mysql' overrides LSB defaults (0 1 6).
На этом тупо остановилось, после 15 минут ожидания решил прервать процесс, но ни на какие комбинации реакции не было, сделал ресет, После перезагрузки апдейт предложил ввести команду
sudo dpkg --configure -a , ввёл.
► Показать

Что ещё пробовал, в синаптике нашёл эти пакеты и хотел переустановить, выдало вообще чушь (error - no name). На этом мысли кончились. :cray2:
PS. dpkg делал в 3 вариантах ( менял уровни загрузки - указанные в первых строчках), результат одинаковый.

Решение symon2014 » 15 сен 2016, 18:03
Победил. Не знаю почему поломался и как починился. Мои последние действия.
Удалил 3 пакета. mysql-server , mysql-server-5.7 , mysql-server-core-5.7 .
Вычистил и аптом и аптитуде( на всякий случай ), запустил установку метапакета mysql-server , выдало ту же ошибку. Нервно покурил и решил ребутнуться. После, первым делом запустил sudo dpkg --configure -a
. Стало выдавать это.
► Показать

Пока шёл процесс я чуть не :harakiri: , но в итоге починилось. Думаю в некоторых случаях полезно делать ребут.

Перейти к ответу ➙
Изображение :sry:
Debian (8.8) , LMDE2 , LM (18.2 Mate , 17.3 Xfce) , Antergos 17.2 .

Аватара пользователя
Dja
Сообщения: 1370
Зарегистрирован: 27 авг 2016, 20:03
Решено: 8
Откуда: Воскресенск
Благодарил (а): 220 раз
Поблагодарили: 148 раз
Контактная информация:

Re: Ошибка mysql-server при обновлении.

Сообщение #2 Dja » 15 сен 2016, 14:56

Синаптик выкинуть. sudo apt-get install -f
Новичок? - ознакомься с правилами
Изображение
В поисках истины :grabli:
Изображение

В сети
Аватара пользователя
symon2014
Сообщения: 923
Зарегистрирован: 29 авг 2016, 05:17
Решено: 14
Откуда: Феодосия
Благодарил (а): 32 раза
Поблагодарили: 239 раз
Контактная информация:

Re: Ошибка mysql-server при обновлении.

Сообщение #3 symon2014 » 15 сен 2016, 15:11

Dja, Об этой мелкой команде я просто не упомянул, пост получился бы длинным.
► Показать
Изображение :sry:
Debian (8.8) , LMDE2 , LM (18.2 Mate , 17.3 Xfce) , Antergos 17.2 .

Аватара пользователя
zuzabrik
Сообщения: 759
Зарегистрирован: 29 авг 2016, 12:08
Решено: 14
Благодарил (а): 48 раз
Поблагодарили: 214 раз
Контактная информация:

Re: Ошибка mysql-server при обновлении.

Сообщение #4 zuzabrik » 15 сен 2016, 15:55

MySQL настроен?

Такое ощущение что он хочет чтобы ты запустил демон mysqld и сделал там начальную конфигурацию
Имею желание иметь всех желающих, но не имею желающих.

В сети
Аватара пользователя
symon2014
Сообщения: 923
Зарегистрирован: 29 авг 2016, 05:17
Решено: 14
Откуда: Феодосия
Благодарил (а): 32 раза
Поблагодарили: 239 раз
Контактная информация:

Re: Ошибка mysql-server при обновлении.

Сообщение #5 symon2014 » 15 сен 2016, 16:03

И где этого демона найти и запустить?
Изображение :sry:
Debian (8.8) , LMDE2 , LM (18.2 Mate , 17.3 Xfce) , Antergos 17.2 .

Аватара пользователя
Chocobo
Сообщения: 3083
Зарегистрирован: 27 авг 2016, 22:57
Решено: 72
Откуда: НН
Благодарил (а): 301 раз
Поблагодарили: 830 раз
Контактная информация:

Re: Ошибка mysql-server при обновлении.

Сообщение #6 Chocobo » 15 сен 2016, 16:17

symon2014, попробуй purge'нуть этот пакет, затем дай опять же sudo apt-get install -f и попробуй переустановить.

Или поменяй mysql на mariadb - разницы не увидишь :smile:
Изображение

В сети
Аватара пользователя
symon2014
Сообщения: 923
Зарегистрирован: 29 авг 2016, 05:17
Решено: 14
Откуда: Феодосия
Благодарил (а): 32 раза
Поблагодарили: 239 раз
Контактная информация:

Re: Ошибка mysql-server при обновлении.

Сообщение #7 symon2014 » 15 сен 2016, 16:31

Я пурген давал, но инсталл -ф не делал, сейчас попробую полностью вырезать гланды через другое место. Позавчера ещё работало , а сейчас -

Изображение
Изображение :sry:
Debian (8.8) , LMDE2 , LM (18.2 Mate , 17.3 Xfce) , Antergos 17.2 .

В сети
Аватара пользователя
symon2014
Сообщения: 923
Зарегистрирован: 29 авг 2016, 05:17
Решено: 14
Откуда: Феодосия
Благодарил (а): 32 раза
Поблагодарили: 239 раз
Контактная информация:

Re: Ошибка mysql-server при обновлении.

Сообщение #8 symon2014 » 15 сен 2016, 18:03

Победил. Не знаю почему поломался и как починился. Мои последние действия.
Удалил 3 пакета. mysql-server , mysql-server-5.7 , mysql-server-core-5.7 .
Вычистил и аптом и аптитуде( на всякий случай ), запустил установку метапакета mysql-server , выдало ту же ошибку. Нервно покурил и решил ребутнуться. После, первым делом запустил sudo dpkg --configure -a
. Стало выдавать это.
► Показать

Пока шёл процесс я чуть не :harakiri: , но в итоге починилось. Думаю в некоторых случаях полезно делать ребут.
Изображение :sry:
Debian (8.8) , LMDE2 , LM (18.2 Mate , 17.3 Xfce) , Antergos 17.2 .


Вернуться в «Иное программное обеспечение»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей