Установка видеодрайвера AMD (fglrx) в LMDE2 Betsy

Не знаете как установить драйвер? Возникли проблемы? Вам сюда!
Правила форума
Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа.
Аватара пользователя

Автор темы
Chocobo
Сообщения: 5110
Зарегистрирован: 27 авг 2016, 19:57
Решено: 122
Откуда: НН
Благодарил (а): 384 раза
Поблагодарили: 1330 раз

Установка видеодрайвера AMD (fglrx) в LMDE2 Betsy

Сообщение Chocobo » 17 апр 2017, 21:59

Установка AMD Catalyst 15.9 (основной репозиторий)

Код: Выделить всё

sudo -i
aptitude update
aptitude -r install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') fglrx-driver
aticonfig --initial
mkdir /etc/X11/xorg.conf.d
echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "fglrx"\nEndSection' > /etc/X11/xorg.conf.d/20-fglrx.conf

Установка AMD Catalyst 15.12 (jessie-backports)


Необходимо добавить non-free ветку репозитория backports строкой вида

Код: Выделить всё

deb http://ftp.debian.org/debian jessie-backports main contrib non-free
С помощью утилиты "Источники приложений"
2017-04-18-005800_1194x492_scrot.png
Или самостоятельно в файл /etc/apt/sources.list

Код: Выделить всё

echo "deb http://ftp.debian.org/debian jessie-backports main contrib non-free" | sudo tee -a /etc/apt/sources.list
Затем можно устанавливать сам драйвер:

Код: Выделить всё

sudo -i 
aptitude update
aptitude -r install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,')
aptitude install -t jessie-backports fglrx-driver
aticonfig --initial
mkdir /etc/X11/xorg.conf.d
echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "fglrx"\nEndSection' > /etc/X11/xorg.conf.d/20-fglrx.conf
Посте установки перезагружаемся и проверяем, с inxi -G

Драйвер совместим со следующими моделями видеокарт:
  • AMD Radeon™ R9 Fury X
  • AMD Radeon™ R9 Fury
  • AMD Radeon™ R9 Nano
  • AMD Radeon™ R9 300 Series
  • AMD Radeon™ R9 200 Series
  • AMD Radeon™ R7 300 Series
  • AMD Radeon™ R7 200 Series
  • AMD Radeon™ R5 230 Series
  • AMD Radeon™ HD 8000 Series
  • AMD Radeon™ HD 7000 Series
  • AMD Radeon™ HD 6000 Series
  • ATI Radeon™ HD 5000 Series
  • AMD Radeon™ HD 7600A Series
  • AMD Radeon™ HD 7450A Series
  • AMD Radeon™ HD 6600A Series
  • AMD Radeon™ HD 6350A Series
  • A-Series AMD Radeon™ R7 Graphics
  • A-Series AMD Radeon™ R6 Graphics
  • A-Series AMD Radeon™ R5 Graphics
  • A-Series AMD Radeon™ R4 Graphics
  • A-Series AMD Radeon™ R3 Graphics
  • FX-8800P AMD Radeon™ R7 Graphics
  • E-Series AMD Radeon™ R2 Graphics ​
  • AMD Radeon™ HD 8000D Series
  • AMD Radeon™ HD 7000D Series
  • AMD Radeon™ HD 6000D Series
  • AMD Radeon™ HD 8000G Series
  • AMD Radeon™ HD 7000G Series
  • AMD Radeon™ HD 6000G Series
  • AMD Radeon™ R9 M300 Series
  • AMD Radeon™ R7 M300 Series
  • AMD Radeon™ R5 M300 Series
  • AMD Radeon™ R9 M200 Series
  • AMD Radeon™ R7 M200 Series
  • AMD Radeon™ R5 M200 Series
  • AMD Radeon™ HD 8000M Series
  • AMD Radeon™ HD 7000M Series
  • AMD Radeon™ HD 6000M Series
  • ATI Mobility Radeon™ HD 5000 Series
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя

SemenSinchenko
Сообщения: 316
Зарегистрирован: 17 фев 2017, 09:01
Решено: 2
Откуда: Москва
Благодарил (а): 40 раз
Поблагодарили: 41 раз

Установка видеодрайвера AMD (fglrx) в LMDE2 Betsy

Сообщение SemenSinchenko » 18 апр 2017, 06:47

Chocobo, а кстати вопрос совместимости Gnome Shell и fglrx так и не решился? А то помню были проблемы...

Аватара пользователя

Автор темы
Chocobo
Сообщения: 5110
Зарегистрирован: 27 авг 2016, 19:57
Решено: 122
Откуда: НН
Благодарил (а): 384 раза
Поблагодарили: 1330 раз

Установка видеодрайвера AMD (fglrx) в LMDE2 Betsy

Сообщение Chocobo » 18 апр 2017, 06:50

SemenSinchenko, Не углублялся в этот вопрос, LMDE c Gnome-Shell у нас пока не предвидится :smile:
Впрочем, т.к. разработка его уже остановлена - не думаю что будут дальнейшие фиксы, версия 15.12 вышла давненько.

Аватара пользователя

wanoska
Сообщения: 133
Зарегистрирован: 17 окт 2016, 12:36
Решено: 3
Откуда: Кинешма
Благодарил (а): 26 раз
Поблагодарили: 27 раз

Установка видеодрайвера AMD (fglrx) в LMDE2 Betsy

Сообщение wanoska » 12 май 2017, 21:29

Отпишусь как сломал свои иксы, и как починил, может кому поможет

Код: Выделить всё

sudo rm /etc/X11/xorg.conf
sudo nano /etc/X11/xorg.conf
, может и не правильно но мне помогло, жду чокобо с объяснением что я сделал не так :smile:
LM18.2 Cinnamon 3.2.7 Kernel: 4.12.0-041200-generic

Аватара пользователя

Автор темы
Chocobo
Сообщения: 5110
Зарегистрирован: 27 авг 2016, 19:57
Решено: 122
Откуда: НН
Благодарил (а): 384 раза
Поблагодарили: 1330 раз

Установка видеодрайвера AMD (fglrx) в LMDE2 Betsy

Сообщение Chocobo » 13 май 2017, 11:18

wanoska, файл у тебя и сейчас пустой, или туда что либо нагенерилось при загрузке?

У меня такой вот зверек был создан на вызов aticonfig --initial

Код: Выделить всё

~$ cat /etc/X11/xorg.conf
Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:0:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Аватара пользователя

wanoska
Сообщения: 133
Зарегистрирован: 17 окт 2016, 12:36
Решено: 3
Откуда: Кинешма
Благодарил (а): 26 раз
Поблагодарили: 27 раз

Установка видеодрайвера AMD (fglrx) в LMDE2 Betsy

Сообщение wanoska » 13 май 2017, 12:16

Chocobo, пустой сейчас
LM18.2 Cinnamon 3.2.7 Kernel: 4.12.0-041200-generic

Аватара пользователя

Автор темы
Chocobo
Сообщения: 5110
Зарегистрирован: 27 авг 2016, 19:57
Решено: 122
Откуда: НН
Благодарил (а): 384 раза
Поблагодарили: 1330 раз

Установка видеодрайвера AMD (fglrx) в LMDE2 Betsy

Сообщение Chocobo » 13 май 2017, 12:55

wanoska, а в conf.d там есть чего-нибудь похожего? откуда он берет конфиг текущей сессии?

Аватара пользователя

wanoska
Сообщения: 133
Зарегистрирован: 17 окт 2016, 12:36
Решено: 3
Откуда: Кинешма
Благодарил (а): 26 раз
Поблагодарили: 27 раз

Установка видеодрайвера AMD (fglrx) в LMDE2 Betsy

Сообщение wanoska » 13 май 2017, 16:16

Chocobo,
X11.tar.gz
вся папка Х11. Вот от сюда походу xorg.conf.fglrx-0
У вас нет необходимых прав для просмотра вложений в этом сообщении.
LM18.2 Cinnamon 3.2.7 Kernel: 4.12.0-041200-generic

Аватара пользователя

wanoska
Сообщения: 133
Зарегистрирован: 17 окт 2016, 12:36
Решено: 3
Откуда: Кинешма
Благодарил (а): 26 раз
Поблагодарили: 27 раз

Установка видеодрайвера AMD (fglrx) в LMDE2 Betsy

Сообщение wanoska » 14 май 2017, 08:35

wanoska ~ # aptitude -r install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') fglrx-driver
Следующие НОВЫЕ пакеты будут установлены:
fglrx-atieventsd{a} fglrx-driver{b} fglrx-modules-dkms{a} libbsd0:i386{a}
libdrm-intel1:i386{a} libdrm-nouveau2:i386{a} libdrm-radeon1:i386{a}
libdrm2:i386{a} libedit2:i386{a} libelf1:i386{a} libexpat1:i386{a}
libffi6:i386{a} libfglrx:i386{ab} libfglrx-amdxvba1:i386{a}
libgl1-fglrx-glx{ab} libgl1-fglrx-glx:i386{a}
libgl1-fglrx-glx-i386:i386{a} libgl1-mesa-dri:i386{a}
libgl1-mesa-glx:i386{a} libglapi-mesa:i386{a} libllvm3.5:i386{a}
libpciaccess0:i386{a} libtinfo5:i386{a} libudev1:i386{a} libx11-6:i386{a}
libx11-xcb1:i386{a} libxau6:i386{a} libxcb-dri2-0:i386{a}
libxcb-dri3-0:i386{a} libxcb-glx0:i386{a} libxcb-present0:i386{a}
libxcb-sync1:i386{a} libxcb1:i386{a} libxdamage1:i386{a}
libxdmcp6:i386{a} libxext6:i386{a} libxfixes3:i386{a}
libxshmfence1:i386{a} libxxf86vm1:i386{a} zlib1g:i386{a}
0 пакетов обновлено, 40 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 39,8 MB архивов. После распаковки 179 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
libfglrx : Ломает: libfglrx:i386 (!= 1:15.12-2~bpo8+3) но устанавливается 1:15.9-4~deb8u2.
libfglrx:i386 : Ломает: libfglrx (!= 1:15.9-4~deb8u2) но установлен 1:15.12-2~bpo8+3
fglrx-driver : Зависит: libfglrx (= 1:15.9-4~deb8u2) но установлен 1:15.12-2~bpo8+3
libgl1-fglrx-glx : Зависит: libfglrx (= 1:15.9-4~deb8u2) но установлен 1:15.12-2~bpo8+3
Следующие действия разрешат зависимости:

Сохранить для следующих пакетов их текущие версии:
1) fglrx-driver [Не установлен]
2) libfglrx:i386 [Не установлен]
3) libfglrx-amdxvba1:i386 [Не установлен]
4) libgl1-fglrx-glx [Не установлен]
5) libgl1-fglrx-glx:i386 [Не установлен]
6) libgl1-fglrx-glx-i386:i386 [Не установлен]

Оставить следующие зависимости неразрешёнными:
7) fglrx-atieventsd рекомендует fglrx-driver (= 1:15.9-4~deb8u2)


Принять данное решение? [Y/n/q/?] ^C
зависимости какие то просит, опять что то наковырял блин :aggressive:
LM18.2 Cinnamon 3.2.7 Kernel: 4.12.0-041200-generic

Аватара пользователя

Автор темы
Chocobo
Сообщения: 5110
Зарегистрирован: 27 авг 2016, 19:57
Решено: 122
Откуда: НН
Благодарил (а): 384 раза
Поблагодарили: 1330 раз

Установка видеодрайвера AMD (fglrx) в LMDE2 Betsy

Сообщение Chocobo » 14 май 2017, 08:38

wanoska, наставлены зависимости из бекпортов.
wanoska писал(а): установлен 1:15.12-2~bpo8+3
Либо грохни их сначала по очереди, либо пробуй ставить catalyst 15.12

Аватара пользователя

wanoska
Сообщения: 133
Зарегистрирован: 17 окт 2016, 12:36
Решено: 3
Откуда: Кинешма
Благодарил (а): 26 раз
Поблагодарили: 27 раз

Установка видеодрайвера AMD (fglrx) в LMDE2 Betsy

Сообщение wanoska » 14 май 2017, 08:53

поставил 15.12,упала корица
Прекращена работа Cinnamon. Вы перешли в Резервный режим.

Вы хотите перезапустить Cinnamon?

inxi -G
Graphics: Card: Advanced Micro Devices [AMD/ATI] Wrestler [Radeon HD 6320]
Display Server: X.Org 1.16.4 driver: fglrx
Resolution: 1366x768@59.99hz
GLX Renderer: N/A GLX Version: N/A
LM18.2 Cinnamon 3.2.7 Kernel: 4.12.0-041200-generic

Аватара пользователя

Автор темы
Chocobo
Сообщения: 5110
Зарегистрирован: 27 авг 2016, 19:57
Решено: 122
Откуда: НН
Благодарил (а): 384 раза
Поблагодарили: 1330 раз

Установка видеодрайвера AMD (fglrx) в LMDE2 Betsy

Сообщение Chocobo » 14 май 2017, 08:57

wanoska, просто до этого, судя по поломанным зависимостям - именно он у тебя и стоял :hoho:

Аватара пользователя

wanoska
Сообщения: 133
Зарегистрирован: 17 окт 2016, 12:36
Решено: 3
Откуда: Кинешма
Благодарил (а): 26 раз
Поблагодарили: 27 раз

Установка видеодрайвера AMD (fglrx) в LMDE2 Betsy

Сообщение wanoska » 14 май 2017, 09:00

Chocobo, ну да я пробовал его ставить, было то же самое, потом я сломал иксы заодно, теперь вот решил еще раз попробовать и опять корица умерла. Теперь вопрос как поднять корицу?
LM18.2 Cinnamon 3.2.7 Kernel: 4.12.0-041200-generic


pugachev.e
Сообщения: 11
Зарегистрирован: 29 июл 2017, 19:28
Благодарил (а): 1 раз

Установка видеодрайвера AMD (fglrx) в LMDE2 Betsy

Сообщение pugachev.e » 04 авг 2017, 13:59

зачем вообще ставить catalist если всё работает без него и ещё r7 370, в списке он как AMD Radeon™ R7 300 Series просто вырубается или как это назвать с монитора другой видеокарты r7 250 мышка переходит на монитор под управлением r7 370, а вот подхваченное окно упирается в край монитора :dash2: удаление каталиста не дала ничего монитор так и остался в шоковом состоянии так как это была только примерка к линукс просто переустановил

Аватара пользователя

Автор темы
Chocobo
Сообщения: 5110
Зарегистрирован: 27 авг 2016, 19:57
Решено: 122
Откуда: НН
Благодарил (а): 384 раза
Поблагодарили: 1330 раз

Установка видеодрайвера AMD (fglrx) в LMDE2 Betsy

Сообщение Chocobo » 04 авг 2017, 17:17

pugachev.e писал(а): зачем вообще ставить catalist если всё работает без него
Так никто ж и не заставляет вроде. :smile:
У меня основным критерием на моих amd-карточках (старая HD5450 и текущая r9270X) - было отказ работать 3D и steam под radeon, там у него все свосем плохо. А поиграть иногда все же бывает и времечко и желание.
Вот мультимониторных конфигураций у меня пока нет, поэтому не тестил такой юзкейс.

Вернуться в «Видеокарты»