PaleMoon

Интернет
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
Аватара пользователя

Ivan 85
Сообщения: 155
Зарегистрирован: 13 ноя 2017, 17:14
Решено: 1
Благодарил (а): 14 раз

Установка расширения в Pale Moon

Сообщение Ivan 85 » 20 июл 2018, 08:45

Всем привет! Подскажите как обстоят дела с расширениями в Pale Moon (например: FastProxy,Seller Check,Flash Video Downloader,uBlock Origin). Пробывал ставить данный браузер примерно год назад и там была проблема с установкой браузерных расширений пришлось снести. Проблемы остались или нет?
 ! Сообщение из: Chocobo
Перенесено в общую ветку по PM

Аватара пользователя

darkfenix
Сообщения: 3019
Зарегистрирован: 27 июн 2017, 10:36
Решено: 32
Откуда: Нижний Тагил
Благодарил (а): 190 раз
Поблагодарили: 507 раз

Установка расширения в Pale Moon

Сообщение darkfenix » 20 июл 2018, 08:49

Да вроде ставятся расширения, только вот отсюда https://addons.palemoon.org/extensions/
Изображение

В сети
Аватара пользователя

Автор темы
Chocobo
Сообщения: 8274
Зарегистрирован: 27 авг 2016, 19:57
Решено: 179
Откуда: НН
Благодарил (а): 553 раза
Поблагодарили: 2223 раза

PaleMoon

Сообщение Chocobo » 20 июл 2018, 08:57

Ivan 85, Работали лисьи аддоны всегда. Правда не все подряд, но немалая их часть.
Да и в последнем чейнджлоге вот как раз есть о том, что этот функционал отслеживается на предмет изменений.
x230 писал(а):
17 июл 2018, 13:56
Обновлен useragent для addons.mozilla.org, чтобы обойти их дискриминацию «Только с Firefox», не позволяя пользователям загружать темы, старые версии расширений и другие файлы с помощью Pale Moon.
Изображение
   
Изображение

Аватара пользователя

Ivan 85
Сообщения: 155
Зарегистрирован: 13 ноя 2017, 17:14
Решено: 1
Благодарил (а): 14 раз

PaleMoon

Сообщение Ivan 85 » 20 июл 2018, 10:09

darkfenix писал(а):
20 июл 2018, 08:49
Да вроде ставятся расширения, только вот отсюда https://addons.palemoon.org/extensions/
Как я понял предварительно посмотрев ссылку не все расширение есть?
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Последний раз редактировалось пользователем 1 Ivan 85; всего редактировалось раз: 20

Аватара пользователя

darkfenix
Сообщения: 3019
Зарегистрирован: 27 июн 2017, 10:36
Решено: 32
Откуда: Нижний Тагил
Благодарил (а): 190 раз
Поблагодарили: 507 раз

PaleMoon

Сообщение darkfenix » 20 июл 2018, 10:10

Ivan 85, возможно, я лисой пользуюсь
Изображение

Аватара пользователя

x230
Сообщения: 1101
Зарегистрирован: 02 сен 2016, 19:07
Решено: 3
Откуда: Краснодарский край
Благодарил (а): 222 раза
Поблагодарили: 280 раз

PaleMoon

Сообщение x230 » 20 июл 2018, 12:09

Ivan 85 писал(а):
20 июл 2018, 10:09
?
отсюда скачал только тему:


а расширения стащил отсюда:


И очень даже комильфо!


useragent - такой:
моя платформа :
ОС: Linux Mint 18.3, x64 DE: Xfce 4.12.3 Ядро: 4.15.1 Browser: Pale Moon 27.*; Железо: Intel Core i3-3210; Mem 4GB; VGA - на борту.

Аватара пользователя

x230
Сообщения: 1101
Зарегистрирован: 02 сен 2016, 19:07
Решено: 3
Откуда: Краснодарский край
Благодарил (а): 222 раза
Поблагодарили: 280 раз

PaleMoon

Сообщение x230 » 16 авг 2018, 15:22

Релиз v28.0.0 (2018-08-16)
ReleaseNotes

Это новая важная веха в истории выпуска Pale Moon.

В настоящее время мы строим платформу Unified XUL, которая была разветвлена ​​с мозилла-центра Mozilla в момент, когда Rust и Quantum продолжали фокусироваться на языке интерфейса XUL и традиционных расширениях браузера. С тех пор, как версии v27 (AKA «Tycho») изменились, многие тысячи вещей изменились, и здесь не все могут быть перечислены. Вместо этого наиболее важные улучшения в этом новом выпуске выделены здесь:
● Обновление SpiderMonkey: механизм JavaScript получил значительное обновление и теперь поддерживает все важные функции из стандартов ECMAScript, которые переносятся основными браузерами. Это должно положить конец растущим проблемам JavaScript, которые мы видели из-за того, что веб-фреймворки не являются агронизирующими браузерами в этом отношении, или браузер, не поддерживающий ожидаемые веб-сайты.
● Обновление Goanna: механизм компоновки и рендеринга (Goanna) был обновлен до 4-го поколения (версия 4. *), благодаря чему улучшена совместимость с «модными» стилями CSS-стилей, которые основаны на нескольких очень специфических функциях (например, CSS Grid) , Goanna продолжает использовать проверенные программные резервные копии в случае, если аппаратное ускорение не может быть использовано, а пользователи удаленного рабочего стола Linux могут продолжать использовать xrender для быстрого обновления удаленного экрана в Pale Moon.
● Улучшения DOM: Усовершенствования в объектной модели документа предоставляют веб-сайты с обновленными API-интерфейсами для выполнения своих задач. (например, Fetch, WebAnimations, WebCrypto, HTML Input Element Extensions и т. д.)
● Улучшения в средствах массовой информации. Наше мультимедийное фоновое обновление, по сути, завершено. Потоковая передача MSE (для MP4) должна быть совместима со всеми основными игроками на рынке. MSE для WebM по-прежнему отключен по умолчанию из-за некоторых проблем совместимости, которые необходимо изучить, но вы можете включить это в настройках, например, разрешить воспроизведение 4k видео на некоторых сайтах, которые предлагают только UHD в формате WebM. Теперь мы также поддерживаем воспроизведение аудио в кодировке FLAC.
● Новое: поддержка WebGL2! Pale Moon теперь поддерживает стандарт WebGL2 для улучшения графического опыта в 2D и 3D.
● Devtools получили обновление. На всякий случай, если вы считаете, что они недостаточно обширны, некоторые новые категории были добавлены для проверки и управления всеми аспектами веб-контента.
● Обновления для менеджера входа: учетные данные для входа теперь могут быть сохранены специально с именем пользователя или без него и выбраны отдельно. Это изменение поведения от предыдущего, и нажатие поля пароля теперь может отображать список имен пользователей, для которых хранятся пароли (при сохранении нескольких учетных данных). При нажатии соответствующего имени пользователя (или даты с отметкой даты, если имя отсутствует) будет заполнен сопроводительный пароль.
.
Что может быть более важным для людей, которые беспокоятся о переходе на эту веху, - это то, что не изменилось.
● Мы продолжаем поддерживать плагины NPAPI.
● Мы продолжаем поддерживать полные темы, а также облегченные темы.
● Мы по-прежнему предлагаем полностью настраиваемый интерфейс, как раньше. Australis (как видно в Василиске) не используется.
● Мы по-прежнему поддерживаем XUL-наложение, загруженные и устаревшие расширения Jetpack (совместно называемые «устаревшими расширениями» Mozilla).
● Мы не включаем DRM в браузер (люди, которым это нужно, могут использовать, например, плагин Silverlight для воспроизведения защищенного контента), хотя платформа, на которой мы строим, поддерживает ее.
.
Наша главная цель - поднять Pale Moon на новую платформу, и поэтому большинство изменений «под капотом» и не будут замечены в повседневном использовании (кроме того, что больше всего «работает»). Мы стремимся поддерживать постоянство и логичность вашего пользователя; но некоторые вещи, конечно, будут изменены. Расширения браузера, возможно, нуждаются в обновлении или могут потребоваться, например, в другой версии.

Конечно, с такой большой заменой платформы есть некоторые вещи, которые регрессировали (раньше работали, но сейчас не работают), и мы будем работать над исправлением этих регрессий с течением времени (надеюсь, с вашей помощью).

Проверка реальности: Несмотря на то, что мы тщательно тестировали браузер в ежедневном использовании в течение нескольких месяцев (также благодаря смелым душам на нашем неустойчивом канале), мы не ожидаем, что браузер будет безупречен или без ошибок. Если вы найдете ошибки, регрессии или проблемы с новой версией, пожалуйста, обсудите их на форуме. Давайте работать вместе как сообщество пользователей, чтобы сделать это лучшим браузером!

Большие благодарности и прекрасности выходят всем, кто так или иначе способствовал этому выпуску этапов и помог сделать это возможным. Это принадлежит всем вам!

* * * * * *
Дополнение с форума PM:
Pale Moon 28 и расширения
(взято с форума PM (https://forum.palemoon.org/viewtopic.ph ... 8ae884002a))
(posted by 'Moonchild' 23 июл 2018)
Чтобы повторить и уточнить ситуацию с расширениями на Pale Moon 28, я хотел бы объявить следующее:

Когда Mozilla отказалась от всех наложений XUL, бутстрапов и расширений для Jetpack, а это зависит от независимых усилий, чтобы сохранить эту экосистему в живых.
Тем не менее мы намерены поддерживать совместимость с (неизмененными) расширениями Firefox.
Pale Moon (теперь более чем когда-либо) считается другим приложением, и для этого необходимы расширения для приложений.
В то время как предстоящий выпуск релиза Pale Moon 28 снял все ограничения с точки зрения диапазона версий и дальнейшего ограничения на jetpack специально для расширений, которые не нацелены на Pale Moon конкретно, они не поддерживаются нами, и нет никакой гарантии, что они будут работать в неизмененном виде.

Позиция проекта Pale Moon Project заключается в том, что, если расширение напрямую не поддерживает и не нацелено на Pale Moon, все расширения Firefox считаются неподдерживаемыми и на свой страх и риск. Мы больше не будем навязывать им каких-либо ограничений, и никаких дальнейших усилий по их удовлетворению не будет. То, что вы видите, это то, что вы получаете, и ваш пробег ('опыт'?) может отличаться. Если расширение Firefox не работает или не работает полностью на Pale Moon 28, это должно быть расширение, которое должно измениться, чтобы исправить это.

Любое усилие во имя расширений на Pale Moon должно продолжаться вперед, как расширения Pale Moon, путем разметки расширений Firefox (с разрешения лицензии) или привлечения разработчиков к нашим трущобам, чтобы напрямую нацелиться на Pale Moon. Во многих случаях корректировка расширений, необходимых для нацеливания на Pale Moon и их расширение Pale Moon, будет минимальной, но необходимо предпринять согласованные усилия, чтобы специально ориентировать приложение.

Это объявление не является практическим изменением нынешнего статус-кво, но разъяснение и напоминание об этом.

В качестве дополнительного напоминания: поддерживаемые технологии расширения Pale Moon основаны на XUL (либо накладываются, загружаются, либо используются устаревшие библиотеки Jetpack), а WebExtensions не поддерживаются и не будут поддерживаться Pale Moon любым способом, формой или формой.
Улучшение кода Mozilla: вы знаете, что находитесь на правильном пути с изменениями кода, когда вы тратите большую часть времени на удаление кода.

«Если вы хотите создать для себя лучший мир, вы должны быть готовы построить его для всех». - Койот Осборн
Последний раз редактировалось пользователем 1 x230; всего редактировалось раз: 16
моя платформа :
ОС: Linux Mint 18.3, x64 DE: Xfce 4.12.3 Ядро: 4.15.1 Browser: Pale Moon 27.*; Железо: Intel Core i3-3210; Mem 4GB; VGA - на борту.

Аватара пользователя

x230
Сообщения: 1101
Зарегистрирован: 02 сен 2016, 19:07
Решено: 3
Откуда: Краснодарский край
Благодарил (а): 222 раза
Поблагодарили: 280 раз

PaleMoon

Сообщение x230 » 16 авг 2018, 15:36

28-ая версия у меня пока не обновляется на 2018.08.16 18:30мск :

Хотя с Инетом все в порядке!
Ждёмс...
моя платформа :
ОС: Linux Mint 18.3, x64 DE: Xfce 4.12.3 Ядро: 4.15.1 Browser: Pale Moon 27.*; Железо: Intel Core i3-3210; Mem 4GB; VGA - на борту.

Аватара пользователя

x230
Сообщения: 1101
Зарегистрирован: 02 сен 2016, 19:07
Решено: 3
Откуда: Краснодарский край
Благодарил (а): 222 раза
Поблагодарили: 280 раз

PaleMoon

Сообщение x230 » 17 авг 2018, 10:42

Добавил репу как указано здесь:
sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/stevenpusser/xUbuntu_16.04/ /' > /etc/apt/sources.list.d/home:stevenpusser.list"
wget -nv https://download.opensuse.org/repositories/home:stevenpusser/xUbuntu_16.04/Release.key -O Release.key
sudo apt-key add - < Release.key
sudo apt-get update
sudo apt-get install palemoon

.
При попытке установить из Синаптика

.
Выдал ошибку:

.
При попытке уст-ть в консоли выдал больше инфы:
sudo apt-get install palemoon
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
palemoon : Зависит: libavcodec54 но он не может быть установлен или
libavcodec-extra54 но он не может быть установлен или
libavcodec55 но он не может быть установлен или
libavcodec-extra55 но он не может быть установлен или
libavcodec56 но он не может быть установлен или
libavcodec-extra56 но он не может быть установлен или
libavcodec57 но он не может быть установлен или
libavcodec-extra57 но он не может быть установлен или
libavcodec58 но он не может быть установлен или
libavcodec-extra58 но он не может быть установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.


Пересел временно на FF... :sad: А временно ли?? :scratch:
моя платформа :
ОС: Linux Mint 18.3, x64 DE: Xfce 4.12.3 Ядро: 4.15.1 Browser: Pale Moon 27.*; Железо: Intel Core i3-3210; Mem 4GB; VGA - на борту.

Аватара пользователя

AlexelA
Сообщения: 411
Зарегистрирован: 24 июл 2017, 17:11
Решено: 2
Откуда: город-герой Новороссийск
Благодарил (а): 41 раз
Поблагодарили: 85 раз

PaleMoon

Сообщение AlexelA » 17 авг 2018, 15:44

x230 писал(а):
17 авг 2018, 10:42
Пересел временно на FF...
ИМХО, ФФ более-менее устаканился...
Для того, чтобы ничего не делать, надо уметь делать все! (©) (А.Лебедь)
https://linux-hardware.org/?probe=f616eaca40
FM2A85X Extreme6 (8GB RAM)+AMD A8-5600K+NVIDIA GeForce GTX 660 (2GB)+BENQ GL2460+LMC 18.3x64...

Аватара пользователя

x230
Сообщения: 1101
Зарегистрирован: 02 сен 2016, 19:07
Решено: 3
Откуда: Краснодарский край
Благодарил (а): 222 раза
Поблагодарили: 280 раз

PaleMoon

Сообщение x230 » 18 авг 2018, 08:34

Так что, похоронили Palemoon?
Как-то очень не хочется... :sad:
.
И что с этим делать?

Как ставить PM?
...
Поискал в Инете требуемое... - был послан неск.раз и забил на это дело!..
...
Верните мне Palemoon!
...
Плиз!..

.
моя платформа :
ОС: Linux Mint 18.3, x64 DE: Xfce 4.12.3 Ядро: 4.15.1 Browser: Pale Moon 27.*; Железо: Intel Core i3-3210; Mem 4GB; VGA - на борту.

Аватара пользователя

darkfenix
Сообщения: 3019
Зарегистрирован: 27 июн 2017, 10:36
Решено: 32
Откуда: Нижний Тагил
Благодарил (а): 190 раз
Поблагодарили: 507 раз

PaleMoon

Сообщение darkfenix » 18 авг 2018, 08:42

А что скрипт для установки/обновления так и не заработал?
Изображение

Аватара пользователя

x230
Сообщения: 1101
Зарегистрирован: 02 сен 2016, 19:07
Решено: 3
Откуда: Краснодарский край
Благодарил (а): 222 раза
Поблагодарили: 280 раз

PaleMoon

Сообщение x230 » 18 авг 2018, 10:05

darkfenix писал(а):
18 авг 2018, 08:42
А что скрипт для установки/обновления так и не заработал?
Не-а
моя платформа :
ОС: Linux Mint 18.3, x64 DE: Xfce 4.12.3 Ядро: 4.15.1 Browser: Pale Moon 27.*; Железо: Intel Core i3-3210; Mem 4GB; VGA - на борту.

Аватара пользователя

darkfenix
Сообщения: 3019
Зарегистрирован: 27 июн 2017, 10:36
Решено: 32
Откуда: Нижний Тагил
Благодарил (а): 190 раз
Поблагодарили: 507 раз

PaleMoon

Сообщение darkfenix » 18 авг 2018, 10:10

x230 писал(а):
17 авг 2018, 10:42
deb http://download.opensuse.org/repositori ... ntu_16.04/
С этим репом какие-то проблемы. Пробовал другой реп?

UPD: Тут предлагают скачать руками. Или вот еще
Изображение

Аватара пользователя

x230
Сообщения: 1101
Зарегистрирован: 02 сен 2016, 19:07
Решено: 3
Откуда: Краснодарский край
Благодарил (а): 222 раза
Поблагодарили: 280 раз

PaleMoon

Сообщение x230 » 18 авг 2018, 10:21

darkfenix писал(а):
18 авг 2018, 10:10
... другой реп? ... руками ... Или
Других реп со свежими версиями нету. Руками не могу (как тот работник: "работать не могу, воровать боюсь").
Столько лет пилят версии под линь, а за дебку не подумали... :sad:
моя платформа :
ОС: Linux Mint 18.3, x64 DE: Xfce 4.12.3 Ядро: 4.15.1 Browser: Pale Moon 27.*; Железо: Intel Core i3-3210; Mem 4GB; VGA - на борту.

Аватара пользователя

darkfenix
Сообщения: 3019
Зарегистрирован: 27 июн 2017, 10:36
Решено: 32
Откуда: Нижний Тагил
Благодарил (а): 190 раз
Поблагодарили: 507 раз

PaleMoon

Сообщение darkfenix » 18 авг 2018, 10:26

x230 писал(а):
18 авг 2018, 10:21
Руками не могу
Ну тогда подумаем как можно решить эту проблему :smile:
Изображение

Аватара пользователя

x230
Сообщения: 1101
Зарегистрирован: 02 сен 2016, 19:07
Решено: 3
Откуда: Краснодарский край
Благодарил (а): 222 раза
Поблагодарили: 280 раз

PaleMoon

Сообщение x230 » 18 авг 2018, 10:45

darkfenix писал(а):
18 авг 2018, 10:26
Ну тогда подумаем как можно решить эту проблему
А дебку долго собирать?
моя платформа :
ОС: Linux Mint 18.3, x64 DE: Xfce 4.12.3 Ядро: 4.15.1 Browser: Pale Moon 27.*; Железо: Intel Core i3-3210; Mem 4GB; VGA - на борту.

Аватара пользователя

x230
Сообщения: 1101
Зарегистрирован: 02 сен 2016, 19:07
Решено: 3
Откуда: Краснодарский край
Благодарил (а): 222 раза
Поблагодарили: 280 раз

PaleMoon

Сообщение x230 » 18 авг 2018, 12:55

x230 писал(а):
18 авг 2018, 10:45
как можно решить эту проблему
Пока решил проблему следующим образом:
Скачал с их ФТП архивчик с версией 27.9.4 и переписал получившийся после разархивации каталог в /opt/.
Сделал значок (и на горячую клавишу закинул соотв.) с командой /opt/palemoon/palemoon;
на иконку значка повесил это: /opt/palemoon/browser/icons/mozicon128.png.
.
На закуску создал ярлык и в Гл.меню (через прогу alacarte):

.
Я рад.
Пока значит так, но в перспективе думать надыть как переходить на вер.28.
Может также, кустарно?
Хочется все-таки (полу)официально, хотябы как было.
моя платформа :
ОС: Linux Mint 18.3, x64 DE: Xfce 4.12.3 Ядро: 4.15.1 Browser: Pale Moon 27.*; Железо: Intel Core i3-3210; Mem 4GB; VGA - на борту.

Аватара пользователя

darkfenix
Сообщения: 3019
Зарегистрирован: 27 июн 2017, 10:36
Решено: 32
Откуда: Нижний Тагил
Благодарил (а): 190 раз
Поблагодарили: 507 раз

PaleMoon

Сообщение darkfenix » 18 авг 2018, 14:01

x230, накидал такой скриптик. Тут есть более сведущие в bash - думаю поправят где нужно, если нужно :smile:

Код: Выделить всё

#!/usr/bin/env bash

if [[ "$1" = "install" ]]; then
  version=$2
  link="https://linux.palemoon.org/datastore/release/palemoon-$version.linux-x86_64.tar.bz2"
  archName="palemoon-$version.linux-x86_64.tar.bz2"

  do="install"

  if [ ! -f "$archName" ]; then
    curl -O $link
  fi

  if [ -d /opt/palemoon ]; then
    do="update"
  fi

  if [[ "$do" = "install" ]];
  then
    sudo tar -xvf $archName -C /opt
    sudo sh -c '
      ln -s /opt/palemoon/palemoon /usr/bin/palemoon
      ln -s /opt/palemoon/browser/chrome/icons/default/default16.png /usr/share/icons/hicolor/16x16/apps/palemoon.png
      ln -s /opt/palemoon/browser/chrome/icons/default/default32.png /usr/share/icons/hicolor/32x32/apps/palemoon.png
      ln -s /opt/palemoon/browser/chrome/icons/default/default48.png /usr/share/icons/hicolor/48x48/apps/palemoon.png
      ln -s /opt/palemoon/browser/icons/mozicon128.png /usr/share/icons/hicolor/128x128/apps/palemoon.png
      echo "[Desktop Entry]
        Version=1.0
        Name=Pale Moon Web Browser
        Comment=Browse the World Wide Web
        Keywords=Internet;WWW;Browser;Web;Explorer
        Exec=palemoon %u
        Terminal=false
        X-MultipleArgs=false
        Type=Application
        Icon=palemoon
        Categories=Network;WebBrowser;Internet
        MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/rss+xml;application/rdf+xml;image/gif;image/jpeg;image/png;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;x-scheme-handler/chrome;video/webm;application/x-xpinstall;
        StartupNotify=true" > /usr/share/applications/palemoon.desktop
      gtk-update-icon-cache -f /usr/share/icons/hicolor'
  elif [[ "$do" = "update" ]]; then
    sudo rm -r /opt/palemoon
    sudo tar -xvf $archName -C /opt
  fi

  rm $archName
elif [[ "$1" = "delete" ]]; then
  sudo sh -c '
    rm -r /opt/palemoon
    rm /usr/bin/palemoon
    rm /usr/share/icons/hicolor/16x16/apps/palemoon.png
    rm /usr/share/icons/hicolor/32x32/apps/palemoon.png
    rm /usr/share/icons/hicolor/48x48/apps/palemoon.png
    rm /usr/share/icons/hicolor/128x128/apps/palemoon.png
    rm /usr/share/applications/palemoon.desktop
    gtk-update-icon-cache -f /usr/share/icons/hicolor'
fi
Сохрани в удобном тебе месте, задай имя.
Выдай права на исполнение chmod +x script_name.

Использование:(все команды в консоли) Кнопка запуска в меню создается.
Тестировал на LMDE3.
Изображение

Аватара пользователя

x230
Сообщения: 1101
Зарегистрирован: 02 сен 2016, 19:07
Решено: 3
Откуда: Краснодарский край
Благодарил (а): 222 раза
Поблагодарили: 280 раз

PaleMoon

Сообщение x230 » 18 авг 2018, 16:54

darkfenix писал(а):
18 авг 2018, 14:01
накидал ... скриптик
Ну, это ты скромничаешь!
Скриптище получился хороший! СПСБ!
Видно, что работа проведена большая.
.
Устанавливал им версию 28 и версию 27.
Только для 27-ых версий нужно менять пути к архиву инсталяхи.

По крайней мере - корректная установка/удаление!
Ручками будем лишние движения делать пока... а потом что-нибудь придумаем.
Еще раз СПСБ!
Не могу поставить "палец вверх" - он у меня не работает! Эттт вопрос к di_mok и Chocobo??

* * * * * *

И так, Релиз версии 28.0.0
Первые впечателения.
.
Давеча я отписался в панике, что установить-то как раз 28-ую версию - уже проблема.
Благодаря darkfenix все ставится и убивается (почти) ровно.
После установки 28-ой версии сразу бросилась в глаза шкура (стояла тема Aeromoon 1.5.0 - при первом запуске предложено сменить языковое доп-ние и версию темы оформ.на 2.2.0) к иконкам/значкам папок добавили какие-то странные галочки:
.
было(27.9.4):

стало(28.0.0):

Не понравилось.
.
Но! В вер.27.9.4 на Яндекс.Деньги не показывает историю платежей, а в 28.0.0 - показывает норм. Транзакции не проводил - денихх мало пока - позже попробую - как работает...
.
моя платформа :
ОС: Linux Mint 18.3, x64 DE: Xfce 4.12.3 Ядро: 4.15.1 Browser: Pale Moon 27.*; Железо: Intel Core i3-3210; Mem 4GB; VGA - на борту.

Вернуться в «Работа с сетью»