Ошибка монтирования NTFS диска в Linux Mint

Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

Автор темы
ostrovok
Сообщения: 38
Зарегистрирован: 27 авг 2016, 22:49
Благодарил (а): 6 раз
Поблагодарили: 1 раз

Ошибка монтирования NTFS диска в Linux Mint

Сообщение ostrovok » 05 сен 2016, 16:33

Здравствуйте.
Помогите пожалуйста с проблемой монтирования диска виндовс в линукс минт.
Когда я нажимаю на иконку диска в файловом менеджере - появляется вот такая ошибка
При обращении к «Домашняя папка» произошла ошибка, ответ системы: The requested operation has failed: Error mounting /dev/sda2 at /media/ostrovok/6E28FF8128FF469D: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda2" "/media/ostrovok/6E28FF8128FF469D"' exited with non-zero exit status 14: Windows is hibernated, refused to mount. Failed to mount '/dev/sda2': Operation not permitted The NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting), or mount the volume read-only with the 'ro' mount option.
Минт установлен рядом с Windows8.1
Так выглядит диск в редакторе разделов
hdd_gparted.png
Подскажите пожалуйста в чем проблема?

Решение Anonymous » 05 сен 2016, 18:08
ostrovok писал(а): The NTFS partition is in an unsafe state. Please resume and shutdownWindows fully (no hibernation or fast restarting), or mount the volumeread-only with the 'ro' mount option.
Прямым и ясным, англицким по белому, уговаривает, отключите быстрый запуск в винде.

Перейти к ответу ➙
У вас нет необходимых прав для просмотра вложений в этом сообщении.

В сети
Аватара пользователя

di_mok
Сообщения: 2330
Зарегистрирован: 27 авг 2016, 16:06
Решено: 15
Откуда: Арзамас
Благодарил (а): 606 раз
Поблагодарили: 351 раз

Re: Ошибка монтирования NTFS диска в Linux Mint

Сообщение di_mok » 05 сен 2016, 16:56

Попробуй

Код: Выделить всё

mount -t ntfs-3g -o remove_hiberfile /dev/sda2 /mnt/чего-то-там
или гибернацию в восьмёрке грохнуть.
Настоящая водка — это не пьянство, а ключ к своей совести, с нее-то и начинается настоящая мудрость. (c)


Автор темы
ostrovok
Сообщения: 38
Зарегистрирован: 27 авг 2016, 22:49
Благодарил (а): 6 раз
Поблагодарили: 1 раз

Re: Ошибка монтирования NTFS диска в Linux Mint

Сообщение ostrovok » 05 сен 2016, 17:44

Вот что получилось. Диска так и не видно.

Код: Выделить всё

ostrovok@linmint:~ > sudo mount -t "ntfs-3g" -o remove_hiberfile "/dev/sda2" "/media/ostrovok/6E28FF8128FF469D
"
[sudo] password for ostrovok: 
The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda2': Операция не позволена
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.
:sad:
Восьмерка не в гибернации, она выключена сейчас

Аватара пользователя

val
Сообщения: 38
Зарегистрирован: 02 сен 2016, 22:17
Решено: 2
Поблагодарили: 9 раз

Re: Ошибка монтирования NTFS диска в Linux Mint

Сообщение val » 05 сен 2016, 17:45

ostrovok писал(а): Please resume and shutdown
Windows fully (no hibernation or fast restarting)
зайдите в винду и завершите корректно ее работу -либо перезагрузкой компа либо выключением
В чем Сила Брат?!А Сила,она во Сне! :smoke:


symon2014

Re: Ошибка монтирования NTFS диска в Linux Mint

Сообщение symon2014 » 05 сен 2016, 18:08

ostrovok писал(а): The NTFS partition is in an unsafe state. Please resume and shutdownWindows fully (no hibernation or fast restarting), or mount the volumeread-only with the 'ro' mount option.
Прямым и ясным, англицким по белому, уговаривает, отключите быстрый запуск в винде.


Автор темы
ostrovok
Сообщения: 38
Зарегистрирован: 27 авг 2016, 22:49
Благодарил (а): 6 раз
Поблагодарили: 1 раз

Re: Ошибка монтирования NTFS диска в Linux Mint

Сообщение ostrovok » 06 сен 2016, 19:46

symon2014, большое спасибо, нашел нужную галку (fast reboot) в настройках виндовс, в настройках электропитания :thumbs:


Filin
Сообщения: 176
Зарегистрирован: 05 ноя 2016, 15:20
Решено: 1
Благодарил (а): 26 раз
Поблагодарили: 21 раз

Ошибка монтирования NTFS диска в Linux Mint

Сообщение Filin » 16 июн 2017, 07:22

Уже не раз последнее время сталкиваюсь с тем, что не получается отключить гибернацию в windows и соответственно потом из Linux нет возможности примонтировать NTFS. Стандартный способ отключить функцию в панели управления у меня не срабатывал. Причину не знаю...возможно кривые сборки windows или майкрософт мудрит. Рабочий файл гибернации hiberfil sys не удаляется даже если есть админские права. С загрузочной флешки удалить можно но до первой перезагрузки а потом он появляется вновь так как сама гибернация не отключена программно. А вчера натолкнулся на железный способ добить таки гибернацию, удалить файл hiberfil sys и заодно отключить навсегда. В ветке реестра windows
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power
значения параметров HiberFileSizePercent и HibernateEnabled установить равным нулю, сохранить изменения и перезагрузится. После перезагрузки файл hiberfil sys как корова языком слизала и одновременно на диске освободилось место как минимум на 3 Гб (зависит от установленной памяти на компьютере). Почерпнул метод отсюда
Последний раз редактировалось пользователем 1 Dja; всего редактировалось раз: 27
Причина: BB-codes

Вернуться в «Загрузка системы, бэкапы и восстановление»