IPSec L2TP client Linux Mint 18 18.1

Интернет
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
Аватара пользователя

Автор темы
Dja
Сообщения: 5946
Зарегистрирован: 27 авг 2016, 17:03
Решено: 26
Откуда: Voskresensk
Благодарил (а): 860 раз
Поблагодарили: 625 раз

IPSec L2TP client Linux Mint 18 18.1

Сообщение Dja » 27 сен 2018, 17:32

darkfenix, я это понял. Не понял почему то, что должно работать и работало сейчас требует какую-то другую версию... Новое должно работать и поддерживать старое, а не выпиливать старое...

Аватара пользователя

darkfenix
Сообщения: 5393
Зарегистрирован: 27 июн 2017, 10:36
Решено: 61
Откуда: Нижний Тагил
Благодарил (а): 295 раз
Поблагодарили: 996 раз

IPSec L2TP client Linux Mint 18 18.1

Сообщение darkfenix » 27 сен 2018, 17:36

Dja, что за логика? Новая версия программы использует новую версию библиотеки, т.к. для работы программы потребовались новые фукции, а он есть в новой версии библиотеки.
Изображение

Аватара пользователя

root
Сообщения: 942
Зарегистрирован: 16 фев 2017, 17:03
Решено: 5
Откуда: г. Хабаровск
Благодарил (а): 284 раза
Поблагодарили: 259 раз

IPSec L2TP client Linux Mint 18 18.1

Сообщение root » 27 сен 2018, 17:54

darkfenix, возникает закономерный вопрос: какие же новые функции ей могли потребоваться...
Вы не готовы! :pc2:
Изображение

Аватара пользователя

darkfenix
Сообщения: 5393
Зарегистрирован: 27 июн 2017, 10:36
Решено: 61
Откуда: Нижний Тагил
Благодарил (а): 295 раз
Поблагодарили: 996 раз

IPSec L2TP client Linux Mint 18 18.1

Сообщение darkfenix » 27 сен 2018, 17:58

root, хороший вопрос, вот только адресовал ты его не туда. Лучше задать его разрабам
Изображение

Аватара пользователя

Автор темы
Dja
Сообщения: 5946
Зарегистрирован: 27 авг 2016, 17:03
Решено: 26
Откуда: Voskresensk
Благодарил (а): 860 раз
Поблагодарили: 625 раз

IPSec L2TP client Linux Mint 18 18.1

Сообщение Dja » 27 сен 2018, 18:50

Я думаю это скорее проблема linux вцелом, о чем и говорил taoist. Должны уживаться хоть 2 хоть 4 версии либ. И потом... если софт требует ту или иную либу он должен сам ее подтягивать и ставить. И уж как минимум он должен поддерживать работу и со старой либой если вдруг у кого нет новой.

Аватара пользователя

Автор темы
Dja
Сообщения: 5946
Зарегистрирован: 27 авг 2016, 17:03
Решено: 26
Откуда: Voskresensk
Благодарил (а): 860 раз
Поблагодарили: 625 раз

IPSec L2TP client Linux Mint 18 18.1

Сообщение Dja » 27 сен 2018, 20:20

darkfenix писал(а):
27 сен 2018, 15:47
1.8.0
Дал ему 1.8.10
Не хочет.
18-09-27-231858.png
Смена в official-package-repositories.list Сильвии на Тару тоже ничего не дало. Хотя вроде казалось бы должны же быть новые версии пакетов. Ан нет...
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя

Автор темы
Dja
Сообщения: 5946
Зарегистрирован: 27 авг 2016, 17:03
Решено: 26
Откуда: Voskresensk
Благодарил (а): 860 раз
Поблагодарили: 625 раз

IPSec L2TP client Linux Mint 18 18.1

Сообщение Dja » 27 сен 2018, 20:41

Вобщем

Код: Выделить всё

sudo add-apt-repository ppa:nm-l2tp/network-manager-l2tp 
sudo apt update
sudo apt install network-manager-l2tp
sudo apt install network-manager-l2tp-gnome
И вроде как появляется на ходу без переустановки нетворк-манагера.
Источник

Аватара пользователя

Автор темы
Dja
Сообщения: 5946
Зарегистрирован: 27 авг 2016, 17:03
Решено: 26
Откуда: Voskresensk
Благодарил (а): 860 раз
Поблагодарили: 625 раз

IPSec L2TP client Linux Mint 19*

Сообщение Dja » 19 июл 2019, 18:29

Работу в 19.2 beta подтверждаю. (xfce x64). Пакеты, выкинутые ментейнерами из предустановленных добавил в первый пункт IPSec L2TP client Linux Mint 18 18.1 (Пост Dja #9377)

Вернуться в «Работа с сетью»