Баг при использовании HDMI

Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
Аватара пользователя

Автор темы
Дмитрий
Сообщения: 142
Зарегистрирован: 02 дек 2016, 13:42
Решено: 1
Откуда: Россия
Благодарил (а): 9 раз
Поблагодарили: 12 раз

Баг при использовании HDMI

Сообщение Дмитрий » 01 июл 2019, 20:47

Linux Mint 19.1 Cinnamon

Столкнулся с не очень проблемным но всё равно неприятным багом. На выходных бук подключал к телевизору, фильм смотрели, в настройках звука устройством вывода выбрал HDMI, потом я как обычно отключил от телика (сдёрнул со шнурка) и выключил. Сегодня вечером заметил что бук не воспроизводит звуки, покрутил громкость - хрен вам, полез в настройки, в перечне устройств вывода только встроенные динамики... и оно и выделено... ни какие настройки, проверки звука и перезагрузки ничего не изменили... пришлось снова подключить к телевизору и при наличие 2 устройств выбрать встроенные динамики...

Я много лет пользуюсь Минт (Корица), раньше такого бага небыло :sad:

Кто ни будь с этим сталкивался?

Аватара пользователя

WWolf
Сообщения: 2183
Зарегистрирован: 13 фев 2018, 21:51
Решено: 11
Откуда: Краснодар
Благодарил (а): 731 раз
Поблагодарили: 556 раз

Баг при использовании HDMI

Сообщение WWolf » 01 июл 2019, 20:58

Дмитрий, на 18.3 такое впоймал, только подключение к телику и выбору не помогало... чё только блин не делал, инструкций штук 10 перебровал, откатился на бэкап и всё завелось...

Аватара пользователя

Автор темы
Дмитрий
Сообщения: 142
Зарегистрирован: 02 дек 2016, 13:42
Решено: 1
Откуда: Россия
Благодарил (а): 9 раз
Поблагодарили: 12 раз

Баг при использовании HDMI

Сообщение Дмитрий » 01 июл 2019, 21:06

Я не так что бы часто, но подключаюсь периодически к телевизору и никогда ничего подобного не было (включая все предыдущие дистрибутивы). А тут как то так, не радостно.

Аватара пользователя

WWolf
Сообщения: 2183
Зарегистрирован: 13 фев 2018, 21:51
Решено: 11
Откуда: Краснодар
Благодарил (а): 731 раз
Поблагодарили: 556 раз

Баг при использовании HDMI

Сообщение WWolf » 01 июл 2019, 21:07

Дмитрий, сам прифигел :) три раза нормально подключался, а на четвёртый такой казус впоймал :)

Аватара пользователя

Ара Магеддон
Сообщения: 474
Зарегистрирован: 07 дек 2018, 22:08
Решено: 17
Благодарил (а): 22 раза
Поблагодарили: 110 раз

Баг при использовании HDMI

Сообщение Ара Магеддон » 01 июл 2019, 21:12

Поговаривают, где-то в недрах RedHat пилят ещё одну систему, которая будет и звуком, и видеопотоками управлять. Вот теперь думаю, или она действительно alsa/pulseaudio заменит, или придется все три хрени между собой взаимоувязывать. :)

По теме: рискну осторожно предположить, что ситуацию можно исправить следующими командами
1. pacmd list-cards - покажет информацию о звуковых картах
2. Что-то вроде pactl set-card-profile 1 output:analog-stereo+input:analog-stereo - устанавливает ввод-вывод для карты с индексом "1". Индекс берется из предыдущей команды (он может быть и ноль), список доступных профилей - тоже.

Вернуться в «Cinnamon»