Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Не знаете как установить драйвер? Возникли проблемы? Вам сюда!
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
В сети
Аватара пользователя

Автор темы
Chocobo
Сообщения: 9148
Зарегистрирован: 27 авг 2016, 19:57
Решено: 198
Откуда: НН
Благодарил (а): 637 раз
Поблагодарили: 2614 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение Chocobo » 07 июл 2018, 15:12

Ну я тоже не знаю как ты откатывал там)
Пакеты вынести, холд снять, иксы апгрейдить, конфиги подчистить, блеклисты убрать.
проверить наличие модуля fglrx (fglrx_pci) после перезагрузки
Изображение
   
Изображение


imv9
Сообщения: 28
Зарегистрирован: 18 июл 2017, 18:11
Решено: 3
Благодарил (а): 27 раз
Поблагодарили: 1 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение imv9 » 08 июл 2018, 13:36

Chocobo, откатился):
1.Снял hold: sudo apt unhold xserver-xorg-core xserver-common fglrx-core
2.Вынес пакеты: sudo apt remove --purge fglrx\*
3.Подчистил конфиги: etc/x11/xorg.conf
4.Обновил Х: sudo apt dist-upgrade
5.Обновил grub: /etc/default/grub привел строку в первоначальный вид GRUB_CMDLINE_LINUX_DEFAULT=""
sudo update-grub
Спасибо! :thumbs:

Аватара пользователя

epsicore
Сообщения: 11
Зарегистрирован: 03 фев 2018, 06:23
Благодарил (а): 10 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение epsicore » 12 окт 2018, 16:11

Планируете ли вы отредактировать эту же установку под Linux Mint 19.X?
Я рад был бы рискнуть, если бы ядро совпадало.

И насколько помню, яркость не регулировалась при установленном драйвере (Через клавишу на ноутбуке [Fn+*стрелка вправо/влево]). Как можно это в дальнейшем исправить у себя?

В сети
Аватара пользователя

Автор темы
Chocobo
Сообщения: 9148
Зарегистрирован: 27 авг 2016, 19:57
Решено: 198
Откуда: НН
Благодарил (а): 637 раз
Поблагодарили: 2614 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение Chocobo » 12 окт 2018, 16:30

epsicore, В 19-й минт уже не притащить без кучи проблем Xorg 1.17, поэтому и драйвера не будет. Да и нет особо смыла продолжать, как минимум по трем причинам.
   
  • На старых иксах печально работает некоторый новый софт
  • Девайсы до GCN все же можно использовать с каталистом и в 18.3 согласно этому посту на LTS-ядрах, благо срок жизни дистрибутива еще норм, до 21 года
  • для девайсов с GCN (7700/R2 и выше) - доступен и развивается свободный amdgpu в составе ядра, который уже показывает схожую производительность и лишен основных недостатков легаси-драйвера
Изображение
   
Изображение

Аватара пользователя

epsicore
Сообщения: 11
Зарегистрирован: 03 фев 2018, 06:23
Благодарил (а): 10 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение epsicore » 14 окт 2018, 04:01

Ок, всё верно, в составе ядра стоял. А что делать с вертикальной синхронизацией?
Ограничение на 60 fps стоит.
Есть ли где форум может?

В сети
Аватара пользователя

Автор темы
Chocobo
Сообщения: 9148
Зарегистрирован: 27 авг 2016, 19:57
Решено: 198
Откуда: НН
Благодарил (а): 637 раз
Поблагодарили: 2614 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение Chocobo » 14 окт 2018, 07:10

epsicore, попробуй вызвать с переменной vblank_mode=0, оно должно на уровне месы управляться вроде.
Изображение
   
Изображение


wms
Сообщения: 1
Зарегистрирован: 30 окт 2018, 23:27

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение wms » 30 окт 2018, 23:40

всем привет.

Запускается установщик АТI выбираю установку драйвера все идет хорошо - но потом вылазит вот такое сообщение:

Supported adapter detected.
Check if system has the tools required for installation.
fglrx installation requires that the system have kernel headers. /lib/modules/4.10.0-38-generic/build/include/linux/version.h cannot be found on this system.
One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
Optionally, run the installer with --force option to install without the tools.
Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.

______________________
Processor 2x Intel(R) Pentium(R) CPU P6100 @ 2.00GHz
Memory 7966MB (1702MB used)
Operating System Linux Mint 18.3 Sylvia
Kernel Linux 4.10.0-38-generic (x86_64)
Compiled #42~16.04.1-Ubuntu SMP Tue Oct 10 16:32:20 UTC 2017
C Library Unknown
Default C Compiler GNU C Compiler version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.10)
Distribution Linux Mint 18.3 Sylvia
VGA compatible controller Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470] (prog-if 00 [VGA controller])
Драйвер с сайта четко на мою модель видеокарты:
AMD-Catalyst-15.9-Linux-installer-15.201.1151-x86.x86_64
________________________________

есть подозрение, что производитель драйвера не поддерживает эту версию ядра...что посоветуете ?
Заранее благодарен за ответы

В сети
Аватара пользователя

Автор темы
Chocobo
Сообщения: 9148
Зарегистрирован: 27 авг 2016, 19:57
Решено: 198
Откуда: НН
Благодарил (а): 637 раз
Поблагодарили: 2614 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение Chocobo » 31 окт 2018, 06:50

wms писал(а):
30 окт 2018, 23:40
что посоветуете ?
  • использовать LM17.3 или LMDE2, где драйвер еще официально был жив, функционирует и ставится в пару кликов
  • для 18.Х - вдумчиво перечитать первое сообщение этой темы
  • для всего остального - есть дефолтный открытый radeon
Изображение
   
Изображение


russian user
Сообщения: 7
Зарегистрирован: 04 ноя 2018, 06:28
Благодарил (а): 1 раз
Поблагодарили: 1 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение russian user » 04 ноя 2018, 06:34

Привет всем! Система - Linux Mint 18.3 MATE, версия ядра 4.10.38. Делал все по инструкции из шапки, как итог - система не грузится вообще. Куда копать?


В сети
Аватара пользователя

darkfenix
Сообщения: 5203
Зарегистрирован: 27 июн 2017, 10:36
Решено: 61
Откуда: Нижний Тагил
Благодарил (а): 289 раз
Поблагодарили: 961 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение darkfenix » 04 ноя 2018, 06:52

russian user писал(а):
04 ноя 2018, 06:34
Куда копать?
Вниз
Изображение


russian user
Сообщения: 7
Зарегистрирован: 04 ноя 2018, 06:28
Благодарил (а): 1 раз
Поблагодарили: 1 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение russian user » 04 ноя 2018, 07:56

darkfenix писал(а):
04 ноя 2018, 06:52
Вниз
Типичный ответ доморощенного "линуксоида". Не, если вам всем нравится покупать железку и потом дрочить, выгадывая проценты якобы производительности, вместо работы - я не против.
P.S. Благодаря таким "ответам" вы так и будете теми жалкими несколькими процентами "илиты", которая вовсю материт "винду", но пытается установить .exe в свое поделие с названием "Линукс"..

В сети
Аватара пользователя

darkfenix
Сообщения: 5203
Зарегистрирован: 27 июн 2017, 10:36
Решено: 61
Откуда: Нижний Тагил
Благодарил (а): 289 раз
Поблагодарили: 961 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение darkfenix » 04 ноя 2018, 08:53

russian user, каков вопрос - таков ответ. Научишься задавать вопросы - глядишь начнешь получать на них ответы. А пока только так. Для тех кто в танке - вверху страницы есть красное поле, почитай и подумай.
Изображение

В сети
Аватара пользователя

Автор темы
Chocobo
Сообщения: 9148
Зарегистрирован: 27 авг 2016, 19:57
Решено: 198
Откуда: НН
Благодарил (а): 637 раз
Поблагодарили: 2614 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение Chocobo » 04 ноя 2018, 10:54

russian user, вот буквально в предыдущем сообщении писал
Chocobo писал(а):
31 окт 2018, 06:50
для 18.Х - вдумчиво перечитать первое сообщение этой темы
где там речь про 4.10?
Изображение
   
Изображение


russian user
Сообщения: 7
Зарегистрирован: 04 ноя 2018, 06:28
Благодарил (а): 1 раз
Поблагодарили: 1 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение russian user » 04 ноя 2018, 12:26

darkfenix писал(а):
04 ноя 2018, 08:53
каков вопрос - таков ответ. Научишься задавать вопросы - глядишь начнешь получать на них ответы. А пока только так. Для тех кто в танке - вверху страницы есть красное поле, почитай и подумай.
Если бы ты был внимательней, то прочитал бы, что
russian user писал(а):
04 ноя 2018, 06:34
система не грузится вообще
. Как, например, я могу предоставить данные о системе из консоли? Или главное - показать свою "элитарность"?
Chocobo писал(а):
04 ноя 2018, 10:54
где там речь про 4.10?
А это что?
Chocobo писал(а):
21 ноя 2016, 09:33
для 4.10
Качаем и устанавливаем следующие 4 пакета:
repo/sonya/4.10/fglrx-amdcccle_15.302-0 ... _amd64.deb
repo/sonya/4.10/fglrx-core_15.302-0ubuntu1_amd64.deb
repo/sonya/4.10/fglrx-dev_15.302-0ubuntu1_amd64.deb
repo/sonya/4.10/fglrx_15.302-0ubuntu1_amd64.deb

В сети
Аватара пользователя

Автор темы
Chocobo
Сообщения: 9148
Зарегистрирован: 27 авг 2016, 19:57
Решено: 198
Откуда: НН
Благодарил (а): 637 раз
Поблагодарили: 2614 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение Chocobo » 04 ноя 2018, 13:48

russian user, оно в EOL еще с мая 2017. Возьми одно из актуальных. 4.9.135 например

И что за видеоадаптер кстати?

По самой неудачной загрузке, можно-
  • т.к. по тексту облом выглядит на этапе дисплей менеджера - попробовать прыгнуть в tty2 (ctrl-alt-f2), возможно текстовый режим будет доступен
  • или заблеклистить модуль каталиста в grub - параметр modprobe.blacklist=fglrx
  • или чрут в корень установленной системы с LiveCD для отката пакетов
Изображение
   
Изображение


russian user
Сообщения: 7
Зарегистрирован: 04 ноя 2018, 06:28
Благодарил (а): 1 раз
Поблагодарили: 1 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение russian user » 04 ноя 2018, 14:09

Chocobo писал(а):
04 ноя 2018, 13:48
оно в EOL еще с мая 2017. Возьми одно из актуальных. 4.9.135 например
Linux Mint 18.3 x64 MATE предлагается к загрузке (и устанавливается) именно с ядром 4.10.38. Получается, что для нормальной работы драйверов его нужно даунгрейдить?
Chocobo писал(а):
04 ноя 2018, 13:48
И что за видеоадаптер кстати?
Sapphire Radeon HD 7850

В сети
Аватара пользователя

Автор темы
Chocobo
Сообщения: 9148
Зарегистрирован: 27 авг 2016, 19:57
Решено: 198
Откуда: НН
Благодарил (а): 637 раз
Поблагодарили: 2614 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение Chocobo » 04 ноя 2018, 16:09

russian user, Каталист амд перестали разрабатывать еще в конце 2015 года. и официально он поддерживает ядра до 4.1 и Xorg до 17-й версии.
Поэтому его и в репозиториях 18.Х уже не стало.

А тебе на 7850 (это Pitcairn) на сегодня лучше и проще задействовать amdgpu, на ядрышках посвежей (модуль появился в 4.9+ но активно разрабатывается и норм продвинулся под 4.14+).
Видеодрайвер amdgpu для AMD Southern Islands (GCN 1.0)

modprobe.blacklist=radeon radeon.si_support=0 amdgpu.si_support=1
Изображение
   
Изображение


russian user
Сообщения: 7
Зарегистрирован: 04 ноя 2018, 06:28
Благодарил (а): 1 раз
Поблагодарили: 1 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение russian user » 06 ноя 2018, 14:43

Chocobo писал(а):
04 ноя 2018, 16:09
А тебе на 7850 (это Pitcairn) на сегодня лучше и проще задействовать amdgpu, на ядрышках посвежей (модуль появился в 4.9+ но активно разрабатывается и норм продвинулся под 4.14+)
Установил Linux Mint 17.3 MATE, получилось установить ATI Drivers, загрузил WINE, скачал портированные Mafia и Call of Duty 2. Первая запустилась и даже нормально играется. Вторая игра - звук идет, а картинка на весь экран из загрузочного меню и играть невозможно в принципе. Скачал Ubuntu 14.04.5 (на коей Linux Mint 17.3 и основан), но она сыпет ошибками после установки, а потом вообще отказалась загружаться.
Итог - остаюсь на Windows. Всем спасибо за советы, но пытаться запустить файлы из одной ОС в другой и при этом материть Windows считаю извращением.

В сети
Аватара пользователя

darkfenix
Сообщения: 5203
Зарегистрирован: 27 июн 2017, 10:36
Решено: 61
Откуда: Нижний Тагил
Благодарил (а): 289 раз
Поблагодарили: 961 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение darkfenix » 06 ноя 2018, 14:52

russian user, удачи :hshake:
Изображение


russian user
Сообщения: 7
Зарегистрирован: 04 ноя 2018, 06:28
Благодарил (а): 1 раз
Поблагодарили: 1 раз

Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X

Сообщение russian user » 06 ноя 2018, 17:03

russian user писал(а):
06 ноя 2018, 14:43
Chocobo писал(а):
04 ноя 2018, 16:09
А тебе на 7850 (это Pitcairn) на сегодня лучше и проще задействовать amdgpu, на ядрышках посвежей (модуль появился в 4.9+ но активно разрабатывается и норм продвинулся под 4.14+)
Можно сказать, что "Linux - не для развлечений", но я предпочитаю (как и многие) использовать устройство. Я - обычный пользователь и не собираюсь решать ошибки производителя через замену ядер и компиляцию исходников. Можно даже сказать, что "Linux - это opensource и это круто", но вы же скачиваете музыку и торренты, не платя при этом не копейки. Тогда о какой свободе идет речь?

Вернуться в «Видеокарты»