деинсталировать php apt-get

Руководства, вопросы, обсуждения
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
Аватара пользователя

Imperio
Сообщения: 162
Зарегистрирован: 06 фев 2018, 09:32
Решено: 2
Откуда: Ярославль
Благодарил (а): 36 раз
Поблагодарили: 27 раз

деинсталировать php apt-get

Сообщение Imperio » 03 апр 2018, 21:26

Владислав, про sudo давай в отдельной теме, а пока перечитай 31 и 32 сообщения. И покажи выхлоп apt policy php

Аватара пользователя

darkfenix
Сообщения: 4607
Зарегистрирован: 27 июн 2017, 10:36
Решено: 52
Откуда: Нижний Тагил
Благодарил (а): 272 раза
Поблагодарили: 872 раза

деинсталировать php apt-get

Сообщение darkfenix » 04 апр 2018, 03:00

Владислав писал(а):
03 апр 2018, 21:21
использовать sudo
Следует использовать только в том случае когда необходимы повышенные права.
Imperio писал(а):
03 апр 2018, 21:26
И покажи выхлоп apt policy php
Ничего интересного не увидишь. У него в репах полный хаос.
Владислав, покажи вывод inxi -Fxz
Изображение

Аватара пользователя

Dja
Сообщения: 5465
Зарегистрирован: 27 авг 2016, 17:03
Решено: 22
Откуда: Voskresensk
Благодарил (а): 760 раз
Поблагодарили: 590 раз

деинсталировать php apt-get

Сообщение Dja » 04 апр 2018, 06:23

Владислав писал(а):
03 апр 2018, 17:35
darkfenix,

Код: Выделить всё

sudo apt purge php*
[sudo] password for supersalad: 
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
E: Не удалось найти пакет php
а должно быть примерно так

Аватара пользователя

Imperio
Сообщения: 162
Зарегистрирован: 06 фев 2018, 09:32
Решено: 2
Откуда: Ярославль
Благодарил (а): 36 раз
Поблагодарили: 27 раз

деинсталировать php apt-get

Сообщение Imperio » 04 апр 2018, 13:33

darkfenix писал(а):
04 апр 2018, 03:00
Ничего интересного не увидишь. У него в репах полный хаос.
По выхлопу других команд я это уже понял. Не понял только в чем он заключается и как он этого добился. Сами репы соответствуют его дистру 17.1.
darkfenix писал(а):
04 апр 2018, 03:00
покажи вывод inxi -Fxz
А чем он в данном случае поможет, куда смотреть? Там же про железо в основном, а у него проблема с софтом.

Аватара пользователя

darkfenix
Сообщения: 4607
Зарегистрирован: 27 июн 2017, 10:36
Решено: 52
Откуда: Нижний Тагил
Благодарил (а): 272 раза
Поблагодарили: 872 раза

деинсталировать php apt-get

Сообщение darkfenix » 04 апр 2018, 16:03

Imperio писал(а):
04 апр 2018, 13:33
А чем он в данном случае поможет
Поможет убедиться в
Imperio писал(а):
04 апр 2018, 13:33
репы соответствуют его дистру 17.1
потому как ТС не обмолвился об этом ни словом, а хрустальный шар у меня кот куда-то закатил :-D
Imperio писал(а):
04 апр 2018, 13:33
как он этого добился
Об этом знает только он.
Изображение


Автор темы
Владислав
Сообщения: 205
Зарегистрирован: 04 ноя 2017, 13:33
Благодарил (а): 8 раз

деинсталировать php apt-get

Сообщение Владислав » 04 апр 2018, 18:19

darkfenix,

Код: Выделить всё

  System:    Host: supersalad-EasyNote-LM85 Kernel: 3.13.0-37-generic x86_64 (64 bit, gcc: 4.8.2) 
           Desktop: N/A Distro: Linux Mint 17.1 Rebecca
Machine:   System: Packard Bell (portable) product: EasyNote LM85 version: V1.12
           Mobo: Packard Bell model: EasyNote LM85 version: V1.12 Bios: Phoenix version: V1.12 date: 06/21/2010
CPU:       Dual core Intel Core i5 CPU M 460 (-HT-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10108.2 
           Clock Speeds: 1: 1199.00 MHz 2: 1199.00 MHz 3: 1199.00 MHz 4: 1199.00 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Madison [Mobility Radeon HD 5650/5750 / 6530M/6550M] bus-ID: 02:00.0 
           X.org: 1.15.1 drivers: ati,radeon (unloaded: fbdev,vesa) tty size: 80x24 Advanced Data: N/A for root 
Audio:     Card-1: Intel 5 Series/3400 Series Chipset High Definition Audio driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2: Advanced Micro Devices [AMD/ATI] Redwood HDMI Audio [Radeon HD 5000 Series] driver: snd_hda_intel bus-ID: 02:00.1
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-37-generic
Network:   Card-1: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) driver: ath9k bus-ID: 05:00.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Broadcom NetLink BCM57780 Gigabit Ethernet PCIe driver: tg3 ver: 3.134 bus-ID: 03:00.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 320.1GB (10.3% used) 1: id: /dev/sda model: WDC_WD3200BEKX size: 320.1GB 
Partition: ID: / size: 148G used: 31G (22%) fs: ext4 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 58.0C mobo: 50.0C gpu: 62.0 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 192 Uptime: 3:27 Memory: 1752.6/3816.1MB Runlevel: 2 Gcc sys: 4.8.4 Client: Shell inxi: 1.8.4 
  


Автор темы
Владислав
Сообщения: 205
Зарегистрирован: 04 ноя 2017, 13:33
Благодарил (а): 8 раз

деинсталировать php apt-get

Сообщение Владислав » 04 апр 2018, 18:21

Imperio, ответа на команду нет.

Аватара пользователя

darkfenix
Сообщения: 4607
Зарегистрирован: 27 июн 2017, 10:36
Решено: 52
Откуда: Нижний Тагил
Благодарил (а): 272 раза
Поблагодарили: 872 раза

деинсталировать php apt-get

Сообщение darkfenix » 04 апр 2018, 18:34

Владислав писал(а):
02 апр 2018, 19:51
локально файлы запускаются
Все очень странно.
Сделай sudo apt install pastebinit, затем php -r 'phpinfo();' | pastebinit. Ссылку, которую он тебе вернет - скопируй и вставь сюда
Изображение


Автор темы
Владислав
Сообщения: 205
Зарегистрирован: 04 ноя 2017, 13:33
Благодарил (а): 8 раз

деинсталировать php apt-get

Сообщение Владислав » 05 апр 2018, 21:17

darkfenix,

Код: Выделить всё

sudo php -r 'phpinfo();' | pastebinit
Bad API request, invalid api_dev_key
supersalad@supersalad-EasyNote-LM85 ~ $ 

Аватара пользователя

Dja
Сообщения: 5465
Зарегистрирован: 27 авг 2016, 17:03
Решено: 22
Откуда: Voskresensk
Благодарил (а): 760 раз
Поблагодарили: 590 раз

деинсталировать php apt-get

Сообщение Dja » 06 апр 2018, 05:53

Владислав, про sudo вам не говорили

Код: Выделить всё

$ php -r 'phpinfo();' | pastebinit
https://pastebin.com/aey1AsW0


Автор темы
Владислав
Сообщения: 205
Зарегистрирован: 04 ноя 2017, 13:33
Благодарил (а): 8 раз

деинсталировать php apt-get

Сообщение Владислав » 06 апр 2018, 15:11

Dja, darkfenix,

Код: Выделить всё

Bad API request, invalid api_dev_key
я и с судо и без судо смотрел.

Аватара пользователя

Dja
Сообщения: 5465
Зарегистрирован: 27 авг 2016, 17:03
Решено: 22
Откуда: Voskresensk
Благодарил (а): 760 раз
Поблагодарили: 590 раз

деинсталировать php apt-get

Сообщение Dja » 06 апр 2018, 22:34

darkfenix писал(а):
04 апр 2018, 18:34
Все очень странно
Согласен... и DE у него нет...

Вернуться в «Параметры и оптимизация»