SDA ошибка с установкой(не понятность что делать!)

Вопросы настройки, запуска любых Windows-программ, кроме игр
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

Автор темы
lowbo
Сообщения: 33
Зарегистрирован: 29 мар 2018, 08:43
Благодарил (а): 2 раза

SDA ошибка с установкой(не понятность что делать!)

Сообщение lowbo » 29 мар 2018, 11:45

1 Linux Mint 18.3
4. Делал все как в этой статье до тех пор (https://github.com/Jessecar96/SteamDesk ... g-on-linux), пока не дошел до отркытия файла Steam Desktop Authenticator.sln
. Помогите закончить установку SDA.
5.
(1)(2) Установка SDA
(3) Mono
(4)(5)Работа в Mono
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя

Chocobo
Сообщения: 9170
Зарегистрирован: 27 авг 2016, 19:57
Решено: 198
Откуда: НН
Благодарил (а): 639 раз
Поблагодарили: 2624 раза

SDA ошибка с установкой(не понятность что делать!)

Сообщение Chocobo » 29 мар 2018, 12:07

lowbo писал(а):
29 мар 2018, 11:45
Делал все как в этой статье
Не совсем :) прям с первых строк
"Clicking "Download ZIP" will not work! This project uses git submodules so you must use git to download it properly."
Поэтому выкачивать его надо через git
1. apt install git
2. mkdir ~/git; cd ~/git
2. git clone --recurse-submodules https://github.com/Jessecar96/SteamDesktopAuthenticator.git
и уже монодевелопу указывать путь из директории гит в твоей домашней дире. Тогда проект откроется без ошибок.
Снимок экрана в 2018-03-29 15-07-06.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Изображение
   
Изображение

Аватара пользователя

Chocobo
Сообщения: 9170
Зарегистрирован: 27 авг 2016, 19:57
Решено: 198
Откуда: НН
Благодарил (а): 639 раз
Поблагодарили: 2624 раза

SDA ошибка с установкой(не понятность что делать!)

Сообщение Chocobo » 29 мар 2018, 12:20

И есть там еще какая-то тонкость видимо, по версиям компонентов monodevelop. Нужно обновление некого nuget client
Снимок экрана в 2018-03-29 15-18-52.png
Но я пока хз, как оно работает, погляжу
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Изображение
   
Изображение


Автор темы
lowbo
Сообщения: 33
Зарегистрирован: 29 мар 2018, 08:43
Благодарил (а): 2 раза

SDA ошибка с установкой(не понятность что делать!)

Сообщение lowbo » 29 мар 2018, 12:46

Снимок экрана от 2018-03-29 19-37-05.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя

Chocobo
Сообщения: 9170
Зарегистрирован: 27 авг 2016, 19:57
Решено: 198
Откуда: НН
Благодарил (а): 639 раз
Поблагодарили: 2624 раза

SDA ошибка с установкой(не понятность что делать!)

Сообщение Chocobo » 29 мар 2018, 12:51

lowbo, Ну эти ошибки парсинга из-за неактуальных json'ов как раз.
Сейчас если у меня сбилдится и стартует - то покажу рецепт.
По сути просто в монодевелоп тухлый в репозиториях 16.04
Изображение
   
Изображение

Аватара пользователя

Chocobo
Сообщения: 9170
Зарегистрирован: 27 авг 2016, 19:57
Решено: 198
Откуда: НН
Благодарил (а): 639 раз
Поблагодарили: 2624 раза

SDA ошибка с установкой(не понятность что делать!)

Сообщение Chocobo » 29 мар 2018, 13:13

фиг знает, в общем - может и работает :hoho:
Бинарник сбилдился без ошибок в 7-й версии monodevelop

офсайт проекта предлагает установить с флетпака
Установка - flatpak install --user --from https://download.mono-project.com/repo/monodevelop.flatpakref
Запуск - flatpak run com.xamarin.MonoDevelop
Снимок экрана в 2018-03-29 15-46-02.png
Дальше билдится все по инструкции, заканчивается с одним ворнингом.
Снимок экрана в 2018-03-29 15-51-57.png
При попытке старта - первый-третий пункт куда-то ведут, второй вылетает сразу. На своем аккаунте подобные штуки проверять не буду :crazy:


И получившиеся готовые мои бинарники, что на записи выше - на всякий случай - https://cloud.mail.ru/public/EsgC/nQj6TsSxk
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Изображение
   
Изображение


Автор темы
lowbo
Сообщения: 33
Зарегистрирован: 29 мар 2018, 08:43
Благодарил (а): 2 раза

SDA ошибка с установкой(не понятность что делать!)

Сообщение lowbo » 29 мар 2018, 13:31

..
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Вернуться в «Wine»