VirualBox и ядро 4.14

Языки программирования, IDE, компиляторы, интерпретаторы, гипервизоры и виртуальные среды
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
Аватара пользователя

Автор темы
rogoznik
Сообщения: 6124
Зарегистрирован: 27 июн 2017, 10:36
Решено: 69
Откуда: Нижний Тагил
Благодарил (а): 326 раз
Поблагодарили: 1114 раз

VirualBox и ядро 4.14

Сообщение rogoznik » 06 фев 2018, 03:39

Тут товарищ сокрушался что у него не завелся VirtualBox 5.2 на ядре 4.14.
Dinamic21 писал(а):
05 фев 2018, 17:11
Требуется более новый VB версии выше 5.2, но и он у меня не взлетел, дальше копать не было времени.
А ведь зря что не стал копать.
Сообщение об ошибке было примерно таким (картинка из интернета)
Kernel-driver-not-installed-ubuntu.jpg
Если запустить в терминале то что просит бокса - увидим что она хочет библиотеку libelf. Идем в Synaptic находим, устанавливаем. Снова запускаем что предлагала бокса, но она все равно просит эту библиотеку. Странно, но мы не отчаиваемся и предполагаем что хочет она более новую версию нежели имеется у нас в репах (Chocobo писал об этом тут Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X (Пост Chocobo #39650), хотя нам GCC7 не нужен это верное направление).
Идем теперь уже в шапку, упомянутой выше, темы Установка видеодрайвера AMD Сatalyst (fglrx) в Linux Mint 18.X (Пост Chocobo #4975) и качаем оттуда пакеты libelf для ядра 4.14. Устанавливаем их любым удобным способом. И снова запускаем что просила бокса. И вуаля :magic: модули для ядра собрались и бокса работает.
У вас нет необходимых прав для просмотра вложений в этом сообщении.
ИзображениеИзображение

Аватара пользователя

Dinamic21
Сообщения: 18
Зарегистрирован: 02 фев 2018, 06:46
Поблагодарили: 1 раз

VirualBox и ядро 4.14

Сообщение Dinamic21 » 12 фев 2018, 11:18

darkfenix, к счастью данной ошибки у меня не возникало. Бокс просто намертво вешал систему при попытке запуска любой виртуальной машины. Недуг прошел после установки ядра 4.15 + бокс 5.2.6.
Подозреваю,что проблема зарыта в процессорах Intel, в моем случае i7 4770.
Аналогичная система на амуде с ядром 4.14 и впиленным туда каталистом проблем не доставила, бокс без проблем работал из стандартных реп.

Вернуться в «Программирование, скриптинг, виртуализация»