Удаление программ

Вы не знаете в какой раздел задать вопрос? Ищите ответы на популярные вопросы? Тогда вам сюда!
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
Аватара пользователя

Dja
Сообщения: 6206
Зарегистрирован: 27 авг 2016, 17:03
Решено: 27
Откуда: Voskresensk
Благодарил (а): 918 раз
Поблагодарили: 657 раз

Удаление программ

Сообщение Dja » 26 мар 2019, 08:22

Слайдовая смена обоев доступна через настройки как на одном так и на другом мониторе. Ничего дополнительно ставить не нужно )
Имхо обои видно только при запуске компа ) Остальное время они закрыты окнами программ, поэтому смысла так заморачиваться не вижу.

Аватара пользователя

Anatoli Bagrov
Сообщения: 7
Зарегистрирован: 25 мар 2019, 20:36
Благодарил (а): 7 раз

Удаление программ

Сообщение Anatoli Bagrov » 26 мар 2019, 17:45

darkfenix писал(а):
26 мар 2019, 03:10
Anatoli Bagrov писал(а):
25 мар 2019, 21:31
Я подключил второй монитор и озадачился настройкой обоев для него. Нашел статью
В XFCE это же из коробки работает. На каждом мониторе ПКМ по рабочему столу и выбираешь обоину.
Да, позже разобрался. Ещё в окне настроек обоев менялась директория обоев в зависимости от того на какой монитор перетаскивается это самое окно. В общем, изначальная задача, которая не по теме ветки, тоже решилась.

Аватара пользователя

colonel
Сообщения: 1494
Зарегистрирован: 18 дек 2016, 09:08
Решено: 18
Благодарил (а): 37 раз
Поблагодарили: 405 раз

Удаление программ

Сообщение colonel » 01 апр 2019, 09:25

vir0id писал(а):
26 мар 2019, 03:08
В этом разница
разница не принципиальная и не влияет на то куда в систему будут установлены потроха пакетов скачанных с оффсайта. Ну вроде бы для установки командом sudo dpkg -i *.deb в каталог где эта команда запускается требуется скачивание\наличие всех необходимых пакетов. Да и gdebi-gtk может вдруг не найти пакеты по зависимостям.
"Не ты выбираешь Linux, а Linux выбирает тебя"
(с)Себастьян Перейра, торговец чёрным деревом

Аватара пользователя

Dja
Сообщения: 6206
Зарегистрирован: 27 авг 2016, 17:03
Решено: 27
Откуда: Voskresensk
Благодарил (а): 918 раз
Поблагодарили: 657 раз

Удаление программ

Сообщение Dja » 01 апр 2019, 13:10

colonel писал(а):
01 апр 2019, 09:25
sudo dpkg -i *.deb
После этого может понадобиться

Код: Выделить всё

sudo apt install -f
(на всякий случай).

Аватара пользователя

colonel
Сообщения: 1494
Зарегистрирован: 18 дек 2016, 09:08
Решено: 18
Благодарил (а): 37 раз
Поблагодарили: 405 раз

Удаление программ

Сообщение colonel » 01 апр 2019, 14:30

Dja писал(а):
01 апр 2019, 13:10
...После этого может понадобиться
sudo apt install -f (на всякий случай).
да ну ... я же говорил о дебках скачанных с официальных реп при наличии всех необходимых пакетов в каталоге.
с какого ж там может понадобиться -f
"Не ты выбираешь Linux, а Linux выбирает тебя"
(с)Себастьян Перейра, торговец чёрным деревом

Аватара пользователя

Dja
Сообщения: 6206
Зарегистрирован: 27 авг 2016, 17:03
Решено: 27
Откуда: Voskresensk
Благодарил (а): 918 раз
Поблагодарили: 657 раз

Удаление программ

Сообщение Dja » 01 апр 2019, 14:33

colonel, помнится в 17-3 при установке viber из консоли оно нужно было. А вот если дабл-кликом, то нет.

Аватара пользователя

colonel
Сообщения: 1494
Зарегистрирован: 18 дек 2016, 09:08
Решено: 18
Благодарил (а): 37 раз
Поблагодарили: 405 раз

Удаление программ

Сообщение colonel » 01 апр 2019, 15:19

Dja писал(а):
01 апр 2019, 14:33
... помнится в 17-3 при установке viber из консоли оно нужно было. А вот если дабл-кликом, то нет.
а viber есть в оффрепах? и все пакеты были скачаны?
"Не ты выбираешь Linux, а Linux выбирает тебя"
(с)Себастьян Перейра, торговец чёрным деревом

Аватара пользователя

Dja
Сообщения: 6206
Зарегистрирован: 27 авг 2016, 17:03
Решено: 27
Откуда: Voskresensk
Благодарил (а): 918 раз
Поблагодарили: 657 раз

Удаление программ

Сообщение Dja » 01 апр 2019, 15:22

colonel, видимо мне не совсем понятен смысл оффреп. Вайбер - официальный софт. Есть сайт, там качается дебка. Если же речь "оффреп" идет о том, что есть в репозитории, то и смысла качать такую дебку нет. ибо

Код: Выделить всё

sudo apt install name
установит необходимый пакет без скачивания дебки.

Аватара пользователя

FreeStyler
Сообщения: 483
Зарегистрирован: 23 июл 2018, 04:58
Решено: 2
Откуда: Сиб
Благодарил (а): 519 раз
Поблагодарили: 63 раза

Удаление программ

Сообщение FreeStyler » 01 апр 2019, 15:26

colonel писал(а):
01 апр 2019, 09:25
sudo dpkg -i *.deb
новичкам, коих, задающих здесь вопросы, наверное 99%, лучше давать наименее опасные пути, команды, ну или тогда не забывать и `apt install -f` упомянуть и в чём опасность dpkg -i. Будто они все прям качают из оф. реп и знают что должно быть наличие всех необходимых пакетов в каталоге, ага -__- Это ж новички...
deadmau5 - Harmonic Mix
■ Mint 19.2 KDE (initial Xfce) @ Intel NUC Skull Canyon, i7-6770HQ, 16Gb RAM, 512Gb SSD M2, Iris Graphics 580
■ KDE Neon (Ubuntu 18.04) @ Lenovo V110 15ISK, i3-6006u, 8Gb RAM, 32GB SSD, 640GB HDD, HD Graphics 520

Аватара пользователя

vir0id
Сообщения: 2177
Зарегистрирован: 19 дек 2017, 15:48
Решено: 13
Откуда: Рига
Благодарил (а): 149 раз
Поблагодарили: 231 раз

Удаление программ

Сообщение vir0id » 01 апр 2019, 16:00

colonel писал(а):
01 апр 2019, 09:25
не влияет на то куда в систему будут установлены потроха пакетов
А от тебя это не зависит, если тебе не предложили путь. Они(пути) прописаны в гайдах пакета. Не о путях речь, а о разнице между установкой apt и dpkg.
colonel писал(а):
01 апр 2019, 09:25
Ну вроде бы для установки командой sudo dpkg -i *.deb в каталог где эта команда запускается требуется скачивание\наличие всех необходимых пакетов
Так я об это и говорю... Тебе требуется сделать второе действие. Чего не требует apt, при условии что зависимость есть в репозитории.

П.С: У меня ощущение, что мы говорим и понимаем одно и тоже. Только я сбоку, а ты спереди :-D

Аватара пользователя

vir0id
Сообщения: 2177
Зарегистрирован: 19 дек 2017, 15:48
Решено: 13
Откуда: Рига
Благодарил (а): 149 раз
Поблагодарили: 231 раз

Удаление программ

Сообщение vir0id » 01 апр 2019, 16:03

FreeStyler писал(а):
01 апр 2019, 15:26
apt install -f` упомянуть и в чём опасность dpkg -i
apt подтянет пакеты для dpkg, только и всего. Это фишка apt-a. В чём опасность dpkg, я чего-то не понял?

Аватара пользователя

colonel
Сообщения: 1494
Зарегистрирован: 18 дек 2016, 09:08
Решено: 18
Благодарил (а): 37 раз
Поблагодарили: 405 раз

Удаление программ

Сообщение colonel » 01 апр 2019, 17:10

vir0id писал(а):
01 апр 2019, 16:00
А от тебя это не зависит, ...
а я разве говорил что зависят от того каким инстументом ставят? сказано было что пакеты из офреп. будут ставиться в те же места хоть и командом в терминале хоть кликом по скачанным дебкам.
vir0id писал(а):
01 апр 2019, 16:00
Тебе требуется сделать второе действие.
ничего не говорил и не утверждал о количестве потребных действий. говорил о том что если в каталог скачены ВСЕ НЕОБХОДИМЫЕ пакеты из офреп то dpkg -i *.deb установит их ...
Dja писал(а):
01 апр 2019, 15:22
...видимо мне не совсем понятен смысл оффреп. ..
scrot.png
все остальные подключенные репозитории даже из официальных реп официальных сайтов программ не официальны установленной системе
FreeStyler писал(а):
01 апр 2019, 15:26
новичкам, коих, задающих здесь вопросы, наверное 99%, лучше давать наименее опасные пути, команды...
собсно нефиг новичкам подключать всякую шнягу и не незнакомую нешнягу в погоне за плюшками. Понаподключают через пень колоду хрен его знает чего, что из этого и через апт без -f не получится установить, если вообще установиться сможет
И как-то ни разу не понадобился apt install -f при установке командом sudo dpkg -i *.deb пакетов LO скачанных не из оф.реп минта\убунту, а к примеру с сайта LO (полный комплект пакетов LO из 3-х архивов обычно складываю в один каталог )
У вас нет необходимых прав для просмотра вложений в этом сообщении.
"Не ты выбираешь Linux, а Linux выбирает тебя"
(с)Себастьян Перейра, торговец чёрным деревом

Аватара пользователя

vir0id
Сообщения: 2177
Зарегистрирован: 19 дек 2017, 15:48
Решено: 13
Откуда: Рига
Благодарил (а): 149 раз
Поблагодарили: 231 раз

Удаление программ

Сообщение vir0id » 01 апр 2019, 17:25

colonel писал(а):
01 апр 2019, 17:10
говорил о том что если в каталог скачены ВСЕ НЕОБХОДИМЫЕ пакеты из офреп то dpkg -i *.deb установит их ...
Ну как бы должен, да. В таком случае разницы нет.

Аватара пользователя

FreeStyler
Сообщения: 483
Зарегистрирован: 23 июл 2018, 04:58
Решено: 2
Откуда: Сиб
Благодарил (а): 519 раз
Поблагодарили: 63 раза

Удаление программ

Сообщение FreeStyler » 01 апр 2019, 17:26

vir0id писал(а):
01 апр 2019, 16:03
apt подтянет пакеты для dpkg
Что это значит? -__-
Apt попробует починить, то что мог поломать dpkg.

Вот в чём опасность:
When dpkg install a package and package dependency is not satisfied, it leaves the package in unconfigured state and that package is considered as broken.
Ещё поподробнее.
Поэтому рекомендую использовать GDebi или QApt для установки. Да и сам ими пользуюсь. Через dpkg только LO устанавливал разок и то потому что у него было куча deb'ок, а мне не хотелось разбираться как их ставить по-другому. То ли они же предложили, то ли нагуглил `sudo dpkg -i *.deb`
deadmau5 - Harmonic Mix
■ Mint 19.2 KDE (initial Xfce) @ Intel NUC Skull Canyon, i7-6770HQ, 16Gb RAM, 512Gb SSD M2, Iris Graphics 580
■ KDE Neon (Ubuntu 18.04) @ Lenovo V110 15ISK, i3-6006u, 8Gb RAM, 32GB SSD, 640GB HDD, HD Graphics 520

Аватара пользователя

vir0id
Сообщения: 2177
Зарегистрирован: 19 дек 2017, 15:48
Решено: 13
Откуда: Рига
Благодарил (а): 149 раз
Поблагодарили: 231 раз

Удаление программ

Сообщение vir0id » 01 апр 2019, 17:29

FreeStyler писал(а):
01 апр 2019, 17:26
When dpkg install a package and package dependency is not satisfied, it leaves the package in unconfigured state and that package is considered as broken.
Перевод:
Когда dpkg устанавливает пакет и зависимость пакета не удовлетворяется, он(dpkg) оставляет пакет в ненастроенном состоянии, и этот пакет считается поврежденным.
vir0id писал(а):
01 апр 2019, 16:03
apt подтянет пакеты для dpkg и настроит их.
С ключем install -f, в противном случае удалит их
Последний раз редактировалось пользователем 2 vir0id; всего редактировалось раз: 1

Аватара пользователя

FreeStyler
Сообщения: 483
Зарегистрирован: 23 июл 2018, 04:58
Решено: 2
Откуда: Сиб
Благодарил (а): 519 раз
Поблагодарили: 63 раза

Удаление программ

Сообщение FreeStyler » 01 апр 2019, 17:31

colonel, лол, они на то и новички, чтобы подключать всякую шнягу!
sarcastic.gif
У вас нет необходимых прав для просмотра вложений в этом сообщении.
deadmau5 - Harmonic Mix
■ Mint 19.2 KDE (initial Xfce) @ Intel NUC Skull Canyon, i7-6770HQ, 16Gb RAM, 512Gb SSD M2, Iris Graphics 580
■ KDE Neon (Ubuntu 18.04) @ Lenovo V110 15ISK, i3-6006u, 8Gb RAM, 32GB SSD, 640GB HDD, HD Graphics 520

Аватара пользователя

FreeStyler
Сообщения: 483
Зарегистрирован: 23 июл 2018, 04:58
Решено: 2
Откуда: Сиб
Благодарил (а): 519 раз
Поблагодарили: 63 раза

Удаление программ

Сообщение FreeStyler » 01 апр 2019, 17:32

vir0id, суть в том, что dpkg может сделать пакет повреждённым, а apt нет -__-
deadmau5 - Harmonic Mix
■ Mint 19.2 KDE (initial Xfce) @ Intel NUC Skull Canyon, i7-6770HQ, 16Gb RAM, 512Gb SSD M2, Iris Graphics 580
■ KDE Neon (Ubuntu 18.04) @ Lenovo V110 15ISK, i3-6006u, 8Gb RAM, 32GB SSD, 640GB HDD, HD Graphics 520

Аватара пользователя

vir0id
Сообщения: 2177
Зарегистрирован: 19 дек 2017, 15:48
Решено: 13
Откуда: Рига
Благодарил (а): 149 раз
Поблагодарили: 231 раз

Удаление программ

Сообщение vir0id » 01 апр 2019, 17:34

FreeStyler писал(а):
01 апр 2019, 17:32
суть в том, что dpkg может сделать пакет повреждённым
Да нету опастности, потому что apt его контролирует. Ну умный он(apt), понимаете ли, не виноват он в этом :-D

Аватара пользователя

Dja
Сообщения: 6206
Зарегистрирован: 27 авг 2016, 17:03
Решено: 27
Откуда: Voskresensk
Благодарил (а): 918 раз
Поблагодарили: 657 раз

Удаление программ

Сообщение Dja » 02 апр 2019, 05:34

colonel писал(а):
01 апр 2019, 17:10
все остальные подключенные репозитории даже из официальных реп официальных сайтов программ не официальны установленной системе
В таком случае как я писал выше ничего скачивать не надо.

Код: Выделить всё

sudo apt install имя_пакета
и будет всем щастье
Какой смысл качать то, что прописано в apt?

Аватара пользователя

x230
Сообщения: 1660
Зарегистрирован: 02 сен 2016, 19:07
Решено: 5
Откуда: Курилы/Сахалин/Кубань
Благодарил (а): 287 раз
Поблагодарили: 420 раз

Удаление программ

Сообщение x230 » 02 апр 2019, 07:11

Dmitrii, "осиротевшие" пакеты, в результате удаления программ, хорошо вычищаются прогой deborphan (и шкура к ней - gtkorphan).
Но чтобы с ней не накосячить, надо ставить галки:
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Intel Core i3-3210 / 4GB / VGA - на борту:
1) KDE neon 5.17 / KDE Plasma 5.17.* / 5.0.0-** / Pale Moon 28.* / SlimJet 24.*
2) Linux Mint 18.3 / Cinnamon 3.6.7 / 4.15.0-52 / Pale Moon 28.* / SlimJet 23.*

Вернуться в «Вопрос новичка и FaQ»