Проблема Nvidia с Linux ядрами выше 4.8

Не знаете как установить драйвер? Возникли проблемы? Вам сюда!
Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот
Аватара пользователя

Unborn
Сообщения: 1778
Зарегистрирован: 03 сен 2016, 10:36
Решено: 24
Благодарил (а): 4 раза
Поблагодарили: 253 раза

Проблема Nvidia с Linux ядрами выше 4.8

Сообщение Unborn » 16 янв 2018, 10:44

leonm писал(а):
16 янв 2018, 07:50
попробовал я несколько драйверов из последних на чистой установке ЛМ 17.3 - результат отрицательный.
Как вы устанавливаете? Что там сложного? Загрузиться в Лайф, установить или авто или вручную, перезагрузится с nomodeset, подключиться к сети, из Менеджера установить проприетарь, перезагрузиться, убедиться, что работает, обновить систему. Велосипеды что ли изобретаете? Ну железо 100% рабочим должно быть, это уж само-собой. А ещё лучше вообще из консоли устанавливать видеодрайвер.
leonm писал(а):
16 янв 2018, 09:01
как правильно подбирать драйверы и ядра процессорам и видеокартам?
С видеокартами - на официальные сайты. Их два всего. Ну карточки SIS уж поискать серьёзно нужно.
С ЦП Интел до 4-го поколения выше 4.4 ядро не нужно. 4-го 4.4 со всеми патчами сейчас уже нормально, можно и дальше. 5-го, 6-го - с 4.10. 7-го - с 4.13

Аватара пользователя

Автор темы
leonm
Сообщения: 34
Зарегистрирован: 19 апр 2017, 13:28
Благодарил (а): 3 раза

Проблема Nvidia с Linux ядрами выше 4.8

Сообщение leonm » 22 янв 2018, 20:42

Unborn писал(а):
16 янв 2018, 10:44
Как вы устанавливаете?
Я сделал чистую установку (по дефолту грузился свободный драйвер) и на ней через штатный менеджер драйверов устанавливал, по самому простому пути. А удалял из под live CD, через chroot (поскольку в рекавери или не грузится или как-то глючит (то черный фон, то меню, то вперемешку - запаришься вводить команды)). После удаления Nvidia снова грузился со свободным драйвером, и уже ставил др. версию Nvidia.

Аватара пользователя

Unborn
Сообщения: 1778
Зарегистрирован: 03 сен 2016, 10:36
Решено: 24
Благодарил (а): 4 раза
Поблагодарили: 253 раза

Проблема Nvidia с Linux ядрами выше 4.8

Сообщение Unborn » 24 янв 2018, 10:22

leonm писал(а):
22 янв 2018, 20:42
После удаления Nvidia снова грузился со свободным драйвером, и уже ставил др. версию Nvidia.
Если загрузка на vesa или fbdev, то проблемы редко. А лучше вообще из консоли. Так и блоб устанавливается.
И версия драйвера должна соответствовать модели карты и ядру ОС. Старое железо с новой версией ОС и драйвера не всегда заработает, в чём ты и убедился. Установил бы 17.3 или LMDE2 и не было бы проблем.


syberdaim
Сообщения: 58
Зарегистрирован: 03 апр 2017, 09:56
Решено: 2
Благодарил (а): 2 раза
Поблагодарили: 2 раза

Проблема Nvidia с Linux ядрами выше 4.8

Сообщение syberdaim » 25 янв 2018, 04:03

Да у меня тоже были проблемы с этими драйверами. Раньше Линукс минт 18,2 стоял проблемы не было. А шас поставил минт 18,3 и не смог поставить драйвер на видеокарту никак не поставился после перезагрузки большой экран а если посмотреть в менеджер драйверов показывал нвидиа установлен. а он по умолчанию на ноувеау драйвере стоял все нормально было а хотел нвидия ставит ни как не получилос, Было не понятно что тут виноват минт 18,3 или новые ядра или новые драйвера на нвидиа. И решил по экспериминтировать и откать сделал с нового ядра назад на одно ядро и устанавливал на него нвидия драйвер И в ядре 4,14,5 установил новую нвидиа 390 драйвер не работал а потом установил нвидиа 384 работал. Вот теперь у меня почти что с новым ядром 4,14,5 и видеодрайвером нвидиа не новая но работает 384, и новым минт 18,3 все работаеть Можете у себя тоже попробовать в таком связке поставить Думаю будет работать. А так кто из них виновать я так и не нашол.

Аватара пользователя

Автор темы
leonm
Сообщения: 34
Зарегистрирован: 19 апр 2017, 13:28
Благодарил (а): 3 раза

Проблема Nvidia с Linux ядрами выше 4.8

Сообщение leonm » 30 янв 2018, 07:51

Unborn писал(а):
24 янв 2018, 10:22
Установил бы 17.3 или LMDE2 и не было бы проблем
я выше уже писал, что чистую установку 17.3 попробовал, получив отрицательный результат

Аватара пользователя

vir0id
Сообщения: 2201
Зарегистрирован: 19 дек 2017, 15:48
Решено: 13
Откуда: Рига
Благодарил (а): 149 раз
Поблагодарили: 231 раз

Проблема Nvidia с Linux ядрами выше 4.8

Сообщение vir0id » 30 янв 2018, 07:55

leonm,

Код: Выделить всё

sudo apt install dkms
reinstall драйвер????

Аватара пользователя

Автор темы
leonm
Сообщения: 34
Зарегистрирован: 19 апр 2017, 13:28
Благодарил (а): 3 раза

Проблема Nvidia с Linux ядрами выше 4.8

Сообщение leonm » 30 янв 2018, 16:58

vir0id писал(а):
30 янв 2018, 07:55
КОД: ВЫДЕЛИТЬ ВСЁ
sudo apt install dkms
reinstall драйвер????
надо было после установки через менеджер устанавливать dkms?

Аватара пользователя

vir0id
Сообщения: 2201
Зарегистрирован: 19 дек 2017, 15:48
Решено: 13
Откуда: Рига
Благодарил (а): 149 раз
Поблагодарили: 231 раз

Проблема Nvidia с Linux ядрами выше 4.8

Сообщение vir0id » 30 янв 2018, 16:59

leonm писал(а):
30 янв 2018, 16:58
надо было после установки через менеджер устанавливать dkms?
В консоле просто набрать

Аватара пользователя

Автор темы
leonm
Сообщения: 34
Зарегистрирован: 19 апр 2017, 13:28
Благодарил (а): 3 раза

Проблема Nvidia с Linux ядрами выше 4.8

Сообщение leonm » 30 янв 2018, 17:01

vir0id писал(а):
30 янв 2018, 16:59
В консоле просто набрать
про консоль, конечно, понимаю... двусмысленно вышло... спрошу иначе:
после установки нвидиа через менеджер нужно еще из консоли ставить dkms?

Аватара пользователя

vir0id
Сообщения: 2201
Зарегистрирован: 19 дек 2017, 15:48
Решено: 13
Откуда: Рига
Благодарил (а): 149 раз
Поблагодарили: 231 раз

Проблема Nvidia с Linux ядрами выше 4.8

Сообщение vir0id » 30 янв 2018, 17:02

leonm писал(а):
30 янв 2018, 17:01
ужно еще из консоли ставить dkms?
Если его нет, то нужно. И вообще, обновить систему, если не обновлена

Аватара пользователя

Автор темы
leonm
Сообщения: 34
Зарегистрирован: 19 апр 2017, 13:28
Благодарил (а): 3 раза

Проблема Nvidia с Linux ядрами выше 4.8

Сообщение leonm » 30 янв 2018, 17:05

vir0id писал(а):
30 янв 2018, 17:02
Если его нет, то нужно
Ясно, только теперь не на чем тренироваться.

Аватара пользователя

vir0id
Сообщения: 2201
Зарегистрирован: 19 дек 2017, 15:48
Решено: 13
Откуда: Рига
Благодарил (а): 149 раз
Поблагодарили: 231 раз

Проблема Nvidia с Linux ядрами выше 4.8

Сообщение vir0id » 30 янв 2018, 17:08

leonm писал(а):
30 янв 2018, 17:05
не на чем тренироваться.
В смысле не на чем?

Аватара пользователя

Автор темы
leonm
Сообщения: 34
Зарегистрирован: 19 апр 2017, 13:28
Благодарил (а): 3 раза

Проблема Nvidia с Linux ядрами выше 4.8

Сообщение leonm » 30 янв 2018, 17:19

vir0id писал(а):
30 янв 2018, 17:08
В смысле не на чем?
Человеку уже отдал комп, помогал исправить.

Вернуться в «Видеокарты»