Viber.deb - не debian пакет!

Правила форума
Как правильно задавать вопросы Правильно сформулированный вопрос и его грамотное оформление способствует высокой вероятности получения достаточно содержательного и по существу ответа. Общая рекомендация по составлению тем: 1. Версия ОС вместе с разрядностью. Пример: LM 18.1 x64, LM Sarah x32 2. DE. Если вопрос касается двух, то через запятую. (xfce, KDE, cinnamon, mate) 3. Какое железо. (достаточно вывод inxi -Fxz в спойлере (как пользоваться спойлером смотрим здесь)) или же дать ссылку на hw-probe 4. Суть. Желательно с выводом консоли, логами. 5. Скрин. Просьба указывать 1, 2 и 3 независимо от того, имеет ли это отношение к вопросу или нет. Так же не забываем об общих правилах Как пример вот

Adrian
Сообщения: 58
Зарегистрирован: 11 сен 2016, 16:54
Решено: 1
Благодарил (а): 32 раза
Поблагодарили: 15 раз

Viber.deb - не debian пакет!

Сообщение Adrian » 07 апр 2018, 11:51

Попробовал установить Viber на Linux Mint 17 Mate. Не работает.
Может версия Линукса старая?

Скачал отсюда.
https://www.viber.com/ru/download/
Ничего более подходящего, чем это, там не нашёл:
"Скачать Viber для Linux Ubuntu"

Через GDebi, как выше в теме писалось, не устанавливается. Через dpkg что-то делало, но Viber потом не запустился. Попробовал запустить его ещё и через Терминал. Выдаёт такое:

Код: Выделить всё

./Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ./Viber)
./Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by ./Viber)
./Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/lib/libQt5Location.so.5)
./Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/lib/libicui18n.so.52)
./Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/lib/libicuuc.so.52)
./Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/viber/lib/libQt5WebEngineCore.so.5)
./Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/viber/lib/libQt5Qml.so.5)
./Viber: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/lib/libQt5Core.so.5)

Аватара пользователя

Chocobo
Сообщения: 9251
Зарегистрирован: 27 авг 2016, 19:57
Решено: 200
Откуда: НН
Благодарил (а): 645 раз
Поблагодарили: 2661 раз

Viber.deb - не debian пакет!

Сообщение Chocobo » 07 апр 2018, 11:58

Adrian писал(а):
07 апр 2018, 11:51
version `GLIBCXX_3.4.20' not found
Сильно свежих зависимостей требует, которых в 17-м минте нет.
Здесь есть пара советов, как обойти это дело
Изображение
   
Изображение


Adrian
Сообщения: 58
Зарегистрирован: 11 сен 2016, 16:54
Решено: 1
Благодарил (а): 32 раза
Поблагодарили: 15 раз

Viber.deb - не debian пакет!

Сообщение Adrian » 07 апр 2018, 12:22

Попробовал 1-ый совет по ссылке. Установил старый Вайбер. Версия 4.2.2.6
Не работает. Как уже писали здесь раньше по этому поводу:
vladimir195 писал(а):
20 фев 2018, 15:41
Поставил эту версию. Ввожу номер своего телефона- пишет status custom error.


Adrian
Сообщения: 58
Зарегистрирован: 11 сен 2016, 16:54
Решено: 1
Благодарил (а): 32 раза
Поблагодарили: 15 раз

Viber.deb - не debian пакет!

Сообщение Adrian » 07 апр 2018, 12:50

Попробовал следующий совет оттуда же. Доставил вручную библиотеки из Ubuntu 16.04.
Viber работает! Новый, 7-ая версия.


Adrian
Сообщения: 58
Зарегистрирован: 11 сен 2016, 16:54
Решено: 1
Благодарил (а): 32 раза
Поблагодарили: 15 раз

Viber.deb - не debian пакет!

Сообщение Adrian » 23 июн 2018, 11:43

А это, ниже, не вопрос, а ответ. На незаданный вопрос :-) В общем, может быть, кому-то пригодится.

Как настроить размер шрифта в Viber.

Вот, к примеру, здесь, по-английски жалуются, что в Kubuntu шрифт в Вайбере слишком большой. А у меня в Linux Mint Mate, наоборот, шрифт слишком маленький.

Решение.

В ярлык запуска Вайбера, там где "Команда" (или Exec) пишем следующее.

Чтобы уменьшить
env QT_SCALE_FACTOR=0.6 /opt/viber/Viber

Увеличить
env QT_SCALE_FACTOR=1.2 /opt/viber/Viber

или более подходящее вам число.

По ссылке больше, если этого недостаточно.

Аватара пользователя

Black_Shef
Сообщения: 143
Зарегистрирован: 10 сен 2016, 05:22
Решено: 1
Благодарил (а): 12 раз
Поблагодарили: 12 раз

Viber.deb - не debian пакет!

Сообщение Black_Shef » 21 янв 2019, 11:17

Для Linux Mint 19 так и не починили DEB файл на сайте
Dja писал(а):
09 ноя 2017, 22:16
sudo dpkg -i viber.deb
dpkg: ошибка: cannot access archive 'viber.deb': Нет такого файла или каталога

пытаюсь через графическую оболочку Менеджера программ установить. Пока в процессе. Уж слишком долго

Аватара пользователя

Dja
Сообщения: 6184
Зарегистрирован: 27 авг 2016, 17:03
Решено: 27
Откуда: Voskresensk
Благодарил (а): 901 раз
Поблагодарили: 656 раз

Viber.deb - не debian пакет!

Сообщение Dja » 21 янв 2019, 11:23

Black_Shef писал(а):
21 янв 2019, 11:21
Нет такого файла или каталога
Значит находитесь не в той папке.

Аватара пользователя

Black_Shef
Сообщения: 143
Зарегистрирован: 10 сен 2016, 05:22
Решено: 1
Благодарил (а): 12 раз
Поблагодарили: 12 раз

Viber.deb - не debian пакет!

Сообщение Black_Shef » 21 янв 2019, 11:35

Через менеджер программ всё-таки установился...

Пришлось его ставить, из-за инертности людей, что хотят таким пользоваться, а перейти на нормальные мессенджеры - технически на две головы лучше, не, не хотим.

Аватара пользователя

Dja
Сообщения: 6184
Зарегистрирован: 27 авг 2016, 17:03
Решено: 27
Откуда: Voskresensk
Благодарил (а): 901 раз
Поблагодарили: 656 раз

Viber.deb - не debian пакет!

Сообщение Dja » 21 янв 2019, 11:36

Black_Shef писал(а):
21 янв 2019, 11:35
нормальные мессенджеры - технически на две головы лучше
Например?

Аватара пользователя

slant
Сообщения: 1888
Зарегистрирован: 21 июн 2017, 15:09
Решено: 31
Благодарил (а): 15 раз
Поблагодарили: 822 раза

Viber.deb - не debian пакет!

Сообщение slant » 21 янв 2019, 12:40

Black_Shef писал(а):
21 янв 2019, 11:35
Пришлось его ставить, из-за инертности людей, что хотят таким пользоваться, а перейти на нормальные мессенджеры - технически на две головы лучше, не, не хотим
Назовите пожалуйста "нормальный мессенджер" с такими параметрами:
1. Кроссплатформа: линукс, винда, андроид.
2. Видеозвонки.
3. Можно обяснить как пользоваться по телефону (без личного контакта) человеку, который практически чайник и/или в возрасте.

Аватара пользователя

Dja
Сообщения: 6184
Зарегистрирован: 27 авг 2016, 17:03
Решено: 27
Откуда: Voskresensk
Благодарил (а): 901 раз
Поблагодарили: 656 раз

Viber.deb - не debian пакет!

Сообщение Dja » 21 янв 2019, 13:09

Судя по WhatsApp сдох... Что делать? (Пост Black_Shef #73174)
там телеграм рулит ) который вобщем-то ничем не лучше, если не хуже. Он как минимум заблокирован на территории РФ.

Аватара пользователя

Black_Shef
Сообщения: 143
Зарегистрирован: 10 сен 2016, 05:22
Решено: 1
Благодарил (а): 12 раз
Поблагодарили: 12 раз

Viber.deb - не debian пакет!

Сообщение Black_Shef » 21 янв 2019, 13:24

Dja писал(а):
21 янв 2019, 13:09
Он как минимум заблокирован на территории РФ.
Да, Телеграм. И чем же он хуже ?
Заблокирован. Формально, да, но работает, Даже правительство РФ имеет оф.канал в нем.

Нет, той криворукости при установке. Устанавливай на любое кол-во устройств параллельно свой аккаунт (есть ограничение, что-то около 30 устройств), да, нужна СМС, но и на кнопочный телефон достаточно для этого, при этом вся информация полностью синхронизирована, Нет необходимости в запущенной сессии на смартфоне.

Отсутствует тот информационный мусор, что создается при использовании того вайбера. Только при установке, на смартфоне создает 1500-2000 служебных файлов. Что в них можно хранить то ?

Вайбер при сохранении истории сохраняет только текст, пультимейдиуную переписку ни в какую не хотят разработчики внедрить.

Это так, навскидку.

А, да, еще фишка телеграма - чат с самим с собой. Т.е. считай виртуальное облако, храни нужную себе информацию. Допустим какой файл или программу или что угодно другое.
Объем файла ограничен, да, 2 ГБ мало ?

Аудиосообщения, опять же, какие временные ограничения ? по сравнению с вайбером, в котором 30 сек. 2 часа аж.
slant писал(а):
21 янв 2019, 12:40
2. Видеозвонки.
Пока только на смартфоне - неофициальный клиент Vidogram, пожалуйста, уже давным давно
slant писал(а):
21 янв 2019, 12:40
3. Можно обяснить как пользоваться по телефону (без личного контакта) человеку, который практически чайник и/или в возрасте.
Ничем не отличается от вайбера или whatsapp, если не считать каналы.

Уже двоих таких перевел
 ! Сообщение из: zuzabrik
Это не чатик, если вам не отвечают свои монологи пишите правкой предыдущего поста.
Последний раз редактировалось пользователем 1 Black_Shef; всего редактировалось раз: 21

Аватара пользователя

Dja
Сообщения: 6184
Зарегистрирован: 27 авг 2016, 17:03
Решено: 27
Откуда: Voskresensk
Благодарил (а): 901 раз
Поблагодарили: 656 раз

Viber.deb - не debian пакет!

Сообщение Dja » 21 янв 2019, 13:29

кстати по ходу разблокировали )
А как быть с
slant писал(а):
21 янв 2019, 12:40
Видеозвонки
?

Аватара пользователя

Black_Shef
Сообщения: 143
Зарегистрирован: 10 сен 2016, 05:22
Решено: 1
Благодарил (а): 12 раз
Поблагодарили: 12 раз

Viber.deb - не debian пакет!

Сообщение Black_Shef » 21 янв 2019, 13:32

А куда все мои сообщения пропали кроме того большого ?

Я там всё расписал по пунктам

Аватара пользователя

Dja
Сообщения: 6184
Зарегистрирован: 27 авг 2016, 17:03
Решено: 27
Откуда: Voskresensk
Благодарил (а): 901 раз
Поблагодарили: 656 раз

Viber.deb - не debian пакет!

Сообщение Dja » 21 янв 2019, 13:36

Большое и есть объединение трех :hoho: :magic:

Аватара пользователя

Black_Shef
Сообщения: 143
Зарегистрирован: 10 сен 2016, 05:22
Решено: 1
Благодарил (а): 12 раз
Поблагодарили: 12 раз

Viber.deb - не debian пакет!

Сообщение Black_Shef » 21 янв 2019, 13:36

slant писал(а):
21 янв 2019, 12:40
2. Видеозвонки.
На десктопе, да, пока нет такого, но на смартфоне уже давно все это есть, НО, для этого нужно использовать неофициальный клиент, который развивается и есть в плей маркете - Vidogram, им успешно и пользуюсь. Там, есть, кстати, и вкладки, для разделения контактов, каналов, чатов....
slant писал(а):
21 янв 2019, 12:40
3. Можно обяснить как пользоваться по телефону (без личного контакта) человеку, который практически чайник и/или в возрасте.
Можно, более чем вполне. Не учитывая вникания в каналы, использование или настройки ничем не отличается от вайбера или Whatsapp. Вернее, отличаются лишь внешним видом, впрочем как сами вайбер и whatsapp друг от друга

Аватара пользователя

Dja
Сообщения: 6184
Зарегистрирован: 27 авг 2016, 17:03
Решено: 27
Откуда: Voskresensk
Благодарил (а): 901 раз
Поблагодарили: 656 раз

Viber.deb - не debian пакет!

Сообщение Dja » 21 янв 2019, 13:40

Нету. Нету там видеовызова. Только аудио.

Аватара пользователя

slant
Сообщения: 1888
Зарегистрирован: 21 июн 2017, 15:09
Решено: 31
Благодарил (а): 15 раз
Поблагодарили: 822 раза

Viber.deb - не debian пакет!

Сообщение slant » 21 янв 2019, 13:45

Black_Shef писал(а):
21 янв 2019, 13:24
Нет, той криворукости при установке. Устанавливай на любое кол-во устройств параллельно свой аккаунт (есть ограничение, что-то около 30 устройств), да, нужна СМС, но и на кнопочный телефон достаточно для этого, при этом вся информация полностью синхронизирована, Нет необходимости в запущенной сессии на смартфоне.
Две недели назад регистрировался в телеграмме сам, и заводил себе клиент на компе - ничего подобного. Нужна именно запущенная сессия клиента на смартфоне, без этого десктоп не подключить никак. Если раньше было по другому - уже поменяли. Процесс 1 в 1 как вайбере, не лучше и не хуже.
А вот видеозвонков я там не нашел.
Black_Shef писал(а):
21 янв 2019, 13:36
На десктопе, да, пока нет такого,
Когда будет, тогда и рекламируйте как превосходящий по всем статьям. А сейчас - не подходит.
Black_Shef писал(а):
21 янв 2019, 13:36
НО, для этого нужно использовать неофициальный клиент, который развивается и есть в плей маркете - Vidogram, им успешно и пользуюсь.
Пользуйтесь на здоровье, а я подожду официальной поддержки. А то знаете как с этими неофициальными клиентами - сегодня оно есть, а завтра автору надоело, или с официальными разработчиками поругались и их отключили.
Black_Shef писал(а):
21 янв 2019, 13:36
Вернее, отличаются лишь внешним видом, впрочем как сами вайбер и whatsapp друг от друга
whatsapp тоже видеозвонки не умеет.

Аватара пользователя

zuzabrik
Сообщения: 1635
Зарегистрирован: 29 авг 2016, 09:08
Решено: 19
Благодарил (а): 103 раза
Поблагодарили: 510 раз

Viber.deb - не debian пакет!

Сообщение zuzabrik » 21 янв 2019, 13:46

Раньше была по сути только ICQ и я ей пользовался. Сейчас десятки мессенджеров, и я не пользуюсь ни одним из них, потому что не хочу плодить долбаный зоопарк на все случаи жизни. Все равно что иметь десятки браузеров для десятков сегментов интернета.
Наш IRC-канал для общения: #linuxmint-ru на сервере irc.spotchat.org
Для захода откройте HexChat, выберите сервер Linux Mint и наберите в чате /join #linuxmint-ru
Или любым другим удобным способом ;)

Аватара пользователя

Dja
Сообщения: 6184
Зарегистрирован: 27 авг 2016, 17:03
Решено: 27
Откуда: Voskresensk
Благодарил (а): 901 раз
Поблагодарили: 656 раз

Viber.deb - не debian пакет!

Сообщение Dja » 21 янв 2019, 13:56

slant писал(а):
21 янв 2019, 13:45
whatsapp тоже видеозвонки не умеет
Смартовский умеет.

Вернуться в «Иное программное обеспечение»