✓ Решено Установка Retropie в LMDE2

Аватара пользователя
wanoska
Сообщения: 105
Зарегистрирован: 17 окт 2016, 15:36
Решено: 2
Откуда: Кинешма
Благодарил (а): 21 раз
Поблагодарили: 24 раза
Контактная информация:

Установка Retropie в LMDE2

Сообщение #1 wanoska » 06 июл 2017, 19:20

Всем привет, возникла хотелка поставить Retropie https://retropie.org.uk/docs/RetroPie-U ... l-retropie, но при запуске скрипта ./retropie_setup.sh он говорит хочу mint выше 17, проверка прописана в criptmodules/system.sh но как ее поменять что бы и lmde2 кушал? вот архив
RetroPie-Setup-master.zip
(1.65 МБ) 2 скачивания

Решение wanoska » 06 июл 2017, 20:17
цитата с оф сайта, надо блин документацию до конца читать Ваньке :-D
► Показать

Перейти к ответу ➙
LM18.2 Cinnamon 3.2.7 Kernel: 4.12.0-041200-generic

Аватара пользователя
di_mok
Сообщения: 1690
Зарегистрирован: 27 авг 2016, 19:06
Решено: 13
Откуда: Арзамас
Благодарил (а): 481 раз
Поблагодарили: 277 раз
Контактная информация:

Установка Retropie в LMDE2

Сообщение #2 di_mok » 06 июл 2017, 19:38

Тупейший способ - заменить строку error="You need Linux Mint 17 or newer" на __os_debian_ver="8", но проверить сейчас не могу
Настоящая водка — это не пьянство, а ключ к своей совести, с нее-то и начинается настоящая мудрость. (c)

В сети
Аватара пользователя
Chocobo
Сообщения: 3995
Зарегистрирован: 27 авг 2016, 22:57
Решено: 96
Откуда: НН
Благодарил (а): 347 раз
Поблагодарили: 1051 раз
Контактная информация:

Установка Retropie в LMDE2

Сообщение #3 Chocobo » 06 июл 2017, 19:41

di_mok, Ага должно сработать.

Или поставить в той же проверке lt 2 в 114 строке:

Код: Выделить всё

LinuxMint)
            if compareVersions "$__os_release" lt 2; then
                error="You need Linux Mint 17 or newer"


Тогда бетси, со своей второй версией пройдет проверку)
Изображение

Аватара пользователя
wanoska
Сообщения: 105
Зарегистрирован: 17 окт 2016, 15:36
Решено: 2
Откуда: Кинешма
Благодарил (а): 21 раз
Поблагодарили: 24 раза
Контактная информация:

Установка Retropie в LMDE2

Сообщение #4 wanoska » 06 июл 2017, 20:17

цитата с оф сайта, надо блин документацию до конца читать Ваньке :-D
► Показать
LM18.2 Cinnamon 3.2.7 Kernel: 4.12.0-041200-generic

Аватара пользователя
di_mok
Сообщения: 1690
Зарегистрирован: 27 авг 2016, 19:06
Решено: 13
Откуда: Арзамас
Благодарил (а): 481 раз
Поблагодарили: 277 раз
Контактная информация:

Установка Retropie в LMDE2

Сообщение #5 di_mok » 06 июл 2017, 20:41

:lol:
Настоящая водка — это не пьянство, а ключ к своей совести, с нее-то и начинается настоящая мудрость. (c)

В сети
Аватара пользователя
Chocobo
Сообщения: 3995
Зарегистрирован: 27 авг 2016, 22:57
Решено: 96
Откуда: НН
Благодарил (а): 347 раз
Поблагодарили: 1051 раз
Контактная информация:

Установка Retropie в LMDE2

Сообщение #6 Chocobo » 06 июл 2017, 20:43

di_mok, в яблочко :ok:
Изображение

Аватара пользователя
di_mok
Сообщения: 1690
Зарегистрирован: 27 авг 2016, 19:06
Решено: 13
Откуда: Арзамас
Благодарил (а): 481 раз
Поблагодарили: 277 раз
Контактная информация:

Установка Retropie в LMDE2

Сообщение #7 di_mok » 06 июл 2017, 20:45

Chocobo, ты на днях баш помянул :-D
Настоящая водка — это не пьянство, а ключ к своей совести, с нее-то и начинается настоящая мудрость. (c)


Вернуться в «Linux Mint Debian Edition»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость